3 Replies Latest reply: Feb 15, 2007 3:36 PM by Klaus1
DYmac Level 1 Level 1 (0 points)
Okay... I am a bit of a dunce when it comes to the techy stuff with macs...

I have a problem with my iMac G5 running 10.4.8
After I was forced to do a hard restart when the system would not shut down one night, I got:

/etc/master.passwd: no such file or directory

...on a black screen. Did a search for this in the forums and found this article and followed the directions:

http://docs.info.apple.com/article.html?artnum=106908

Which seemed to work... Then I could then proceed to the "starting up OSX" screen with the blue progress bar... and there it stays! I threw in the install disk and ran disk utility, fixed the permissions [of which there were a few to fix] and tried to restart, No luck. Now the disk is stuck in there too....

HELP!

iMac G5   Mac OS X (10.4.8)   2Ghz
  • MGW Level 7 Level 7 (27,020 points)
    Welcome to Discussions - Take a look at this from Apple, it has more suggestions. To get the disk out, try rebooting holding down your mouse button, or lay your machine face down on a towel and press the eject button on the keyboard. You should also reset your SMU and your PRAM.

    Please post back with results,

    Miriam
  • DYmac Level 1 Level 1 (0 points)
    Thanks Miriam,

    Got the disk out, thanks.

    Worked my way through every applicable step in the article you sent, as well as resetting the PRAM and the SMU. No luck at all.
    It still makes it to the Mac OS X silver square logo on the blue background, the progress meter kind of slowishly moves to the end with "Starting Mac OS X" underneath... and then nothing...

    D
  • Klaus1 Level 8 Level 8 (45,510 points)
    You may possibly find this article from Macfixit helpful:

    iMac G5: Fails to startup

    Some users are reporting an issue where iMac G5s fail to properly startup -- apparently at a hardware level -- never reaching the Mac OS X startup splash screen (Apple logo with a spinning progress indicator).
    MacFixIt reader Michael Connors writes:
    "We have several older G5 iMacs, probably upwards to about a dozen of them that have taken to not starting up. What is happening now is they will not power up with the power button. The only way in some cases to start them up is to unplug the power cord and then plug it back it back in. In this case, you might be able to get it power up. In many cases, this will not work. Following Apple's own documentation, resetting the SMU via the logic board will not resolve the issue."
    We are attempting to determine whether or not this is an issue endemic to certain iMac G5s. In the meantime, a few workarounds may be of help. [Note that in cases where the system does reach the Mac OS X startup splash screen or further progression but stalls, software issues may be to blame.]
    Potential fixes
    Disconnect external devices External devices -- especially those that draw power from the system -- can cause issues with startup that manifest either at the beginning of or later in the boot process. Try temporarily any external FireWire or USB devices then re-attempt startup and check for persistence of the issue.
    Reset SMU Although this workaround was not successful in Connors' case, resetting the iMac G5's SMU (system management unit) as described in Apple Knowledge Base article HYPERLINK "http://docs.info.apple.com/article.html?artnum=301733"#301733 can resolve a variety of power-related problems, including sudden-onset startup failure.
    Check power cables Check your power cord for a loose connection. As noted in the aforementioned reader case, unplugging and re-plugging the power cord can sometimes result in a successful startup -- likely the result of a more snug fit.
    Also, power cables can become defective or ship in such a state. Try exchanging the power cable from a problematic machine with a system that starts up properly to eliminate this as a potential cause.