5 Replies Latest reply: Feb 19, 2007 8:57 PM by mona-lisa
sirslabknit Level 1 (0 points)
I am trying to get a MightyMouse working with my MacBook Pro.I am using "Bluetooth Setup Assisant" and selecting "Mouse".

I cannot get it to find the mouse (except it does when switching the mouse off and on with its switch).

Then it says "The computer will use an empty passkey to pair with your device if possible"

Then it simply hangs for minutes with a message "Connecting to 00-14-51-etc" which I guess is the hardware id of the mouse.

Resart the application. Same result.

Batteries and mouse are new. But take out batteries and re-insert. Same problem.

Shutdown and restart the Macbook Pro. Same problem.

Try with power cable connected and not connected. Same problem.

Now I've got something new which I have not seen before.

There is a message that comes up in Bluetooth Setup Assistant which toggles every couple of seconds with the standard Welcome message and says "Appropriate Bluetooth hardware or software was not found on this computer". Also when you click the Bluetooth icon it sometimes shows the normal expected options. Do it again, a message "Bluetooth: Not Available" is given.

My thought is that I have got a hardware or operating system fault. The thought of re-installing the OS doesn't appeal since I will probably lose all my setups, files and everything.

My supplier says "Reinstall OS" which sounds like a get-out.

Incidentally I also have a Macbook which works perfectly.

I have 2 Mighty Mouses. Both work fine on the Macbook. Neither works on the Macbook Pro.

Both have up-to-date software.

I wonder has anyone else had this problem? And have they solved it?

Macbook Pro   Mac OS X (10.4.8)  

Macbook Pro, Mac OS X (10.4.8)