Previous 1 2 Next 15 Replies Latest reply: Jun 16, 2007 3:14 PM by bwadma
Jim Humphrey Level 2 (155 points)
I wanted to post this because I read all the posts before calling Apple Tech Support. I spent 2 to 2.5 hours on the phone over 3 calls and they could never get it to work correctly. My 4th call, I waited 1 hour and never got help, so I just hung up, couldn't wait any longer.

So here goes. If anyone has any ideas, let me know but I think the software in this box-AEn is screwed up.

5 computers, 1 Windows XP Pro sevice Pack 2, D-Link AirPlus DWL-650+ (B) card, 1 G5 Dual 2GHZ, running OS 10.4.8 Wireless card (G), 1 Powerbook G4, wireless card (G), running OS 10.3.9, Powerbook G4 1GHZ, running 10.4.8, 1 old iMac no card just Ethernet wired, running 10.3.9. All computers are up to date with repect to their operating systems and all dirivers are up to date.

Note: I have tried the AEn on channel 6 as well as Auto in many differnt combinations by myself and with Tech Support. We even went as far as, in Preferences, throwing away the System Configuratiion Folder and in Key Chain Access (in the Utilities folder) throwing away all references to Airport Internet connections. All computers will connect as WIRED ethernet no problem at all, Windows and Macs.

The Problems:

If I set my network to WEP; my G5 wirelessly connects no problem, my Windows XP connects no problem, but my 2 Powerbook G4's do not. When I go to connect to the network they both show the login box as WPA and ask for a WPA Password (even thought it's set to WEP) and it does not give any option to change it to WEP, so it will not accept my 13 character password. But if I go up to the menu and instead of trying to log into my Network that's listed, I go to "Other" which is just below my network in the list, I do get the opportunity to pull down to my saved network and set the encryption to WEP. I then can sign on with the 2 Powerbooks. The only problem is when I shut off the computers, since it's not stored in my keychain, when I start my computer again I have to manually go through this entire process to get logged in each time.

Now if I set my network to WPA Personal as is recommended; all my Macs will log in correctly even after shutting down the computers. The only problem is now I can't get the Windows XP computer to log into the network. It's kinda the same problem in reverse. The Windows machine can see the network, but when I go to connect, it doesn't even ask for a Password. It just won't connect.

I have tried: WEP, Shared, WPA (TKIP), WPA-PSK to connect up to WPA Personal from the AEn with no luck. Each time I have restarted the computer when deleting a preferred network to make sure it's out, then restarting and creating a new one manually.

Also depending on the settng that I choose the in the Windows computer, the signal strength is different. If I start my computer with no preferred network listed (created) the signal strength is 0 = Zero and the computer will not even try to log in. Although it does see my network name, it just says the signal strenght is zero. If I create a preferred network in my Windows computer as WEP it say the signal strength is 2 bars. And if I create a preferred network on the Windows machine that is WPA it sees the network and says it's 4 bars and is at full strength.

So, if I try to log in to a WEP encrypted AEn from the XP machine, I can get in under WEP but if I try to log into a WPA encrypted AEn it won't and I don't even get a Password field to put the password in. It's as if it doesn't know there is a Password needed.

So I can either, have WEP in the AEn and have to login each time manually with the Mac Laptops or go to WPA Personal on the AEn and not have the Windows XP be wireless.

As I said they all work perfectly on Wired Ethernet.

One last thing, and I stated this as a reply in another posting, I can no longer see any of the computers through Network (on the left side of a folder window) The only thing that works is, the Powerbook G4 running 10.3.9 can see the G5 running 10.4.8. That's it. My G5 network window takes 5 to 10 minutes to show anything sometimes.

And yes, PRAM has been zapped many times on the Macs.

As I said in my other posting, I'm not sure Networking is Apples best suit.

G5 Dual 2 GHz, Mac OS X (10.4)
  • Smokerz Level 6 (9,410 points)
    hey both show the login box as WPA and ask for a WPA Password (even thought it's set to WEP) and it does not give any option to change it to WEP, so it will not accept my 13 character password.

    I had a similar issue but I did type in my WEP password and it was accepted. Did you in fact type yours in or did you just think that I don't see a WEP drop down menu?
  • Jim Humphrey Level 2 (155 points)
    Yes I did try to put in the password, each time I got the box anyway. I even tried it several times while on the phone with Apple. No go. It doesn't work.

    You must have been lucky.

    thanks for the suggestion.
  • John Reinhold Level 1 (140 points)
    Does (b) even support WPA?

    I am not sure you can use WPA with the (b) only wireless card.

    I have 3 Macs, a Wii, a Tivo, and a Dell all (g) and working using WPA2.
  • Gino Cerullo Level 4 (1,445 points)
    Jim, it sounds like if you can get WPA Personal to work in Windows XP all your problems will be solved so here's something you can try to that end.

    Make sure you've downloaded and installed the latest drivers (v3.07 is the latest) for the AirPlus DWL-650+ card from the D-link web site.

    In Windows XP go to the properties panel for the Wireless Network Connection. At the top of that panel you'll see a checkbox next to where it says 'Use Windows to configure my wireless network connection. Make sure that is off (unchecked). Click PK to close the panel.

    Now double click on the bar graph icon in the system tray. The D-link AirPlus connection panel should open. Enter the information for your wireless network including the WPA password and see if you can connect.
  • Duane Level 10 (118,975 points)
    I am not sure you can use WPA with the (b) only wireless card.

    Yes you can. See KB 107795, AirPort Card: When You Can Join a WPA Network.
  • John Reinhold Level 1 (140 points)
    OK, so it is possible. But that KB is for Macs, and the OP had a (b) card on Windows. So I guess it depends on the drivers for that particular card.

  • Jim Humphrey Level 2 (155 points)
    Thanks Gino for the fine suggestion. I did try it but it did not work. When I set it up directly through D-link and turned off using Windows to configure my wireless settings, D-link couldn't find the network at all. When I get to the part, The View Available Wireless Networks window shows no networks at all (and I have about 6 all around me), accept to say info about configuring Windows to do the set up.

    I even went through the entire process: My Computer/Manage/Services & Applications/Services/Wireless Zero Configuration / the Restart to turn off having Windows confgiure. As suggested in the D-link website FAQ's = If still having trouble connecting to Windows XP service pack 2.

    I did uninstall and reinstall the 3.07 version of the software just to make sure before I started any of this.

    The only way I could get the network to show up is to set up a Preferred Network in windows. The D-link will not find it on it's own. I tried all the combinations of encryption through D-link software.

    I'm about to give up. I've spent 3 days on this. This is really bad.

    Thanks again for your help.
  • Gino Cerullo Level 4 (1,445 points)
    I have one last idea, it's a bit tedious but it did work for someone else who was having trouble with Windows and it may work for you.

    Connect to the base station using AirPort Admin and go into manual configuration mode (Command L). On the 'Wireless' configuration screen select each channel one-at-a-time, clicking the 'Update' button between each one and see if your Windows machine will see the wireless network.
  • Jim Humphrey Level 2 (155 points)

    I'll try this later tonight. the channels were set to Automatic when I tried this and mine was on channel 10 because the Summary page tells you the channel. I made sure the D-link was set to 10 when I went into it's software, by selecting my network and then updating, recanning the network. It then changed to 10 to match.

    But I will go through these as you suggest. The D-link seems to want to be channel 6 from looking at everthing although it will accept all channels.

    P.S. For the person asking if my card accepts WPA, yes it does, also WPA-PSK where you can put your password in. The Card has WEP, WPA, WPA-PSK.

    Thanks, for all your help.
  • Killko Caballero Level 1 (10 points)
    I had a similar problem. I set my network to 802.11n at 2.4Ghz and tried to log in using WPA from my PC, which didn't work.

    It seems that MS has some problems supporting some changes in the std regarding WPA.

    I downloaded a Windows XP freware called "Network Magic" and used that to manage my wireless connection instead of Windows XP's. This worked like charm!
  • Jim Humphrey Level 2 (155 points)
    Thanks for all the great suggestions. I've decided to just go get a G card for the windows machine and see if that works.

    Thanks again,

  • NJBarnes Level 1 (25 points)
    Jim you're not alone - but I can't assist either. I have an iMac 20" Intel, an Intel MacBook and an old G4 iMac (802.11b). I understand that the old G4 Airport card doesn't do WPA so I stayed with WEP. However everytime I fire up any of the machines the airport connection isn't activated. Clicking on the network name only gives me the chance to input a WPA password and not the WEP. Argh! So like you I have to go the "Other" network route, and this way it doesn't helpfully store the password in the Keychain.

    Airport is such a great product, but this is really frustrating. Can anyone out there help?

  • levytv Level 1 (20 points)
    i bought an linksys n usb external WUSB300N for my toshiba qosmio laptop and its running very well.
  • Xenious Level 1 (15 points)
    Same problem here. I setup my network to WEP b/g/n and my G5 and iMac keep seeing it as a WPA network. My other gear (Win XP laptop, PS3, Wii, DSs) seem to handle it just fine. It is like there is a bug in OSX that sees it as WPA instead of plain WEP. Either that or something the base station is advertising is incorrectly going out as WPA.

    I guess there aren't a lot of complaints because really WEP is not great security, but I keep it that way to be easy for other consumer electronics gear to join.
Previous 1 2 Next