7 Replies Latest reply: Mar 17, 2007 7:25 PM by Devin Crutcher
Peter Bodik1 Level 1 Level 1 (30 points)
I bought an external SATA drive, put it into an enclosure, and connected to my laptop. OS X said, "can't recognize drive that you connected; do you want to initialize?" I said yes and it opened the Disk utility, but apparently I tried to partition it before initializing. I got a read/write error.

Now the disk won't show up in Disk utility even though it shows up in System profiler under "USB High-Speed Bus" as "USB to ATA/ATAPI Bridge". This is what it says:

USB to ATA/ATAPI Bridge:

Version: 1.00
Bus Power (mA): 500
Speed: Up to 480 Mb/sec
Manufacturer: JMicron
Product ID: 0x2338
Serial Number: 152D203380B6
Vendor ID: 0x152d

Any suggestions on how to get it to work?

Thanks,
Peter

MacBook Pro, Mac OS X (10.4.9)
  • 1. Re: OS X won't recognize external drive
    Justin William Smith Level 1 Level 1 (10 points)
    You may just have the same issue a bunch of us are having with external drives following the 10.4.9 update now. Boot off your install DVD and THEN attach the USB enclosure with the disk in it, from the Utilities menu on the DVD choose Disk Utility and see if it shows up there. If it does then I'd say revert your system back to 10.4.8 by doing an archive and install restore on your MacBook Pro and keep 10.4.8 until Apple releases a patch.
  • 2. Re: OS X won't recognize external drive
    jthomasfl Level 1 Level 1 (5 points)
    Coincidentally, since I performed the 10.4.0 update yesterday, my external 400 GB Seagate USB/Firewire drive doesn't mount either. I've tried changing ports and cables. I've reinstalled the os update manually. I've tried to follow earlier advice vis-a-vis going to Disk Utility, etc. The drive does show up in the left pane of Disk Utility, but when I select it the buttons to repair, etc., remain grayed out. The only choices available to me are within the tabs to erase, partition, RAID, restore. The funtions within First Aid is completely grayed out.

    I really don't want to lose the data on that back up drive. I have a hard time believing that the drive sponteneously corrupted without help from the update. Oh, and my iPod doesn't sync now either. My 80 frigin' GB iPod is getting a "can't read to or from this disk" error message! Right now I'm pretty upset. I've tried restoring it, but it keeps crashing mid-sync with the same error message. All of these problems occurred immediately following the update.

    If anyone has a new suggestion on how to recover from these problems, please let me know.
  • 3. Re: OS X won't recognize external drive
    markorth Level 1 Level 1 (0 points)
    Judging by all of the issues that have cropped up since the 10.4.9 update it seems that it requires attention from Apple. Has this ever happened before?
  • 4. Re: OS X won't recognize external drive
    jthomasfl Level 1 Level 1 (5 points)
    No, I've never had a problem. All of my equipment/software is relatively new, i.e., 3-4 months old. I totally associate all the problems with the update alone.

    Thanks for your help.

    Jamie
  • 5. Re: OS X won't recognize external drive
    markorth Level 1 Level 1 (0 points)
    I just downloaded the Combo Updater for Mac OSX 10.4.9 and it seems to have worked, all is back to normal.

    Get it here: http://www.apple.com/support/downloads/macosx1049comboupdateppc.html

    Disconnect all of your external devices before doing the update and then reconnect 1 by 1.

    I am happy again!
  • 6. Re: OS X won't recognize external drive
    jthomasfl Level 1 Level 1 (5 points)
    (Sorry about the cross-posting, but I discussed this issue in several threads.)

    I promised to report the results of my call to AppleCare regarding my non-functioning external drives since the update to 10.4.9. My Seagate external hard drive is still toast, but my iPod is back.

    During nearly two hours with a fantastically patient product specialist (Robert) who helped me, here are the steps we went through in an attempt to troubleshoot the external hard drive. While it didn't bring back the hard drive, it did fix the freeze/can't read-write to disk/can't eject disk problem I was having with iPod (details given for those who may not be familiar with the procedures):

    1.) Boot up in safe mode -- hold down the shift key during the start up sequence. (The Seagate still received the "disk not readable" error. I'm not sure what you'd do next if you open disk utility in safe mode and your drive behaves differently.)

    2.) Reset firewire and USB ports -- completely shut down, then power up holding the apple, option, p, and r keys at the same time during start up.

    3.) Use Disk Utility from the Install Disc 1 -- Shut down. Hold the c key during start up. (Since this rendered the same problem of being able to see the drive in disk utility, but not being able to use any of the First Aid functions, the support tech said it proved that 10.4.9 wasn't the problem. To me it only proves that the update isn't currently causing the issue, but not that it didn't originally cause whatever the malfunction is with the drive at the time of the update.)

    4.) Reset the System Management Controller -- Remove all external drives from USB/Firewire ports, remove power cable, remove internal battery (if laptop). With no power source connected, hold down the on/off button for 5 seconds. The restore power source(s) and power up. If that solves the problem, you're good to go.

    If none of these methods resolve your external hard drive problems (back up drives, iPods, etc.) then you may have no choice but to try reformatting the drive. I'm not going the route yet. Robert has promised to contact me if a further solution comes down the pike. I'll let you know if I hear anything.
  • 7. Re: OS X won't recognize external drive
    Devin Crutcher Level 2 Level 2 (270 points)
    yaaay! Yeah, sometimes the combo updates are better than the consecutive ones.