7 Replies Latest reply: Mar 19, 2007 8:36 AM by philsmith_dot_com
Drew Friedman Level 1 Level 1 (10 points)
Here's the situation. My neighbors, at my suggestion, purchased a MacBook. They love the OS, but they are not able to use their wireless router. Because I suggested the Mac, I feel partly responsible to help get this working.
Here is the setup: MacBook OSX 10.4.9connnected to the linksys wrt54g connected to a speedstream modem with a DSL setup. In the router settings, I have everything setup for PPoE. It says we are connected, and have an ip address. The router settings are for PPoE, but in order to access the router, I have to set my OS network configs to DHCP. This doesn't seem right to me. And when I go do the network diagnostics, it gives me green lights all the way up through "ISP", but turns red at "internet". One last thing, the Macbook does connect through the modem if I bypass the router. I am getting very frustrated by this, and would appreciate any help.
  • Henry G4 Level 4 Level 4 (1,865 points)
    Hi.

    Read this other recent thread. It seems it's a problem with the router:

    http://discussions.apple.com/message.jspa?messageID=4246450


    MacMini G4 1.25GHz 1GB   Mac OS X (10.4.9)  
  • scapesuiter Level 7 Level 7 (27,660 points)
    I think the MacBook should be set to connect via Airport Extreme not PPoE if you are trying to connect wirelessly and the router would have to be set for 802.11b,g or n The trouble is, not all ISPs are compatible with Airport Extreme. If you are trying to connect wired, then you would have to set the MacBook to connect via Built-in Ethernet and TCP/IP using DHCP.
  • ctomer Level 1 Level 1 (35 points)
    Just to confirm that the a Linksys WRT54G should work absolutely fine with a Mac. Until recently I had one sharing my internet connection to both PCs and Macs, in both wired and wireless.
  • ctomer Level 1 Level 1 (35 points)
    Your WRT54g should not be configured for PPoE. It's the modem that should be configured for PPoE and by what you've written, it sounds like it's setup correctly.

    The WRT54g should have a configuration type of 'Automatic Configuration - DHCP'.
    You also need to make sure that the DSL modem is plugged into the WAN port on the WRT54G. Setting DHCP on all of your clients should be fine, you might run into port forwarding issues later on, but you can leave that for another day.

    Is the WRT54g successfully supplying the Macbook with an IP address?
  • Gnarlodious Level 4 Level 4 (3,225 points)
    Ctomer is right, there is no problem with the WRT router lineup but the Mac must be set to DHCP not PPOE.
  • ctomer Level 1 Level 1 (35 points)
    Ctomer is right, there is no problem with the WRT
    router lineup but the Mac must be set to DHCP not
    PPOE.

    I think he may have the Mac setup correctly already. He mentions that plugging the Mac into the DSL modem works. I'm guessing then that the DSL modem is providing his Macbook with an IP address.

    AFAIK PPOE is only used by devices that connect directly to the telephone/cable line (ADSL/DSL).

    One other thing to check is that the internet connection doesn't restrict connections for a particular MAC address. My ISP used to do this. That might explain why connecting the Mac to the DSL modem works whilst connecting the router to the DSL modem doesn't. If this is the case, then it's easy to sort out. Find the MAC address of the NIC used on the Macbook. Note it down, then use this MAC address in the WRT54g's "Clone Address" (I think that's what it's called) setting.
  • philsmith_dot_com Level 3 Level 3 (830 points)
    AFAIK PPOE is only used by devices that connect
    directly to the telephone/cable line (ADSL/DSL).


    No, PPPoE can be used anywhere, but the other devices need to be put in what's called "bridge" mode in order to pass the protocol along. If the router and the modem are all set to bridge PPPoE can be done on the Mac. But this is silly. If the modem is already set up, set the router to bridge and the Mac to DHCP.