6 Replies Latest reply: Jun 3, 2007 10:49 AM by Jeffrey Jones2
James Wilson7 Level 1 Level 1 (75 points)
I just installed 10.4.9 and then wanted to explore Inkscape v0.45 using X11 - which I've not used before. I've loaded X11 from the install disk. It opens successfully. I then double click the Inkscape icon, X11 disappears from the menu bar and the dock and the menu bar shows only the name 'Inkscape', no menu items or anything else. Can anyone tell me what I'm doing wrong here?

Thanks,

Jim

MacBook   Mac OS X (10.4.9)   Al 15" 1.25 MHz
  • 1. Re: X11 and inkscape
    Nils C. Anderson Level 4 Level 4 (3,485 points)
    Worked for me. Though, I needed to start Inkscape twice. The first time it exited, and took X11 with it.

    You might try starting the Console.app and watching the console.log. I noticed the following messages written to mine.

    (inkscape-bin:17253): Gtk-WARNING **: Locale not supported by C library.
    Using the fallback 'C' locale.
    Unable to find: FullScreen

    ** (inkscape-bin:17253): WARNING **: Unknown verb name: FullScreen
    Unable to find: FullScreen
  • 2. Re: X11 and inkscape
    James Wilson7 Level 1 Level 1 (75 points)
    Nils,

    Thanks for the response. Started Inkscape three times and each time got this back in the Console:

    bash: no job control in this shell
    dyld: Library not loaded: /usr/X11R6/lib/libfreetype.6.dylib
    Referenced from: /Applications/Inkscape.app/Contents/Resources/bin/inkscape-bin
    Reason: no suitable image found. Did find:
    /usr/X11R6/lib/libfreetype.6.dylib: mach-o, but wrong architecture
    Mar 21 20:40:36 James-Wilsons-book crashdump[12933]: inkscape-bin crashed
    Mar 21 20:40:36 James-Wilsons-book crashdump[12933]: crash report written to: /Users/jameswilson/Library/Logs/CrashReporter/inkscape-bin.crash.log

    I can kind of figure out the problem, but have no idea what to do about it. Can you help?

    Thanks,

    Jim

    MacBook   Mac OS X (10.4.9)   Al 15" 1.25 MHz
  • 3. Re: X11 and inkscape
    James Wilson7 Level 1 Level 1 (75 points)
    Well, an update for X11 just showed up on Apple software update. Loaded that and up came Inkscape.
  • 4. Re: X11 and inkscape
    Alan Hall Level 1 Level 1 (0 points)
    I'm struggling with the same problem. Here's my console script:

    /Applications/Inkscape.app/Contents/Resources/script: line 17: open-x11: command not found
    2007-06-02 18:50:21.422 open[260] Couldn't open file: /tmp/getdisplay.sh

    Here is some copy from a blog review of Inkscape, which looks great btw.
    http://mikesalsbury.com/mambo/content/view/231/1/

    Installation of Inkscape was slightly more complicated. The test system didn’t get built with Apple X11 by default, so I had to install that and reboot before installing Inkscape. Inkscape itself also seemed to have some problems getting started. I had to launch and quit it a couple of times before it finally came up. To be fair, when the application seemed to hang on a subsequent launch, it was clear from the Activity Monitor that X11 was the one having a real problem coming up, so I don’t think Inkscape was at fault. After killing X11 from the command line and rebooting the system, Inkscape came up in only a couple of seconds. I haven't seen this X11 issue since that first attempted launch, so I'm pointing a finger at X11 or a previously-opened X11 application on that machine.

    Once up and running, Inkscape was very nearly as fast as a native Mac OS X application (i.e., I think I detected a very minuscule delay but it never bothered me). In fact, if I regularly used the Macintosh, I’d have no problems at all working with Inkscape on a regular basis. It performed well, was perfectly stable (aside from the X11 issue above that I don’t think is Inkscape’s fault), and never crashed or generated an unexpected error during operation.

    New to this debugging thing. Any help will be delighful!
    Thanks,
    Alan
  • 5. Re: X11 and inkscape
    Alan Hall Level 1 Level 1 (0 points)
    After studying this awhile, it appears I have made a series of errors.
    My mac is about three years old, and came with OS 10.4.0, and so that is the version of X11 I started with. I'm running 10.4.9 now.
    After downloading Inkscape, I found the X11 install package in Spotlight and ran it. It appeared to install, but I never found an X11 app icon. Is there such a thing? I have never been able to launch X11 as far as I can tell. Inkscape won't launch as a result.
    I restarted, and then downloaded X11 from Apple. I think it was this one:
    http://www.apple.com/downloads/macosx/apple/macosx_updates/x11update2006113.html
    It would not install, saying I already had X11 on my hard disk. I trashed everything I could find named X11, restarted, and tried again. No luck.
    I read that I have to run an uninstall script in my terminal window to clear the files, and then I read other instructions that don't mention a need to uninstall.
    I am pretty close to giving up, as I don't have time to learn programming, and Leopard is in the wings. I guess the $45 bucks for Manga Studio doesn't look so bad.

    Alan
  • 6. Re: X11 and inkscape
    Jeffrey Jones2 Level 6 Level 6 (8,510 points)
    Alan Hall-

    Install X11 using the "Optional Installs" package on your Tiger DVD. It will put X11.app into /Applications/Utilities. After it is installed, you can update it with "X11 Update 2006 1.1.3".

    - Don't search the DVD for an "X11" package, since you will inevitably find the wrong one. Use the package named "Optional Installs".

    - Don't download X11 from Apple. Use the one on your 10.4 DVD. The one on Apple's download site is for Panther only. You can download the updater that you referenced in your post after X11 is installed.