3 Replies Latest reply: Apr 11, 2007 11:40 AM by Cassidy Knight
Cassidy Knight Level 1 (40 points)
I had Final Cut Studio 5.1 intalled on my Powerbook G4. Then, my computer was sent in and I was without for a month. So while it was away, I put Final Cut Pro on my home computer to finish my film for school. When I got my laptop back, I tried uninstalling Final Cut Pro on my home computer, but didn't have the installation disk, so I just simply trashed the 'Final Cut Studio System ID' on my home computer so that I couldn't use the program.

So, now Final Cut works fine on my Powerbook. But, I accidently updated to 5.1.4 - while my school computers are still on 5.1.2. So I wanted to uninstall Final Cut, and then re-install it so that the applications would be compatable. But, when I insert my Final Cut Studio Installation Disk, it asks for my serial number, which I put in - but the 'Continue' button never lights up.

I also went to the website to register my product so that I could download the 5.1.2 update...entered my serial number and it told me it was an invalid number.

I'm entering the exact same number in the exact same way that I originally did on my Powerbook. Is there anything I can do? The only time the serial number has ever been on another computer before was when it was on my home computer, but I hadn't registered it, and then I removed it - so my laptop is the only computer I have Final Cut on. Why isn't this working? It's quite frustrating when I need an edit for my class tomorrow and I can't work on it.

Thank you for any help, suggestions, or support.

1.67 GHz PowerBook G4, Mac OS X (10.4.9)
  • Bengt Wärleby Level 6 (19,450 points)
    Hi Cassidy

    To my mind comes two thoughts.

    a. There are several serial no.
    - one that came with You first purchase
    - one that came with the updates.
    It is important to enter the right one

    b. My FCP didn't just want the serial no. but all three lines to be entered
    and they have (I think !! I !!) to be very exact as You entered first time.

    Ps Most irritated on that when switching booth drive it asks for "Registring"
    every time. I doesn't help to connect and register, after next switch it's
    time to register again. Very annoying. Can't buy a version for each hard disk
    (ONLY Using ONE and the same Mac)

    Yours Bengt W
  • Tom T. Level 4 (1,760 points)
    Cassidy, I believe the FCP license allows for installation of the same serial # on a laptop and a tower, as long as both are yours, so you didn't have to trash the home computer installation.

    Check to make sure you're not entering the letter O instead of a zero, or vice versa.
  • Cassidy Knight Level 1 (40 points)
    That's good to know, thank you very much. I was wanting to use it on my G5 this Summer (same one I installed it in before).

    I'm entering the fields exactly as I had originally entered them, and I'm using the right letter/number (O/0 or I/1) when applicable. But it still won't let me continue.

    I even trashed the 'Final Cut Studio System ID' on my PowerBook, then opened Final Cut, it asked me for the serial number - I entered it, exactly as I had been trying with the disk, and it worked. But it still won't work on the installation disk.

    Also, I did a bit of editing on the PowerBook (5.1.4) and then moved to my school's computers (5.1.2) expecting them not to be able to open the file, but it did. I know that 5.1 and 5.1.1 weren't compatable with 5.1.2, so how is 5.1.2 compatable with 5.1.4? Regardless, this is good news.