6 Replies Latest reply: Apr 16, 2007 6:28 PM by Kappy
Penguhwin Level 1 Level 1 (0 points)
Hi,
After disconnecting it the other day, I'm having a problem with my external firewire drive. I can't copy SOME files from my Mac drive to it without getting "...some data could not be read or writter [Error code -36]), nor can I download to it. If I create an empty folder, or make a small text file, that seems to copy over - so maybe it's a file size problem?

The thing is, I don't think the external drive's bad (or my Mac HD, for that matter). All the data reads fine, and everything checks out fine through disc utility. I fixed permissions on everything (twice), and swapped my firewire cable for another - made no difference. I played around with disc permissions on the "get info" box, and thought I'd found the problem when "Group" was set to "read" instead of "read & write" - but I changed that, rebooted, and it made no difference at all.

Any suggestions?

iMac 17" Intel, Mac OS X (10.4.9), 1 Meg memory.
  • Kappy Level 10 Level 10 (255,410 points)
    How is the drive formatted? If it's MS-DOS then the error probably means you are trying to copy a file with a bad or illegal or too long filename.
  • Penguhwin Level 1 Level 1 (0 points)
    I just tried rebuilding permissions by running disc utility from the install disc. It fixed a few things, but made no difference.

    One more thing - if I "get info" in my Mac HD and go to change ownership & permissions (even not changing anything) then click on "apply to enclosed items" I get a finder error message that says: "the finder cannot complete the operation because some data in Macintosh HD could not be read or written - error code -36"...

    Maybe I'm dealing with a corrupt OS here?
  • Penguhwin Level 1 Level 1 (0 points)
    Thanks for responding. My external drive is partioned into two halves, both formatted for Mac. I've been using it for years without problem.

    Now THIS is strange... I just tried copying a folder full of stuff from my desktop onto the 2nd partition of the external... and it worked! -- but the SAME folder won't copy to the 1st partition, even though both partitions have the exact same permissions set, and disc utility reads no errors... now I'm REALLY stumped...

    :-O!
  • Kappy Level 10 Level 10 (255,410 points)
    Repairing permissions is a waste of time because whatever your problem is changing permissions won't do a thing. What you want to try is repairing the drive (each volume) using Disk Utility. You may need to do the same for your startup volume (which will require booting from your OS X Installer Disc.)
  • Penguhwin Level 1 Level 1 (0 points)
    That's what confuses me - I did that (booting from the OS X Installer disc), and there were no errors found on any of the discs. It sounds like the VTOC on one of the external partitions got screwed up somehow - but disc utility reads everything as fine, when everything is obviously not fine...
  • Kappy Level 10 Level 10 (255,410 points)
    It's quite possible that although the hard drive is OK you may have corrupted files on the drive. DU does not detect nor repair bad files.

    You might use the Console app (Utilities folder) and inspect the console, system, and crash logs to see if any information in the logs give insight to the specific cause of the problem.

    If you have a utility such as TinkerTool System you can also try cleaning out cache, log, and temporary files in case there's a corrupted file involved.

    If you know the specific file generating the error, then try transferring it singly.