5 Replies Latest reply: May 14, 2007 5:05 AM by Stephen Webb1
Alcanara Level 1 Level 1 (0 points)
I have successfully installed and used Vodafone Mobile Direct (v2.06.05 the latest for mac) on my MacBook Pro, Using 10.4.9. This is connected via a Vodafone USB modem.

It would not load one day and I got the message:-

An exception of Nilobjectexception was not handled. The Application must shut down.

I have uninstalled and reinstalled the software but to no avail... I can only assume the package has altered the registers in some way because I would have thought that a complete removal and reinstall should have fixed it.

I previously ran this package on my Powerbook G4 and am now using this again and it is working Fine.

Can anyone help me here... I live in the country no mains electricity, no telephone line and this is my only form of communication.

Thanks for your help

Power Mac G4, 15" PowerBook G4 and now the 15"Macbook Pro, Mac OS X (10.4.9), Airport in Tower. A Express in Books
  • philsmith_dot_com Level 3 Level 3 (830 points)
    This is a bug. You should file a bug report with Vodafone which will help clients avoid this problem in future releases. You have two pieces of software here, an application and a driver which lives in the kernel. It looks like the application was attempting to access some information in the kernel which wasn't there (a bug). The excepton wasn't caught (another bug) so the application quit.

    In the meantime, since you can't modify the application, the only thing you can do is to reload the driver. The simplest way is to reboot. Did you try that? If that doesn't work, maybe the cache needs to be updated. Hard to imagine, if you reinstalled the driver too. I think you can move the files /System/Library/Extensions.kextcache and Extensions.mkext to the Trash and reboot as an easy way to clear the cache.

    HTH - let me know.
  • BDAqua Level 10 Level 10 (120,305 points)
    Two more things I can think of...

    #1> Uninstalling MAY be leaving a bad Preference or .plist file!? Might look for com.vodaphone or something similar.

    #2> I think you should get Applejack...
    http://www.versiontracker.com/dyn/moreinfo/macosx/19596

    After installing, reboot holding down CMD+s, then when the prompt shows, type in...

    applejack AUTO

    Then let it do all 5 of it's things.

    At least it'll eliminate some questions if it doesn't fix it.
  • Alcanara Level 1 Level 1 (0 points)
    Hi chaps... thank you for your help.

    I have downloaded Applejack and run all 5 routines (Good bit of kit by the way) Unfortunately I still have the problem. My first thought was that the latest software from vodafone may not have been for the Intel macs. Certainly the software was available before and it works fine on the powerbook.... BUT it has worked since I first intalled for a month or more..Intriguing

    HELP??!!
  • BDAqua Level 10 Level 10 (120,305 points)
    I think one thing an install would change, and an uninstall most likely won't revert... is the Ports & Order in Network>Show:>Network Port Configurations.

    So you might take a look there to see what's checked, and you can drag the Interface you want to use for Internet to the top of the list. Might try deleting vodaphone related ones and reboot, then reconnect the vodaphone.

    Might try uninstalling vodaphone, then trashing...

    /Users/nnnn/Library/Preferences... the whole Prefs folder there.

    /Library/Preferences/SystemConfiguration... the whole SysConfig folder.

    /Library/Preferences/com.apple.sharing.firewall.plist

    /Library/Preferences/com.apple.networkConfig.plist

    And reboot & reinstall vodaphone, & setup Networking again... of course you dont have to trash them, you can just move them to the desktop to drag back if it doesn't work.
  • Stephen Webb1 Level 1 Level 1 (5 points)
    I have had the same problem, I have tried the solution and the whole system has ground to a halt. Since VMC no longer functions, it will not load the configuration to re-connect the modem, also, the HUAWEI has produced 3 versions of itself. I now have a complete mes, and Vodafone could not care less! Any suggestins to get it all working again?
    Ta