8 Replies Latest reply: Apr 28, 2007 9:53 PM by AppleGeek
olemed Level 1 Level 1 (110 points)
I have been using 10.4.8 flawlessly on my G4 with 1 gig of ram until yesterday, when I decided to update to 10.4.9.

Noticed some sluggishness after reboot and then attempted to repair permissions but got the spinning beach ball. Forced a restart and then got the circle with a line through it instead of the apple logo upon reboot. I had to install Tiger on my firewire drive in order to boot up. Once in, I ran a permissions fix and repaired the hard drive - it come up with some errors but those errors were repaired.

Proceeded to then restart from the internal hard drive - all seemed well until the computer went to sleep. When I woke it up, the mouse was the only thing that moved - I could not click to open any files or restart from the Apple menu. Upon restart same deal with the circle with a line through it (sorry I forget what this means, as I've never seen it before) and had to boot up from my firewire drive in order to again run a permissions fix and repair the volume.

I've never had this kind of issue before. I admittingly forgot to run a permissions fix before I installed 10.4.9 but I've forgotten to do this before and never had a problem.

I'm running a Sonnet Encore ST/1.4 for 3 years now and haven't had any issues unless it doesn't support 10.4.9 - I'm not able to find this info on their website.

Anyone with a similar setup having issues? I haven't yet zapped the ram - will do so tonight. Anything else I can try to do short of having to reinstall everything again.

PowerMac G4 "Digital Audio"; MacBookPro (2 Ghz Core Duo), Mac OS X (10.4.9)
  • AppleGeek Level 1 Level 1 (55 points)
    That icon with the slash means the OS experienced a kernel panic during startup, or experienced some other misc. issue. See http://docs.info.apple.com/article.html?artnum=106805.

    If you have the space, I would first advise backing you up your system, or at least your personal data files, in case things get worse.

    When you say there are errors being repaired, are these errors being reported from repairing the disk drive itself, or just the permissions?

    If the drive your having problems with is internal, you can use Disk Utility to check the SMART status of the drive. Open that program, click on your hard drive icon in the list, and look near the bottom of the window. There should be a line that reads "SMART Status: " If the status indicates the drive is predicting it will soon fail, you will definitely want to backup your data and replace the drive.

    Otherwise, you might try booting from your firewire drive again, and run the Mac OS 10.4.9 Combo updater against your main hard drive (http://www.apple.com/support/downloads/macosx1049comboupdateppc.html). Sometimes an update of OS X does not install properly, and can be resolved by running the combo updater, which may replace bad/missing files that are preventing your system from updating.

    Hope this helps, and good luck!
  • AppleGeek Level 1 Level 1 (55 points)
    Another thought: Hold down command-v during startup. This trigger "verbose" mode when the OS is trying to boot. The output might appear cryptic, depending on your familiarity with OS X startup messages, but it may print more helpful information indicating what the problem is.
  • olemed Level 1 Level 1 (110 points)
    Thanks for the help. Here's what I did:

    1) Started up from Firewire drive
    2) Downloaded 10.4.9 combo updater
    3) Repaired permissions on my Mac HD
    4) Installed the combo update on Mac HD
    5) Repaired permission on Mac HD again
    6) Selected Mac HD as the start-up volume

    So far, so good. No problems. Not sure what happened before to cause the hiccup, but I think from now on I'll download the combo updaters and install that way.

    Thanks for your help! All very good suggestions.
  • olemed Level 1 Level 1 (110 points)
    As luck would have it ... when I turned on the computer this morning, same problem - prohibitory sign was flashing. Computer had been fine last night and even shut down properly (something it was stalling with after I applied the 10.4.9 update originally).

    Zapped the PRAM and even booted with the shift key down - same sign came flashing. Started the Firewire drive up again and fixed permissions on the Mac HD. Didn't need any disk repair. I was then able to boot into the Mac HD without problems and ran Tiger Cache Cleaner - it restarted without problems. I'll keep my fingers crossed later but I have already backed up data in case I need to restart from ground zero.
  • AppleGeek Level 1 Level 1 (55 points)
    It's starting to sound that way sadly

    However, if you've invested in utilities like Disk Warrior, pop in that CD and allow to check your HDD. It might reveal directory structure corruption that's beyond fsck's (i.e. Disk Utility) ability to detect and resolve.

    Also please check into my suggestion about verifiation of SMART hard drive diagnostics (in my previous post).

    Another helpful utility if TechTool Pro. It can run advanced diagnostics on much of your hardware to ensure it's functioning normally, including a full sector verification of your hard drive(s). I've discovered bad disk blocks from this type of test in this past.

    How much RAM do you have installed? If you have more than 1 stick of RAM, please try removing the one closest to the CPU, slide the others down the line, and keep an eye on things. If you have defective/marginal RAM, the OS might be corrupting itself in memory, leading to all kinds of potential problems. Memtest is a great tool to test RAM, but it recommends 5 passes which can take hours to complete: http://www.memtestosx.org/

    If it comes down to simply being a corrupt OS X installation, one option you have is Archive and Install, which is a process Apple developed to allow users to make a best-effort at reinstalling the OS with minimal impact to already installed applications and user files: http://docs.info.apple.com/article.html?artnum=107120

    Though doubtful, you might have an outdated version of Sonnet Cache installed (last release was April 2006, which includes support for OS X 10.4): http://www.sonnettech.com/support/downloads/osxupgradesw.html

    Bear in mind I didn't look too deeply into Sonnet's information on this software and your processor. So I'm not sure if your processor even uses the Cache software or not. But if it does, you might want to try upgrading/reinstalling to the latest release. I'd be surprised if this fixed your problem, given how long you've probably been running 10.4.x

    Good luck, keep us posted on your progress!
  • olemed Level 1 Level 1 (110 points)
    Thanks AppleGeek for all your suggestions.

    I did not realize I have Tech Tool Pro 3 on my work MacBook Pro so I did a firewire-target drive with my G4 at home and was able to run Tech Tool. It found no major errors - some minor volume structure errors that it attempted to repair but I think it did a lousy job because disk utility, which I ran afterward, fixed up the repair mess caused by TT. Otherwise no hardware problems were detected.

    I did check the smart status of my hard drive and it said it was verified. I have no idea if that's a good thing or not. But no errors came up.

    I deleted the finder preferences with one of my maintenance programs and all seems well for now. I'm going to monitor this and if it continues to act up I'm just going to either reformat and reinstall or do the archive and reinstall method.
  • olemed Level 1 Level 1 (110 points)
    Alas, I have had to reformat and reinstall Tiger on my hard drive. Now everything runs faster and better. No more problems booting up or shutting down and no more other strange oddities, at least not for now. Thanks for your suggestions and help AppleGeek.
  • AppleGeek Level 1 Level 1 (55 points)
    No problem, at least it's resolved now! Hopefully your troubles are over (for now.)