12 Replies Latest reply: Oct 2, 2009 12:05 AM by mike.habermeier
mike.habermeier Level 1 Level 1 (5 points)
Hallo everybody. I have a very strange problem with a customer who uses about 20 macs. Different machines. No new Intel Macs. All G5 machines. The customer has a network with abouth 20 machines. 100 Mbit Network connection to a Helios (Sun) FileServer. The Uplink to the server is Gigabit and this all goes threw Cisco Networking Switches. Now to my Problem this still exists since 10.4.0. The Macs randomly crashes bei placing pictures in Quark. Let me explain. The customer goes to "placing picture" in quark. Browsing the network volume and than it crashes before they can click on the button import. As first i thought it was a Quark Problem. But quark can not help me. Than i thought it was a finder dialog problem and deactivated all previews and all the other stuff. Nothing helps. Now 10.4.9 comes out and I was full in hope that this fixes my issues because Apple said they updates Finder Network Browsing.

But now the things go crazier. Sometimes the crashes are in Photoshop by saving a picture or open a picture. And of course in Quark with pacing a picture. Now i really do not know what i can do.

I will post here because i hope that someone can help me.
Here is the Kernel Error Log file:

*******

Tue Apr 24 11:44:36 2007
panic(cpu 1 caller 0x000E82A0): vnode_put(4cc3840): iocount < 1
Latest stack backtrace for cpu 1:
Backtrace:
0x000952D8 0x000957F0 0x00026898 0x000E82A0 0x000E824C 0x000D4CB0 0x002AB7F8 0x000ABB30
0x0303A008
Proceeding back via exception chain:
Exception state (sv=0x517AD780)
PC=0x9001C9C0; MSR=0x0000F030; DAR=0x0D450FFC; DSISR=0x0A000000; LR=0x90B99274; R1=0xF0507FC0; XCP=0x00000030 (0xC00 - System call)

Kernel version:
Darwin Kernel Version 8.9.0: Thu Feb 22 20:54:07 PST 2007; root:xnu-792.17.14~1/RELEASE_PPC

*******


If someone need more information. Just let me know.!!!
Thanx for your help.

Mike


Different Macs   Mac OS X (10.4.9)  
  • 1. Re: Weird Kernel Errors accessing Network Volume
    BDAqua Level 10 Level 10 (116,480 points)
    Hi Mike.

    Just throwing out some thoughts here...

    Any other info in the Logs, like Applefileservice, Directoryservice, Application crash logs like Quark or PShop?

    Have you cleared caches, fixed permissions and such? If not, I like Applejack...
    http://www.versiontracker.com/dyn/moreinfo/macosx/19596

    After installing, reboot holding down CMD+s, then when the prompt shows, type in...

    applejack AUTO

    Then let it do all 5 of it's things.

    At least it'll eliminate some questions if it doesn't fix it.

    Tried tweaking the sysctl variables yet?
  • 2. Re: Weird Kernel Errors accessing Network Volume
    mike.habermeier Level 1 Level 1 (5 points)
    Hi BDAqua,

    i have allready installed AppleJack. I installed AppleJack to all customers i work with.

    After AppleJack it works for about a week or something. But this is only a sujective feeling from my own. Maybe caches i thougt.

    I tweaked the Network parameters to half duplex, full duplex and so on. Not helping. In all the log files i can not see any other infos. not in the system.log or something else.

    Thank your for your help. Maybe we can figure it out together. I really end up here

    What do you mean with sysct variables ??

    thanx. mike
  • 3. Re: Weird Kernel Errors accessing Network Volume
    BDAqua Level 10 Level 10 (116,480 points)
    Sorry, poor eyesight when I typed sysct, meant... The sysctl variables like...

    Not certain these work for Network, or just Internet !??

    The settings shown below are given in a good faith there is not at all any guarantee that it will work perfectly for you.
    Lets give it a try and run the following commands from the command line:
    sysctl -w net.inet.tcp.delayed_ack=0
    sysctl -w net.inet.tcp.mssdflt=1460
    sysctl -w kern.ipc.maxsockbuf=131070
    sysctl -w net.inet.tcp.sendspace=65535
    sysctl -w net.inet.tcp.recvspace=65535
    sysctl -w net.inet.tcp.newreno=1

    A word on MTU or mssdflt...
    Different Servers may have different MTUs, and that can cause Havoc, here's some guides on that issue...

    Setting MTU size is a process of trial-and-error: start with the maximum value of 1500, then reduce the size until the problem goes away. Using one of these values is likely to solve problems caused by MTU size:
    • 1500. The largest Ethernet packet size; it is also the default value. This is the typical setting for non-PPPoE, non-VPN connections. The default value for NETGEAR routers, adapters and switches.
    • 1492. The size PPPoE prefers.
    • 1472. Maximum size to use for pinging. (Bigger packets are fragmented.)
    • 1468. The size DHCP prefers.
    • 1460. Usable by AOL if you don't have large email attachments, etc.
    • 1430. The size VPN and PPTP prefer.
    • 1400. Maximum size for AOL DSL.
    • 576. Typical value to connect to dial-up ISPs.

    Another way to change the MTU is by...
    sudo ifconfig en0 mtu 1460

    Or whatever interface for en0, or different mtu value.

    These will all be lost with a restart, but might help in diagnosing.

    Starting to sound like some flakey HW with the week or so going good !???
  • 4. Re: Weird Kernel Errors accessing Network Volume
    mike.habermeier Level 1 Level 1 (5 points)
    this is a interesting information.

    but i tried the setting the MTU. For a day or something like that.
    I often heard about problems with CISCO Switches and MTU sizes.
    So that was the first thing i tried.

    But i didn´t try the sysctl commands. This seems interesting.
    I will give this a try. I am not sure if this helps for networks and not only
    for working with internet

    Sorry my english is not so good. I am from germany. What do you mean with "flakey HW"

    When I am driving back from the customer i thougt on the cisco switches.
    This is one of the things i did not change. Maybe i will give this a try and
    change one switch to a HP Procurve or a Level One Switch. What do you mean about this ?

    Very very thanx for your help and this conversation.

    Mike
  • 5. Re: Weird Kernel Errors accessing Network Volume
    BDAqua Level 10 Level 10 (116,480 points)
    Your English is far better than my German!
    Maybe better than my English even... since it's Flaky, not Flakey ! :-O

    Uhhhm sorry... "flakey HW" means Hardware that works sometimes, but every so often gets "schuppig" with a bit here or there.

    I was thing the Router myself also.
  • 7. Re: Weird Kernel Errors accessing Network Volume
    BDAqua Level 10 Level 10 (116,480 points)
    Exellent Ant !
  • 8. Re: Weird Kernel Errors accessing Network Volume
    mike.habermeier Level 1 Level 1 (5 points)
    eehmm. wow. that sounds that i am not the only one
    so.. my english is not that good. can someone explain me what i should do.
    i only understand half of what the guy said there

    pleaseeeeee

    thx mike
  • 9. Re: Weird Kernel Errors accessing Network Volume
    Anthony Cunningham Level 3 Level 3 (625 points)
    hes basically giving instructions on how to use the dbg debugger to debug part of the kernel and track down what operation and cause is generating your panic.

    here is the reference document about using dbg i think he was trying to link to:
    http://developer.apple.com/documentation/Darwin/Conceptual/KernelProgramming/bui ld/chapter18_section5.html

    here are the debugger kits youll need:
    http://developer.apple.com/hardwaredrivers/download/kerneldebugkits.html

    hopefully youl be able to gifure it out betwen what the guy from the list outlines and the reference document.

    I don thave time to review them fully myself and break it down for you, but if i have time later tonight i will. Maybe Phil or someone can help in te meantime... if not your on your own till later this afternoon. Sorry
  • 10. Re: Weird Kernel Errors accessing Network Volume
    mike.habermeier Level 1 Level 1 (5 points)
    no problem. i am happy that you help me in this topic.

    dont worry.. I am at the customer in one week. I will figure it out there and i will try to read into this manuals and software kits before i go to the customer.

    Thanx for all your help!
  • 11. what i have done for now
    mike.habermeier Level 1 Level 1 (5 points)
    is reinstalled one computer again. changed the network switches to HP Procurve Switch. Reconfigured the server and the shares from the server.

    But nothing helps !!! If somebody out there has any idea.

    PLEASE POST IT.. !!

    Thanx in advance.

    Mike
  • 12. Re: Weird Kernel Errors accessing Network Volume
    mike.habermeier Level 1 Level 1 (5 points)
    Now all the macs are changed from G5 to MacPro Machines. Nothing else has changed. All the Problems gone away. Problem fixed