7 Replies Latest reply: May 16, 2007 11:56 AM by hobopop
hobopop Level 1 Level 1 (0 points)
ok - this has probably already been asked somewhere but i've been reading and reading and everyone else seems to have split their library or failed to copy their files properly when moving them to an external, etc, etc, and i don't thik i've made any errors here...

so here is my version of the age old thing.

i keep my entire itunes library on a portable external hard drive that i take everywhere i take my computer, and that i always attach when using itunes and my ipod. i have been doing this for a few months and have not had any trouble. the default folder in preferences>advanced>etc is set to the hard drive and all the files are there.

itunes has recently taken to not finding the files i want it to play, and thus not syncing properly to the ipod and all the rest of it. when i double click a track to play it, or try to get info on a track, it dispalys the dreaded ! symbol and tells me it can't locate the file. if i choose to manually locate them they are in the default itunes file and they play fine once i have told itunes where they are.

am i going to have to do this track by track for 30 gig of music, or is some wonderful person out there going to be able to tell me how to grab itunes by the back of the neck and march it down to my external hard drive, showing it all the files at once and shouting "there they are - right there!"...?

thanks in advance.

macbook   Mac OS X (10.4.9)  

macbook, Mac OS X (10.4.9)
  • Jase the C Level 2 Level 2 (375 points)
    Hobopop, You are right about your problem being different than mishandled music folders or library files. There are a number of threads related to your problem, but unfortunately, noone seems to have any clear answers.

    One thing to look at (maybe two): Do you have "Create file names with track number" in Preferences:Advanced:Importing turned on? Also, take a look at some song files inside your music folder, especially those that iTunes doesn't seem to recognize. Do the names of those files begin with the track number?

    If not, then you may find, as I did, that always creating file names with track numbers takes care of this problem. I've run into the Dreaded Exclamation Mark problem many times, but since I started making sure to create file names with track numbers, I hardly ever run into this problem. When I do, it's always concerning a file whose name does not begin with the track number. See http://discussions.apple.com/message.jspa?messageID=3270955#3270955 if you feel like reading my detailed account of this situation.

    iMac G4 17; iBook G4 1.33 Mhz 14; iPod 3G 20GB   Mac OS X (10.3.9)  
  • Michel Dandurand Level 1 Level 1 (0 points)
    I had a similar problem!

    Everybody seems to live this situation at this time probably 'cause everybody is buying a new external drive right now!
    here is what I did...
    hope it can help.
  • Jase the C Level 2 Level 2 (375 points)
    Michel, The problem you had is a different and more common problem than the one I describe. They both can result in the little exclamation marks appearing next to tracks, so I can understand the confusion, and I'm certainly glad that you got your situation figured out. The more common problem that you and many others have had stems from the difficulty of figuring out what the roles of the iTunes Library file, the iTunes Music folder, and iTunes Preferences settings, e.g., the iTunes Music folder location, are. Too bad this all is not more intuitive, although I think iTunes is a great piece of software.

    The rarer problem I describe, and which I think Hobopop has, is a seemingly spontaneous disconnect between the iTunes Library and some of the song files that are listed as entries in the library. In all the threads in this forum on this topic that I've been able to find, noone has been able to explain this problem. It really does seem to be a bug. I've suggested that making sure to always use "Create file names with track numbers" will prevent this problem.

    Hobopop, if you are following this, it would be great if you would post your results from any tinkering you've done. It would be helpful to others to add to the information available about this weird problem.

    iMac G4 17; iBook G4 1.33 Mhz 14; iPod 3G 20GB   Mac OS X (10.3.9)  
  • hobopop Level 1 Level 1 (0 points)
    thanks to you both, but this has not solved the problem. the 'create file name with number' box was already checked so it can't have been that.

    i have tried copying all the music back over to my internal hard drive and re-setting the default disc to the standard itunes music folder, but itunes can't even find the files there.

    as usual - if i find each track individually itunes will play it, but even if i do commit the next 70 years of my life to doing this manually, how ca i be sure that next time i boot up the program it will have maintained the link i created?

    any more ideas anyone?
  • Jase the C Level 2 Level 2 (375 points)
    Thanks for reporting back. If you want to take a look beneath the surface (if you haven't already), next time a track shows up with an exclamation mark, you might want to look inside the iTunes Music Library.xml file. You can open that with TextEdit or a word processor. Do a search on the song title, and then look at the Location string. Does the location, right down to the file name, exactly match what you see in the Finder for the song file?

    BTW, there is no risk in messing around in the xml file (as long as you don't Import it into iTunes, unless you really intend to). In fact, you can throw it out, and iTunes will simply create a new one.

    iMac G4 17; iBook G4 1.33 Mhz 14; iPod 3G 20GB   Mac OS X (10.3.9)  
  • hobopop Level 1 Level 1 (0 points)
    nope - that's not it either! all my xml text things have identical paths to the real location of the files. nice idea, though!

    i have fixed my problem, though. probably not permanently or in a very convenient way, but at present itunes is working for me again. here is how i did it...

    all my files were also on my ipod, so i used a downloadble software package (music rescue, which is fantastic!) to copy all of the mp3 files from my ipod to my internal hard drive. i then dragged these and dropped them all into my itunes library. this meant that after a lot of copying i had all tracks twice, and every other track had the '!' symbol next to it.

    i therefore had my library twice over, once working and once not working. i highlighted all the tracks with exclamation marks and deleted them, leaving the new version of my old library. i lost my playlists but i didn't really have any anyway, and no smart lists or anything like that. i probably also lost playcounts and the like but i don't really care about that either because i don't use itunes in that involved a way...

    i am fully expecting itunes to work fine for a while, then do the same thing again, so i am leaving this as a unanswered question in the hope that someone has a suggestion that will offer a more permanent solution.

    thanks to everyone for their help...

    macbook   Mac OS X (10.4.9)  
  • hobopop Level 1 Level 1 (0 points)
    ok i think this post is done now. after doing what i said in my last post i'm still ok, although i have had to go to my itunes folder and delete all the doubles of files it has created. this is time consuming but can be done over time and is much less inconvenient that finding each file individually through itunes.
    if you're going to do this make sure you 'get info' on tracks to find out which are being used by itunes and which are being deleted.