Previous 1 2 Next 23 Replies Latest reply: May 26, 2007 11:51 PM by Jason Fagan1
Doritos Level 1 Level 1 (0 points)
Hi there,

I have just set up my Apple TV...sort of. It loads the network list, and I can see my wireless network there, but when I click it, it says "There was a problem connecting to the network." And then I'm stuck in an endless loop of trying to connect and failing.

I have a Dell PC running Windows Vista, and I'm wondering if this could be part of the problem? My network is discoverable but password protected.

Hope you guys have some suggestions!

Other OS, Using Windows Vista
  • Winston Churchill Level 10 Level 10 (85,550 points)
    A PC running vista should not be a problem for you, even if it was it would not interfere with the tv joining the network. Is it possible that your tv is either too far away from your base station or that it is in another location from your PC and base station and suffering interference that the PC and base station are not.
  • Doritos Level 1 Level 1 (0 points)
    No...the desktop and router are in the next room, and I'm using my laptop right now, connected to the network, two inches from the Apple TV. I'm not even getting a chance to put in the password, so I don't think it can be a problem with restriction either. I'm completely puzzled.
  • Winston Churchill Level 10 Level 10 (85,550 points)
    What sort of encyrption are you using to secure your network.
  • Doritos Level 1 Level 1 (0 points)
    Honestly, with Windows Vista, I have not been able to tell what, if any, type of encryption I have on my network. Nothing on Vista is anything like XP, and I can't figure out where to even set up encryption except through a program MS provides that requires hard-drive partitioning -- but that's a whole other story and reinforces why I should have switched completely over to the Mac world long ago.

    Anyway...

    I did go into my network settings and allow everything with password-only access, though. Still nothing. I tried rebooting my computer, rebooting the Apple TV, and nothing. My network connections are fine with my laptop.

    Is it possible to use a flash-drive to transfer network settings to AppleTV?
  • capaho Level 4 Level 4 (3,650 points)
    If you're using a router and Apple TV can't establish a connection with it then it's unlikely that the problem is related to your Dell PC. It's more likely to be a problem with DHCP or security settings either in the router or the Apple TV. If your Apple TV is properly connected to your router you should see a network IP address of something like 192.168.x.x.

    iMac   Mac OS X (10.4.9)  
  • junilou Level 1 Level 1 (0 points)
    I had a similar issue and it was router-related - I had to upgrade the firmware on my router and it solved the issue (although I'm still losing the connection whenever I switch the ATV off).
    More info here:
    http://discussions.apple.com/message.jspa?messageID=4310246
    Have you tried plugging it through an ethernet connection to see if that works?
  • Nagarjunam Level 1 Level 1 (0 points)
    I had the exact same issue. Where did you put your Apple TV? I had put my Apple TV on top of my VCR. It would see my wireless network, but would never connect. I put it aside and it was able to connect. You might want to try this.

    This is really weird, and it does force you to find another place for your Apple TV, as you cannot stack it now.

    -Nags
  • Doritos Level 1 Level 1 (0 points)
    Hmm...I had this thought, too, because I just received the Mac Powerbook I ordered at the same time and it had no problems connecting to my network -- even from all the way across my house. So I tried to relocate my Apple TV - this time to the top of my TV stand, but still no luck. I can't imagine it's a problem with my router when my Macbook powered right up and connected.

    I don't suppose there's an 800 number for support on this thing, is there?

    Thanks for the suggestions!
  • R C-R Level 6 Level 6 (15,020 points)
    I don't suppose there's an 800 number for support on
    this thing, is there?


    Of course there is. Check your warranty info. In the US, you get 90 days of free phone support without buying an AppleCare Protection Plan, 2 years with one.
  • capaho Level 4 Level 4 (3,650 points)
    You can't assume that it's not your router just because other devices can connect. I've seen a lot of buggy firmware in routers sold for home use that result in two different devices being assigned the same network address via DHCP, for example, or not responding to a DHCP request from a particular device.

    iMac   Mac OS X (10.4.9)  
  • junilou Level 1 Level 1 (0 points)
    That's true, when I was having my router problems I had two laptops (one macbook and one PC laptop) both connecting fine to the wireless network.
  • Doritos Level 1 Level 1 (0 points)
    So any suggestions for fixing that? I have a Westell router for Verizon DSL. I've gone to the http:192.168.1.1 for changing my settings, but I don't really have any idea what to change once there. As for updating firmware for it, there doesn't seem to be anything on either Verizon's or Westell's site for that, and the "Update Device" button on the http address above doesn't function either.

    Errrgghh...and I was soo looking forward to watching my Battlestar Gallactica on the TV instead of my Video iPod...

    Thanks as always!
  • capaho Level 4 Level 4 (3,650 points)
    In your router settings, make sure DHCP is enabled. You should also set a WEP key in your wireless security settings if you haven't already. If you enter a new WEP key you will have to change it in all of your wireless devices, not just your Apple TV. Also check to see if your router is restricting access by MAC address. If it is you will have to enter your Apple TV's MAC address and allow it access.

    In your Apple TV go to the network settings and let Apple TV search for a wireless network. You should see your router's network name, probably something like "Westell_ABC" or perhaps something more cryptic like "80097_C." Select that as your network (make sure you don't select your neighbor's wireless router if there are other wireless networks near you). Enter the correct WEP key and make sure DHCP is enabled and it should work.

    iMac   Mac OS X (10.4.9)  
  • junilou Level 1 Level 1 (0 points)
    Also you should try it at least once with the ethernet connection (and I know it's a pain...). First you will be able to confirm that the problem is in the wireless connection and not in the ATV itself, and second you'll be able to do one big sync of your iTunes library, assuming it connects... Which should at least get you started.
    If the Ethernet doesn't connect I would bring back the box.
Previous 1 2 Next