7 Replies Latest reply: Aug 27, 2007 9:03 AM by Jim Lange
Djmx Level 1 Level 1
hey every1

I recently reformatted my MBP and since then i tried all the setting and for sum reason every time i restart my computer or turn it off n on..the doesn't connect to my network automatically i tried all the settings.. my Network is there but it doesn't connect to it automatically... any ideas..? Thanks!

Macbook Pro 2.16, Mac OS X (10.4.9)
Solved by dshillis on Aug 9, 2007 11:01 PM Solved
I kept digging around, and found a fix to it (below)...try this and see if it works:

*Delete Preferred Network(s)*
1. System Preferences > Network > AirPort > Configure
2. In the "By default, join:" pull-down menu, select "Preferred networks"
3. Delete the network(s) you regularly use from the list




*Delete AirPort Keychain Entries*
4. Launch the "Keychain Access" application located in Applications/Utilities.
5. Click on the "Kind" filter at the top, and look for any "AirPort network password" entries...and delete them.
6. Restart, or log out then back in.


*Add Preferred Network(s)*
7. System Preferences > Network > AirPort > Configure
8. In the "By default, join:" pull-down menu, select "Preferred networks"
9. Add the preferred network(s) using the "+" button.
10. Restart or log out then back in.
  • Matt C. Level 1 Level 1
    I am having same problem -- only recently -- with my PB. Several wireless networks reach my house, mine is only one on my "preferred" list -- yet I still have to manually select it from airport pull down each time I "wake" my PB. Any thoughts?
  • dshillis Level 1 Level 1
    So am I. I used to have this problem just at work, and now it's happening at home too. Quite frustrating, can't figure it out. I have to manually choose it every time now!
  • dshillis Level 1 Level 1
    I kept digging around, and found a fix to it (below)...try this and see if it works:

    *Delete Preferred Network(s)*
    1. System Preferences > Network > AirPort > Configure
    2. In the "By default, join:" pull-down menu, select "Preferred networks"
    3. Delete the network(s) you regularly use from the list




    *Delete AirPort Keychain Entries*
    4. Launch the "Keychain Access" application located in Applications/Utilities.
    5. Click on the "Kind" filter at the top, and look for any "AirPort network password" entries...and delete them.
    6. Restart, or log out then back in.


    *Add Preferred Network(s)*
    7. System Preferences > Network > AirPort > Configure
    8. In the "By default, join:" pull-down menu, select "Preferred networks"
    9. Add the preferred network(s) using the "+" button.
    10. Restart or log out then back in.
  • Chuck Young Level 1 Level 1
    I've tried what you have said and still do not automatically connect. ANyone with a solution???? Help!!!!!!
  • aocaoc Level 1 Level 1
    Are you sure you followed it exactly. Don't forget to empty the bin when you delete something.

    It solved my problems. Thanks a lot dsdillis!
  • chriguc Level 1 Level 1
    I have the same problem with my new iMac. I followed the instruction posted above, but it didn't work. I wonder if anyone has found a solution yet. thx
  • Jim Lange Level 1 Level 1
    Hey dshillis, thanks for fix, but for some reason, I don't have choice in "By default, join:" to select "Preferred networks." Only option is "A specific network."

    What am I missing?