8 Replies Latest reply: Nov 11, 2007 10:53 PM by Thomas B. Robison
braiders Level 1 Level 1 (0 points)
Hey, recently bought second-hand 17" Powerbook.

Great, although the volume control seems to be set on default LOUD FULL VOLUME, and keypad buttons are disabled (ie: when you press them the speaker icon comes up but with a circle and line through it, inferring you can't change it). When you go into system prefs, the volume slider is greyed and the circle with line through it symbol is there too. What's up? When I put headphones in they don't work either, although System prefs recognises another device has been inserted.

Anyone seen this before?

It's pretty annoying.

Neil

20" iMac G5; 24" iMac G5 Intel; 17" Powerbook, Mac OS X (10.4.9)
  • braiders Level 1 Level 1 (0 points)
    I can't believe no-one has seen this problem before! Help me please.

    Just re-installed Tiger and updated to latest version. Still same problem. Even if I put the headphones in the sound still comes out of the speakers on the laptop. What am I to do. Let's get a dialogue going please....

    I live in hope that some Mac brain will solve this.

    Braiders
  • arnie Level 5 Level 5 (4,065 points)
    since the OS was reinstalled, issue is likely caused by hardware.

    on PowerBook 17" models 2 parts are responsible for sound -
    sound board and logic board.

    could be bad connection or failure of either part.

    probably sound board problem as a guess.
  • Cea Level 1 Level 1 (50 points)
    Is it possible that you might be able to return the Powerbook, since you are having these not-so-simple difficulties? Tell the seller they sold you a bum computer?

    Best wishes to you.

    PB 17 G4, iPod 30g, iPod 60g, 2g Nano   Mac OS X (10.4.9)  
  • Boris Dimitrov Level 1 Level 1 (0 points)
    I get this problem sometimes on my Quad G5. Started happening in March or April 2007. I don't know what the problem is exactly, but I know that newly created user accounts are immune to it. I doubt this is caused by bad hardware; most likely it's some setting stored in your user account which was preserved by the OS reinstall and therefore continues to bug you.

    The following steps usually restore volume control for me:

    1) Log out.

    2) At the login window, try the volume control keys. They work, don't they?

    3) Log back in.
  • Craig Estrella1 Level 1 Level 1 (5 points)
    This has happened to me a couple of times...

    Have you tried going into the System Preferences and checked the Sound settings? Go there, select Output and make sure that the Line Out is selected for the Built-In Audio.

    Sometimes I've found my computer switches to the Digital output or an aggregate device that I have installed. If that happens, you can't change the volume with the volume keys.

    Hope that might have helped.
  • Iffy2020 Level 1 Level 1 (0 points)
    I just did a hard reboot (wouldn't ever finish logging out). Now that I've restarted the computer, the volume control is disabled. I click on the menubar one and can't adjust the slider. The slider in the Sound Pref Pane also is greyed out... and the volume buttons likewise do not change anything (I have the same crossed-out circle popup when I press them)

    The buttons do not work on the login screen either.
  • Iffy2020 Level 1 Level 1 (0 points)
    Hey, I turned it off and on again (soft, not hard) and the volume control works again... kinda buggy...
  • Thomas B. Robison Level 1 Level 1 (20 points)
    This is even more wierd: I, too, had lost the ability to control the volume with the volume buttons. I tried the usual things, ie; System Prefs sound control panel. Then I noticed an application I had running in the background had timed out. When this particular application (SplashID) times out, it asks for password input or CANCEL, as options. When I cancelled the application, I regained volume control button ability, immediately. Very Strange.

    Tom