7 Replies Latest reply: May 31, 2007 6:39 PM by Eme
_New_2_Mac Level 1 (0 points)
Hello - I have an Imac, purchased Oct/06, running Max osx 10.4.7, dial up external modem. No problems since purchase (love my MAC!!) until last night.

I turned my mac off and then on again last night, and then Safari would not connect to the internet. I can't update software either, and MS Messenger.Mac doesn't recognize the internet connection.

I can send and receive mail, I can download through Limewire. I have installed Firefox so I can now access the internet.

I have read many threads on this forum.

I checked my proxies and one was checked, so I unchecked it.
I reinstalled using disks that came with my IMac, used archive option to retain files, rebooted.

I tried inputting DNS #s (never needed them before).

I am on dial up modem, at home, no firewall, nothing newly installed or updated.

Any assistance would be greatly appreciated!!!

I Mac (intel), Mac OS X (10.4.7), dial up external modem
  • mafiaking Level 1 (105 points)
    hi well if you are able to go online with firefox then the issue is not with you ISP
    so try trashing HDD/users/your user account/library/cache also HDD/users/your user account/library/com.apple.safari.plist
    (make sure you do not open any applications before doing this only open them after the next step)
    and then restart mac and then try again
    also you could try from a new user account(if the above step does not work)
  • Eme Level 5 (5,635 points)
    Hello New_2Mac,

    Welcome to Discussions

    / Home~/Library/Caches/Safari cache, that is the only cache folder you want to move to the trash.
    I think that's what the other user meant for you to move to the trash.

    Be aware that Limewire can cause issues on your imac.

  • mafiaking Level 1 (105 points)
    yeah you got me right trashing that folder but also trashing the entire folder will help in the performance of mac itself
  • Lillian Hedbloom Level 1 (0 points)
    I have a PowerBook G4 and am having similar problems - my safari cannot connect, but Firefox is connecting. I cannot use ITunes to connect, and my software updater doesn't work. I have dumped the cache files recommended earlier.

    The second user account has the same problems.

    When I hook it up to a cable and get access to the internet from there, it's no problem using safari, Itunes, or Mail.

    So perhaps it's a connection issue.

  • Eme Level 5 (5,635 points)
    Hello again,New_2Mac,

    • See this users tip article by Neil on Clearing caches with OnyX as an example what trashing the caches do, & if that seems right for you.
    OnyX is a freeware cleaning tool, if you download it make sure to get the correct version for you os. If you do not do maintenance this may good sense.

    Read this user tip article by Travis A. Regular Maintenance/General Troubleshooting


    • With all Applications closed, Click on the Finder's Icon in the Dock.
    In the Finders window, sidebar, click on the Home icon (if Finder prefs. are not set to open home)

    Home~/Library/Preferences/Microsoft, look for MSN Messenger preferences move those to the trash, I presume you may have already trashed the com.apple.Safari.plist file.

    How are your settings in Network?

    Systems Preferences ->Network, make a new Location: name it your Dial-up
    or such as you like,

    PPP tab, Click on the (PPP Options) button,
    Session options:
    Do you have "Connect automatically when needed" √?
    & "Prompt ever 30 minutes to maintain connection", if not select those.

    Now in Advanced Optionsin same window
    √ Send PPP packets
    √ Use TCP Header compression
    Click OK to save setting

    In TCP/IP DNS servers, they seem to be anything but optional for most of us
    these days, two #s & in list mode...

    See the Dns #s for some of Canada on Portforward, DNS Serversweb page. I presume you have contacted your ISP for the number you added I would think there are more then what portforward shows.

    Alternately you could use the OpenDNS

    You may also try Configuring IPV6 to "Automatically"

    Click Apply Now

    Still in Network under Location, go to Show:Network Port Configurations

    Check that your "Internal Modem" is top on the list, checked that
    others are not if you don't use them, you can slide them in the order you need,
    Click "Apply Now".

    • System Preferences -> Sharing folder, Firewall if that is on, & if not
    Check that "Network time" is selected, fwiw, my os x firewall is on at all times & using the advanced settings as, there is no issue with any connections.

    Run disk permissions repair & restart you mac.

    Sorry to be so long winded, had to "just in case".
    Good luck, please keep us posted.

    Eme '~[ )♥♪
  • _New_2_Mac Level 1 (0 points)
    Thank you so much! I tried most of your suggestions before, without success. I may be beeen the plists or creating a new dial up network. Whatever it was, it worked!

    Thanks again!
  • Eme Level 5 (5,635 points)
    Hi once again,
    I am glad to read your Mac is all sorted, thanks for letting me know!
    It was a pleasure to help you solve your problem: )

    Enjoy your Mac!

    Eme '~[ )♥♪