3 Replies Latest reply: Jun 4, 2007 12:53 AM by AppleMal
AppleMal Level 1 (0 points)
After a long confusing day trying to get my Seagate External drive to work on my new Mac Pro I am successful but still need help.

The drive currently only works when plugged into certain ports and I believe those ports are only USB 1.0 so Carbon Copy Cloner is going to be running for a long time!

I would like to know what I can do to get the drive to work on a faster USB 2.0 port? Please help?!

More details follows:

The drive is a Seagate External USB only Push Button 300GB drive -> http://www.seagate.com/ww/v/index.jsp?locale=en-US&name=3.5-PB-300-USB&vgnextoid =0976cd2655bfd010VgnVCM100000dd04090aRCRD&vgnextchannel=c0fed21c2f32b010VgnVCM10 0000dd04090aRCRD&reqPage=Model

I am trying to use it on my Mac Pro 2.0Ghz. None of the front or rear ports on the Mac Pro recognise the drive. By recognise I mean not recognised by Disk Utitity, System Profiler and Disk Warrior 3.

By chance I tried the port on my keyboard and that worked. I was able to use Disk Utility to initialise and reformat the drive. I formatted the drive to the Mac OS Extended - (Journaled) format. My keyboard is the official wired Apple Keyboard that ships with the Mac Pro.

Prior to using the drive with my Mac Pro I used the drive with a Windows XP laptop and left in in it's original FAT32 format. I never managed to get that working with my Mac Pro before reformatting. But that was not an issue, I had already copied my data across a network.

I am fully up to date running 10.4.9

Yes all my USB ports work as I have tested them with a USB thumbdrive.

I use the white plastic 2003 20 inch Apple Cinema Display with my Mac Pro by means of the Apple Display Converter (ADC -> DVI). I can also use the USB ports on the back of that to work successfully with the external disk.

So am I correct in assuming the display and keyboard ports are USB 1.0 only? But say my external disk is only USB 1.0 compliant, then I thought this was fully compatible with USB 2.0 so why doesn't the drive work on all ports?!

I copied the following from the USB tree in the System Profiler if that helps:


Capacity: 279.46 GB
Removable Media: Yes
Detachable Drive: Yes
BSD Name: disk1
Version: 2.00
Bus Power (mA): 500
Speed: Up to 12 Mb/sec
Manufacturer: Seagate
OS9 Drivers: No
Product ID: 0x0502
Serial Number: 344E463232314141
S.M.A.R.T. status: Not Supported
Vendor ID: 0x0bc2
Capacity: 279.34 GB
Available: 278.16 GB
Writable: Yes
File System: Journaled HFS+
BSD Name: disk1s3
Mount Point: /Volumes/Backup300

Mac Pro 2.0Ghz   Mac OS X (10.4.9)   Seagate USB 2.0 Push Button 300Gb External Disk
  • The hatter Level 9 (60,925 points)
    It helps to 'wrap' URLs with code so they don't run off the screen, using UUB or HTML.... but that is minor for now.

    Easier to search "ST94811U2-RK"

    However I get "not found" on that drive. Your link comes up with "ST3300601U2-RK" There are some USB2 only PB 300GB drives listed.

    I tend to stick to non-vendor drives, rather than Maxtor or WD or Seagate etc. Anything with Oxford 911+ or above work well with Macs.

    And avoid USB2 drives and get one with FireWire (and USB2), your drive should be formatted as GUID - check the drive (not volume or partition) in Disk Utility. It is changed by reformatting in Disk Utility: Partition -> Options.... (at bottom of screen) and there will be three options, you want GUID (not MBR).

    Is it bus powered or does it have its own power supply?

    It seems that your drive is older discontinued model?
  • AppleMal Level 1 (0 points)
    Hi thanks for the quick response. Here's some further comments on your remarks:

    ST3300601U2-RK is the model of my drive as it is printed on the sticker on the drive - it is the current model. The other
    ST94811U2-RK code is just what shows in the System Profiler?

    I hear you on the Firewire front - I do have a firewire external drive enclosure which works flawlessly. However the disk in there is too small for my needs and has a very loud fan so that is why I was hoping to use this USB drive instead.

    The USB drive is externally powered with it's own power supply.

    Any further suggestions? Can you confirm that the USB ports on my keyboard and monitor are slower USB 1.0 ? Or how can I confirm that myself?

    I'm off to bed now and will leave Carbon Copy running overnight so will be unable to try new things out till tomorrow now. I will reply tomorrow though.
  • AppleMal Level 1 (0 points)
    Hi, forgot to mention in my previous post that I did try reformatting the drive to use GUID but that also failed. The drive was still not recognisable on the ports that fail as above.