Previous 1 2 3 Next 40 Replies Latest reply: Dec 9, 2007 11:12 AM by NichoTL Go to original post
  • Glyn Williams1 Level 4 (1,015 points)
    That sounds very odd.

    To save yourself a couple of dollars....
    The disk that came with the Airport Extreme (n) includes the enabler. Installing the software should enable those machines which shipped with n hardware and were originally not enabled.
  • Glyn Williams1 Level 4 (1,015 points)
    Bermuda Dave,
    Working Aiport disk systems are easily capable of speeds of 4MegaBYTES per second. It's not an awesome rate , but quite useful for media etc.

    I have the same firmware as you, so it really is not firmware.
    There are three possibilities.
    1) There is something odd about the USB drive itself. I guess you could benchmark it plugged into a Mac
    2) The drive is giving errors, and I think the Airport Extreme reacts badly to errors. A disk check and (if all else fails) a reformat often seems to solve problems.
    3) The problem is the wireless connection. You can check this by benchmarking the drive over a totally wired connection.
  • Bermuda Dave Level 1 (0 points)
    Hi Glyn and thanks for your post.
    I have been through everything that has been suggested and tried multiple USB drives too. Everything works exactly as expected EXCEPT when the airport is sharing the disk (over wired or wireless it does not matter). I see many others on the Net are having the same issue, so this is not unique to a drive, disk formatting, etc. The only common point is the airport unit itself. There must be a bug that shows up under certain situations, etc. The performance is quite ridiculously slow at the moment. I look forward to seeing this resolved in a future update.
  • tcExtreme Level 1 (0 points)
    Yes, I agree. Running the installer disk that came with the Extreme unit should "enable" the 802.11n that's native to the MacBook Pro.

    But why does Network Utility NOT report "/n" at the end of its report "Wireless Network Adapter (802.11 a/b/g)" ?

    Again, this begs the question: is "n" enabled on my Mac or not?

    BTW I paid the $2.17 for the enabler, and it reports that my Mac hardware does not support the enabler, so that was a waste of two bucks.

    Apple, are you listening? You are telling me that YES I am enabled (as a MacBook Pro unit), and NO I'm not enabled (according to Network Utility).

    What should I do?
  • Glyn Williams1 Level 4 (1,015 points)

    The first batch of Intel MacBook Pros were Core Duo.
    The later Core 2 Duos shipped with Atheros 802.11n Wireless hardware in which the n-mode was disabled. The "enabler" was really an un-disabler.

    Are you certain that your machine is a Core2Duo?
  • Barry Brown3 Level 1 (5 points)
    I have some news to report. Disk access using certain USB drive enclosures is, in fact, slow when compared to others.

    I have conducted some tests using different drive enclosures, but using the same physical drive (a Seagate Barracuda 400GB SATA unit). I compared two enclosures in particular: a $120 Newer Tech miniStack v3 and a $35 "generic" USB-only enclosure.

    The miniStack v3 is a "quad interface" enclosure, meaning it supports USB, FW400, FW800, and eSATA.

    In my tests, I found that the miniStack v3 takes twice as long to copy the same set of files from my Mac to the drive as the generic unit does.

    Write test:
    miniStack v3: 383 seconds
    "generic" enclosure: 186 seconds

    Read test:
    miniStack v3: 78 seconds
    "generic" enclosure: 77 seconds

    In all tests, the drive was connected via USB cable to the Airport Extreme. The Mac and Airport were connected via 100BaseT Fast Ethernet -- no wireless was used at all. The drive was reformatted before each test to eliminate any fragmentation problems.

    The enclosure exhibited nearly identical performance when reading from the disk. It was writing to the disk that suffered a severe slowdown.

    So it's true: the AirPort Extreme has trouble with some USB disks but not others. I wish I had the resources to do more extensive testing with a variety of enclosures.

    I've posted my complete test setup at

    Message was edited by: Barry Brown3
  • benjimouse Level 1 (0 points)
    I'm finding similar things. With a simple generic enclosure I get the expected transfer rates. With a enclosure that has usb and fw400 hubs, I get wireless transfers so slow it's unusable. At times transfers speeds drop to 5Kbps.
  • agstei Level 1 (0 points)
    Hi Flu,

    I just wanted to say thanks for your tip! I had exactly the same problem - horrible performance of a otherwise fast USB drive (Lacie Two Big, very neat device, hopefully the RAID 1 does its job ) - about 100 K/sec, together with awful noises coming from the disk.

    After I've reformatted the HD to non-journaling Mac Extended, the Performance is acceptable. With my (by today's standards old) Powerbook G4 I get about 3 MB/sec which is fine for me.
  • dabunting Level 1 (0 points)
    Can anyone name an external USB drive box that works?

    I have the exact same problem. I reformatted the drive to extended but it's no help at all. Copying a 74m file, predicted time was 75 hours, the progress bar showed only a hair line thickness of blue in 5 minutes.

    I'm using:
    Box is SimpleTech SimpleDrive Model 96300-40001-001 which is USB only (no Firewire) Drive is 250G Seagate Barracuda Ultra ATA 100, ST3250620A, 7200rpm, 5yr Warranty, 16MB Cache
    Switch is
  • Distantholler Level 1 (15 points)
    I have a sustained read/write speed of 5 MegaBytes/s (large files, lots of smaller files speed will drop)with the following setup:

    AEBS (Gigabit) with 7.2.1
    WD My Book Essentials USB 500 GB formatted Extended (NOT journaled)

    802.1 n/g, channel setting in automatic (tried setting this manually on free channels but the best pick was the channel the station picked itself)
    IPV6 set to LOCAL (otherwise known to cause trouble with this firmware)
    WPA/WPA2 personal

    Note: Where I live the air is not overly congested just three other networks seen.

    Not sure if any of this helps anyone out... Just wanted to share my working setup.
  • NichoTL Level 1 (5 points)

    The IPV6 setting did it for me. A 350MB file who used to take 15 min (!!!!!) over Ethernet (!!!!!!!!!!) now takes under a minute.
    Let's hope it stays like that.

    Many thanks.
Previous 1 2 3 Next