Skip navigation
This discussion is archived

UserEventAgent not responding.

18209 Views 55 Replies Latest reply: Jun 22, 2008 3:47 PM by Allen Watson1 RSS
  • casey.marshall Calculating status...
    Currently Being Moderated
    Oct 28, 2007 4:24 PM (in response to Mark.Burton)
    From the UserEventAgent man page:

    The UserEventAgent utility is responsible for loading plugins that provide for system response to user-generated events.


    That's pretty cryptic, and the plugins it loads (from /System/Library/UserEventPlugins) are:

    AirPortUserAgent.plugin
    AppleHIDMouseAgent.plugin
    BTMMPortInUseAgent.plugin
    BluetoothUserAgent-Plugin.plugin
    InstrumentsHotKeyAgent.plugin
    ParentalControlsUEAPlugin.plugin
    alfUIplugin.plugin
    iCalAlarmAgent.plugin


    I don't suppose this is helpful in answering the "do I need this?" question.
    iMac, Mac OS X (10.5), 2007 "Aluminum", 24 inch
  • Mark.Burton Level 2 Level 2 (465 points)
    Currently Being Moderated
    Oct 28, 2007 4:27 PM (in response to casey.marshall)
    Sounds fairly important doesn't it.
    MacBook Pro | 2.16Ghz | 2GB RAM | OS X 10.5
  • pinkhandbag Calculating status...
    Currently Being Moderated
    Oct 29, 2007 4:15 AM (in response to PhilZombie)
    I am getting this as well. Upgraded from 10.4.10 and I thought perhaps it was some incompatible third-party software causing it.. but people in this thread have done clean installs and still get it?

    In my case the process is responding but constantly using 100% cpu, same problem as others have mentioned about not being able to reboot.. it just beachballs.

    While UserEventAgent is at 100% cpu, Airport regularly drops out and reconnects (every 1-2 minutes), and if I'm typing at the same time, my key-repeat becomes hyper sensitive and I end up with lines and lines of the same character.

    Since not everyone is experiencing these symptoms, I wonder if we all share a similar peripheral? It seems to happen shortly after I (un)plug USB mouse/keyboard/hub .. but it's possible that's just co-incidence.

    I'm using some no-name hub, a Kinesis Freestyle USB keyboard and a Logitech LX7 cordless mouse. I also have a bus-powered external 2.5" USB2.0 disk. I'm going to try a fresh boot and introduce all of these one by one and I'll post if I find anything interesting.

    I am also going to try switching to wired ethernet and turning off bluetooth.

    If you have any more info on this problem, please share!
    Black MacBook 2GHz Intel Core Duo, Mac OS X (10.5)
  • shaka04 Calculating status...
    Currently Being Moderated
    Oct 29, 2007 4:22 AM (in response to pinkhandbag)
    I have the oposite problem to you. Mine is 'Not responding' but is taking up no CPU usage or RAM and isn't affecting performance at all. I'm just going to leave it alone as it doesn't seem to be affecting anything . . . so far.

    Message was edited by: shaka04
    MacBook 2GHz, Mac OS X (10.5)
  • Michael Wertz1 Calculating status...
    Currently Being Moderated
    Oct 29, 2007 6:19 AM (in response to Mark.Burton)
    Yes it does, but so far everything seems to work fine for me.

    I managed to install 10.5 onto my Ti-Powerbook (my god was that a chore), and on this system UserEventAgent runs without any problems. It hardly takes up any of the processor.
  • Michael Wertz1 Level 1 Level 1 (25 points)
    Currently Being Moderated
    Oct 29, 2007 6:23 AM (in response to pinkhandbag)
    Good idea, lets get a profile of the systems that are having problems.

    I am using an iMac core duo, the first intel iMac. 2 gigs of Apple ram. I also run a dual monitor setup.

    I have a Logitech MX Revolution mouse and a Wolfking Timberwolf keyboard. Neither of these had any driver software installed.

    I also have a Belkin USB hub, and a Logitech USB Microphone.

    Bluetooth is on but not paired to anything, and airport is disable. I used a wired connection.
  • pinkhandbag Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 29, 2007 6:40 AM (in response to pinkhandbag)
    For those of you who are seeing 100% CPU usage and performance issues, here's an update:

    In my case (see my previous post for background), I've narrowed it down to a conflict between one of the UserEventAgent plugins (AppleHIDMouseAgent.plugin) and my USB keyboard (Kinesis Freestyle).

    I edited /System/Library/LaunchAgents/com.apple.UserEventAgent-Aqua.plist and changed the command-line arguments for UserEventAgent to include -v (verbose logging to stderr) and -d (runs each plugin in a separate thread).

    The -v option did not produce anything interesting. The -d option helped though.

    Following a fresh reboot with no peripherals plugged in and no applications loaded, the system idles as normal. The moment I plug in my USB keyboard (to either USB port), the UserEventAgent process running AppleHIDMouseAgent.plugin jumps straight to 100% CPU and stays there even after I unplug the keyboard. The only way out that I've found is power-cycling. I also tried booting up with the keyboard plugged in with the same results.

    All my other USB devices work fine (Logitech LX7, Hub, HDD, Flash drive), although I do not have another USB keyboard to test with.

    While stuck at 100% CPU, watching the inspect pane in Activity Monitor for the AppleHIDMouseAgent.plugin shows the number of faults growing at around 100K+ per second, context switches at 1 per second, while all other fields remain static.

    The version of my AppleHIDMouseAgent.plugin (taken from version.plist):

    BuildVersion 116
    CFBundleShortVersionString 1.2.0
    CFBundleVersion 1.2.0b3
    ProjectName AppleHIDMouse
    SourceVersion 1200303

    I no longer use the Apple mouse so I've been able to fix the issue in my case by moving the plugin out of /System/Library/UserEventPlugins. After about an hour of testing, everything seems to be working fine.
    Black MacBook 2GHz Intel Core Duo, Mac OS X (10.5)
  • Damon Uyeda Calculating status...
    Currently Being Moderated
    Oct 29, 2007 9:52 AM (in response to PhilZombie)
    @pinkhandbag

    I have this problem too. I've tracked it down the the Kinesis Freestyle keyboard. Basically, the UserEventAgent process pegs at 99% when I plug this device in either through my USB hub or directly to my macbook pro. I have an older iMac G5 with 10.5 and the same thing happens when I plug the Kinesis keyboard in.
    MacBook Pro, Mac OS X (10.5)
  • pinkhandbag Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 29, 2007 10:20 AM (in response to Damon Uyeda)
    Hi Damon,

    Damon Uyeda wrote:
    I have this problem too. I've tracked it down the the Kinesis Freestyle keyboard.


    Interesting! Michael Wertz1 mentions he has the same problem too, although not with a Freestyle but another non-Apple keyboard.

    I've filed a bug report with Apple on this, and referenced this thread in my report. If anyone else has the same problem, it might pay to add your 2 cents here, and/or file a bug report (bugreport.apple.com).

    FWIW, the workaround I posted above has been working fine for me all day now.
    Black MacBook 2GHz Intel Core Duo, Mac OS X (10.5), 2GB RAM
  • paolo1888 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 29, 2007 11:36 AM (in response to pinkhandbag)
    So, can anyone tell me exactly what this Aqua.plist actually does? Why not just delete it?
    Mac OS X (10.5)
  • paolo1888 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 29, 2007 12:10 PM (in response to paolo1888)
    p.s. I get tiny speckles when using a Jaguar Aqua Graphite desktop.

    Anyone else? It's fine when I boot into my old 10.4 so not the screen...
    Macbook Pro, Mac OS X (10.5)
  • Michael Wertz1 Level 1 Level 1 (25 points)
    Currently Being Moderated
    Oct 29, 2007 5:17 PM (in response to pinkhandbag)
    Looks like you nailed it. On my testing partition I unplugged my keyboard and booted to it. Things were fine until I plugged the keyboard in, then UserEventAgent shot back to 100% and stayed there even after I unplugged it. Its definalty a problem with the keyboard.

    I removed AppleHIDMouseAgent.plugin and turned UserEventAgent back on for my main partition, and so far things are fine. UserEventAgent is running with a very small footprint. That is clearly what is causing my issue. I dont use an Apple Mouse either, is that all that plugin is for?

    I dont use the same keyboard you guys were talking about. The really odd part is my keyboard requires no drivers to work. Here is a link to what I use (and I cant say enough about it as an awsome gaming keyboard): http://www.amazon.com/WolfKing-DK2588U-Timberwolf-Gaming-Keyboard/dp/B000F0E2Z4

    I am going to pass on what I learned to the rep I worked with. Nice work tracking it down.
  • casey.marshall Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 29, 2007 7:54 PM (in response to Michael Wertz1)
    Same deal with me: Kinesis Freestyle keyboard, moving aside AppleHIDMouseAgent.plugin seems to solve it.
    iMac, Mac OS X (10.5), 2007 "Aluminum", 24 inch
  • Josh111111 Calculating status...
    Currently Being Moderated
    Oct 30, 2007 7:18 AM (in response to pinkhandbag)
    I also have this problem. Whenever I connect my Kinesis Freestyle USB keyboard to my MacBook Pro, the CPU goes to 100% because UserEventAgent uses all the CPU (according to Activity Monitor). Even after removing the keyboard, the problem persists.

    I'm not too happy with the workaround, because it seems that I must be losing some functionality---there must be some other option? I have also filed a bug report with Apple.

    Josh
    MacBook Pro, Mac OS X (10.5)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.