Skip navigation
This discussion is archived

AirPort doesn't connect after wakeup

13002 Views 112 Replies Latest reply: Jun 2, 2008 3:08 PM by William Kucharski RSS
  • old-pro Calculating status...
    Currently Being Moderated
    Dec 1, 2007 5:20 PM (in response to BobP1776)
    This worked for me also. I've been running clean now for about 10 hours with 6-8 sleep/wake cycles and all is well. I'll post again in a couple of days.
    Mac Book Pro 17, Mac OS X (10.5.1)
  • BobP1776 Level 3 Level 3 (695 points)
    Currently Being Moderated
    Dec 2, 2007 12:40 AM (in response to old-pro)
    I'm glad this is working for you guys! There is clearly some sort of order problem in the way the changes are being recorded so that it takes doing things in a particular ordered fashion to get a clean network setup.

    Hopefully some of the folks here more knowledgeable in what's going on behind the scenes will be able to use this to help figure out why the order of setting things up is so finicky.
    Powerbook G4 17" (1.5 GHz), Mac OS X (10.5)
  • Dazman Level 1 Level 1 (10 points)
    Currently Being Moderated
    Dec 2, 2007 3:24 AM (in response to BobP1776)
    Didn't fix the problem of my mac-mini not connecting to my home wifi after waking from sleep. Thanks anyway for going to all the trouble !

    Daz
    Mac OS X (10.5), mac mini
  • BobP1776 Level 3 Level 3 (695 points)
    Currently Being Moderated
    Dec 2, 2007 10:32 AM (in response to Dazman)
    Sorry it didn't work for you. When you went through the steps was there any variation in your computer from what I said would happen with each step? For example, did you actually get a connection upon doing the first "Join Other Network" step? Were you actually asked for a password the second time during the Diagnostics step?

    It would be great if we can figure out what the difference is with your try at this -- and maybe refine the procedure to work for you.

    One other thing to check: It is possible by now that your known network is in the list of known networks multiple times (Preference / Network / Airport / Advanced). If so, remove ALL of those instances and try again with the steps I outlined.

    Also, I'm doing this stuff in the "Automatic" network location. If you are trying it while set to use some other network "location" that may make a difference.
    Powerbook G4 17" (1.5 GHz), Mac OS X (10.5)
  • Dazman Level 1 Level 1 (10 points)
    Currently Being Moderated
    Dec 2, 2007 1:52 PM (in response to BobP1776)
    Sorry it didn't work for you. When you went through the steps was there any variation in your computer from what I said would happen with each step?


    Yes, the steps were all the same. However, when I went into Diagnostics it didn't prompt me for a password unless I selected "Use closed network" along with selecting the SSID of my home wifi. I could then enter my SSID/WPA/and password.

    One other thing to check: It is possible by now that your known network is in the list of known networks multiple times (Preference / Network / Airport / Advanced).


    No, it's only listed once. In my case it's called "HomeWiFi" with WPA Personal security. I'm also in the "Automatic" location.

    I've also disabled my Bluetooth, Built-in Ethernet, Built-in Firewire and IPV6 as suggested by others, but that hasn't helped either.

    I'll keep tinkering and see if I can make any progress, however I think it's more likely I'll need to wait for 10.5.2 or later ! I hope a new update is available soon.

    Daz
    Mac OS X (10.5), mac mini
  • Dazman Level 1 Level 1 (10 points)
    Currently Being Moderated
    Dec 2, 2007 2:27 PM (in response to Dazman)
    Hi Bob,

    I tried creating a new network location (I couldn't delete Automatic and have no locations) and renamed the new one to Network. I went through your steps again and it prompted me the first time to save the password in the keychain. However, as soon as my mac mini goes to sleep and wakes up the Airport changes to a status of On, but it doesn't then automatically connect.

    If I click the button "Turn Airport Off" then "Turn Airport On" a few times, it then changes it's status to Connected and is happy ! I could restart the mac mini and it would be fine too. But this is a problem Apple should be able to fix (they own the hardware so should be able to test better!). Someone else mentioned about some mac's forgetting their "frequency sequence with the network" ? so maybe that's the problem my mac mini has. It wakes up but forgets how it was sync'ing with my home ADSL/Wireless Billion router.

    Daz
    Mac OS X (10.5), mac mini
  • BobP1776 Level 3 Level 3 (695 points)
    Currently Being Moderated
    Dec 2, 2007 4:23 PM (in response to Dazman)
    Automatic is the "default" location that is supposed to figure things out for you on the fly.

    When you create a new "location" you are creating a new record to hold a specific set of network settings. Then you are supposed to be able to switch between locations in the Apple menu to easily switch from one network setup to another.

    So if I understand what you are saying, your Airport is working correctly, but in your case you couldn't do it in the Automatic location, but rather had to create a new location to hold the results. Correct?

    Also, you had to turn Airport off and on again a few times (using the icon in the menu bar) to get the network recognized the first time after doing these steps in the new location. Correct?

    I'm not sure what the difference is in your setup compared to the others that have worked. I'm just trying to document what finally made it work for you.

    I do not believe this is, at root, a hardware issue with your networking hardware or the type of password you are using. It feels much more like you need to make network setup changes in a specific order to get things properly recorded in the Mac so that the known network data is where it should be when you restart or wake from sleep. As such, Apple should be able to fix this.

    But it is very helpful if we can nail down a workaround procedure that makes this stuff get recorded properly with the current software.

    As it turns out, I had a variation on my stuff when I tried to connect to a T-Mobile network -- the type that makes you go through a login page in your browser before you really get access to the internet. I couldn't make it work in my Automatic location. But when I set up a new location (which I named "T-Mobile") it worked just fine. I believe the difference was that I had the OpenDNS servers added to the DNS Server list in my Automatic location, and T-Mobile's login screen might not be happy with that. Depending upon how your ISP operates, a similar thing might have been happening for you.

    In that case, creating a new "location" gave you a fresh start. That and the combo of steps posted above recorded things correctly. That still doesn't explain why you had to start and stop Airport a few times to get the initial good connection and make things fly properly.

    But at least we seem to be getting closer to the magic incantation to make this work.

    I would still recommend folks try this in their default "Automatic" location FIRST. No need to complicate things further if the Automatic location can be made to work for you.

    EDITED TO ADD: I don't believe disabling the other types of network connection or the IPV6 stuff was necessary to get this working for you. You could quite possibly turn them back on now and it would all still work. But if you don't NEED those things, and Airport is working fine for you right now, I would recommend you leave them just the way they are now. (If it ain't broke, don't fix it.)
    --Bob

    Message was edited by: BobP1776
    Powerbook G4 17" (1.5 GHz), Mac OS X (10.5)
  • Joseph Tate Level 1 Level 1 (80 points)
    Currently Being Moderated
    Dec 2, 2007 4:46 PM (in response to BobP1776)
    I'm having this problem, but running into some strangeness when I go through the steps below:

    -- Turn off Airport

    -- Go to System Preferences / Network. Click on the lock and authenticate with an administrator password if necessary.

    -- Select Airport in the column on the left.

    -- CLEAR the check box for "Ask to join new networks"

    -- Click on Advanced.

    -- CLEAR the check box for "Remember any network this computer has joined"

    -- Click on the known network in the list if it is already in there. Click on "-" to delete it from the list.

    -- Click OK to exit the Advanced pane. Click Apply in the main Network pane to make these changes take effect.

    -- Now turn on Airport. The network will not be selected of course since it is no longer "known".


    Here--as soon as I turn Airport back on it finds and joins the deleted network and reapplies a check to "remember networks" checkbox. It's like watching a ghost re-enable all the settings I just disabled.

    This sounds, to me (and I could be wrong) that the computer is not writing to whatever file holds that information. Where/what file stores these network settings?

    -jody
    MacBook Pro 2.4 GHz Intel Core 2 Duo, Mac OS X (10.5.1)
  • Dazman Level 1 Level 1 (10 points)
    Currently Being Moderated
    Dec 2, 2007 5:34 PM (in response to BobP1776)
    So if I understand what you are saying, your Airport is working correctly, but in your case you couldn't do it in the Automatic location, but rather had to create a new location to hold the results. Correct?


    No, I tried your instructions with the default Automatic location which was fine. However, when my mac still failed to automatically connect after waking from sleep I thought I'd try creating a new location to see if that helped..but it didn't. I've renabled the Bluetooth, Ethernet and IPV6 on this new location.

    Also, you had to turn Airport off and on again a few times (using the icon in the menu bar) to get the network recognized the first time after doing these steps in the new location. Correct?


    Yes, that's correct. My mac's networking will work fine when rebooted, or when I toggle the Airport on/off a few times. However it will never automatically connect after waking from sleep. I never had this problem with Tiger, the problem has only happened when I did an upgrade to Leopard. I'm quite sure it's a Leopard problem. I have a call open with Apple and they say it's a known problem (some have said that there's mixed messages from Apple as to whether they recognize it as a problem however - grin). See http://discussions.apple.com/message.jspa?messageID=6003030#6003030

    I've been lucky in that my networking seems to be reliable as long as the mac doesn't sleep. Others have had worse problems...

    Thanks again for your posts. If I work anything out I'll certainly let everyone know. For now I'll just keep my mac running. I have it setup as a HTPC with EyeTV, so would like it to be able to sleep when the problem is resolved. So for now I'll just keep it running

    Daz
    Mac OS X (10.5), mac mini
  • BobP1776 Level 3 Level 3 (695 points)
    Currently Being Moderated
    Dec 2, 2007 7:24 PM (in response to Joseph Tate)
    Jody,
    It sounds to me like you skipped the step to click "Apply" in the main Network preferences panel after clicking OK to exit the Advanced panel.

    I had this happen as well until I realized that you need to Apply the changes in the main panel (after making them in the Advanced panel) for them to get recorded. It is not sufficient just to OK them in the Advanced panel.
    --Bob
    Powerbook G4 17" (1.5 GHz), Mac OS X (10.5)
  • BobP1776 Level 3 Level 3 (695 points)
    Currently Being Moderated
    Dec 2, 2007 7:35 PM (in response to Dazman)
    Daz,
    Try this: AFTER you get the network to connect by turning Airport Off and On as necessary, I suggest you RERUN the Assist Me / Diagnostics portion of the steps posted above in the Preferences / Network pane.

    My guess is that one of two things are going on here. Either one of the settings updaters is not correctly retaining settings previously made (and thus the order in which the updaters are run is crucial) or the network is being recorded in the settings by more than one identifier and not all the changes are being made to the same identifier.

    The Diagnostics stuff seems to do a good job of getting things recorded properly EXCEPT for the option to actually "remember" the network. Once you have forced a "remember" (as demonstrated by the fact that turning Airport off and on gets you a connection, re-running Diagnostics at that point MAY get the rest of the settings in the proper places.

    I wonder whether any of this is due to running the Airport base stations in "mixed" mode (b or g or n speed networking all offered instead of just one) and the computer picking up the various possible speeds of operation as "different" networks that may each have only been partially "remembered" due to previous attempts.

    I'm sorry this is still giving you grief.
    --Bob
    Powerbook G4 17" (1.5 GHz), Mac OS X (10.5)
  • Dazman Level 1 Level 1 (10 points)
    Currently Being Moderated
    Dec 2, 2007 10:39 PM (in response to BobP1776)
    Hi Bob,

    Try this: AFTER you get the network to connect by turning Airport Off and On as necessary, I suggest you RERUN the Assist Me / Diagnostics portion of the steps posted above in the Preferences / Network pane


    Tried that but no go. I also tried:

    - Resetting the Billion ADSL/Wireless router's WPA password. My two XP laptops connect ok (after waking from sleep)
    - Deleted everything in the keychain and starting again...no go
    - Tried various other combinations

    I can reproduce the problem by just clicking "Turn AirPort Off" button. and then clicking "Turn Airport On". The Airport gives a status of On but reports "Airport is turned on but is not connected to a network"...thanks mac, I didn't realise that

    I wonder if there is an "Event Viewer" equivalent for the mac? I'll go searching the net to see if there is and maybe that could provide some clues..

    Daz
    Mac OS X (10.5), mac mini
  • BobP1776 Level 3 Level 3 (695 points)
    Currently Being Moderated
    Dec 3, 2007 1:09 AM (in response to Dazman)
    Can you borrow an Apple Airport base station? Hook that to your router via ethernet and configure your Mac to look for the wireless from the Airport base station. If that works we know the known network setup stuff is working on the Mac and the problem is the wireless handshake between the Mac and your normal wireless router. In the past, some 3rd party wireless routers did not play well with Macs.

    This could be as simple as the router refusing to re-issue the DHCP results to the Mac after it has already gone through it once.

    Try this: Do the steps to configure the Mac to remember the known network and its password (as posted earlier). Then do what you need to do (restarting the computer for example) to get the Airport networking going through your router. (If networking is going after the steps posted, then just start from there.) Now put your computer to sleep. Now reboot your router. Once the router is back up, then wake your computer from sleep. The router should now see the waking computer coming in as a first time connection.

    If that works, then check to see if you can find out the list of dynamic assignments the router is making in response to DHCP requests. It could be the router is counting the waking computer as a new request and this is pushing it over its license limit as to how many dynamic requests (i.e., wireless computers talking to it) it will support at one time. A workaround for that is to set up static DHCP assignments in your router -- a table that associates the computer networking hardware's "MAC ADDRESS" (which identifies the hardware in each computer) with a fixed IP number for the router to send out whenever a DHCP request comes in from that MAC ADDRESS. I.e, as opposed to dynamically assigning one from the pool of remaining unassigned IP address on the LAN.

    Such a problem should also leave some traces in the Console log -- complaints that DHCP did not return anything.
    --Bob
    Powerbook G4 17" (1.5 GHz), Mac OS X (10.5)
  • Dazman Level 1 Level 1 (10 points)
    Currently Being Moderated
    Dec 3, 2007 2:23 AM (in response to BobP1776)
    Can you borrow an Apple Airport base station?


    No, although I have another wireless unit I'll try tomorrow.

    I've tried with SSID broadcast turned off and on. No difference. Here are the system logs, the console logs didn't show anything interesting. Note, much of the logs after the first few lines is a result of my toggling the Airport on/off again a few times.

    * System Log with SSID broadcast off *

    Dec 3 19:56:57 my-computer kernel[0]: AppleYukon2: 00000000,23ae0000 sky2 - HardwareNotResponding, marking offline
    Dec 3 19:57:05 my-computer kernel[0]: AppleYukon2: 00000000,00000000 skqueue - SkEventDispatcher - ignoring event queue, hardware is not responding
    Dec 3 19:56:57 my-computer kernel[0]: System Sleep
    Dec 3 19:57:02 my-computer airportd[222]: Could not find any preferred networks; trying broadcast requests..
    Dec 3 19:57:05 my-computer kernel[0]: System Wake
    Dec 3 19:57:05 my-computer airportd[222]: Broadcast requests failed..
    Dec 3 19:57:20 my-computer mDNSResponder[15]: Note: Frequent transitions for interface en (FE80:0000:0000:0000:021C:B3FF:FEB0:BCF3); network traffic reduction measures in effect
    Dec 3 19:57:20 my-computer mDNSResponder[15]: Note: Frequent transitions for interface en1 (FE80:0000:0000:0000:021C:B3FF:FEB0:BCF3); network traffic reduction measures in effect
    Dec 3 19:57:23 my-computer airportd[222]: Error: Apple80211Associate() failed -3
    Dec 3 19:57:23 my-computer airportd[222]: Could not find any preferred networks; trying broadcast requests..
    Dec 3 19:57:24 my-computer mDNSResponder[15]: Note: Frequent transitions for interface en1 (FE80:0000:0000:0000:021C:B3FF:FEB0:BCF3); network traffic reduction measures in effect
    Dec 3 19:57:26 my-computer airportd[222]: Broadcast requests failed..
    Dec 3 19:57:28 my-computer airportd[222]: Could not find any preferred networks; trying broadcast requests..
    Dec 3 19:57:31 my-computer airportd[222]: Broadcast requests failed..
    Dec 3 19:57:38 my-computer mDNSResponder[15]: Note: Frequent transitions for interface en1 (FE80:0000:0000:0000:021C:B3FF:FEB0:BCF3); network traffic reduction measures in effect
    Dec 3 19:58:21 my-computer com.apple.service_helper[237]: launchctl: Error unloading: org.ntp.ntpd
    Dec 3 19:58:21 my-computer com.apple.launchd[1] (org.ntp.ntpd): Unknown key: SHAuthorizationRight

    * System Log with SSID broadcast ON *

    Dec 3 20:31:56 my-computer kernel[0]: System Sleep
    Dec 3 20:32:05 my-computer kernel[0]: System Wake
    Dec 3 20:32:02 my-computer airportd[281]: Could not find any preferred networks; trying broadcast requests..
    Dec 3 20:32:05 my-computer airportd[281]: Broadcast requests failed..
    Dec 3 20:32:26 my-computer mDNSResponder[15]: Note: Frequent transitions for interface en1 (FE80:0000:0000:0000:021C:B3FF:FEB0:BCF3); network traffic reduction measures in effect
    Dec 3 20:32:26 my-computer mDNSResponder[15]: Note: Frequent transitions for interface en1 (FE80:0000:0000:0000:021C:B3FF:FEB0:BCF3); network traffic reduction measures in effect
    Dec 3 20:32:30 my-computer mDNSResponder[15]: Note: Frequent transitions for interface en1 (FE80:0000:0000:0000:021C:B3FF:FEB0:BCF3); network traffic reduction measures in effect
    Dec 3 20:32:30 my-computer airportd[281]: Error: Apple80211Associate() failed -3
    Dec 3 20:32:30 my-computer airportd[281]: Error: Power unexpectedly off, bailing - Apple80211GetPower() = off (0)
    Dec 3 20:32:30 my-computer airportd[281]: Could not find any preferred networks; trying broadcast requests..
    Dec 3 20:32:30 my-computer airportd[281]: Error: Apple80211Scan() error 82
    Dec 3 20:32:30 my-computer airportd[281]: Error: __performScan() failed (82)
    Dec 3 20:32:35 my-computer mDNSResponder[15]: Note: Frequent transitions for interface en1 (FE80:0000:0000:0000:021C:B3FF:FEB0:BCF3); network traffic reduction measures in effect
    Dec 3 20:32:37 my-computer configd[14]: LINKLOCAL en1: parent has no IP
    Dec 3 20:32:39 my-computer System Preferences[206]: Error: Apple80211Scan() error 82
    Dec 3 20:32:39 my-computer System Preferences[206]: Error: __performScan() failed (82)
    Dec 3 20:32:40 my-computer mDNSResponder[15]: Note: Frequent transitions for interface en1 (192.168.1.3); network traffic reduction measures in effect
    Dec 3 20:32:40 my-computer mDNSResponder[15]: Note: Frequent transitions for interface en1 (FE80:0000:0000:0000:021C:B3FF:FEB0:BCF3); network traffic reduction measures in effect
    Dec 3 20:32:45 my-computer mDNSResponder[15]: Note: Frequent transitions for interface en1 (FE80:0000:0000:0000:021C:B3FF:FEB0:BCF3); network traffic reduction measures in effect
    Dec 3 20:32:49 my-computer ntpd[240]: sendto(17.82.254.7) (fd=23): Network is unreachable
    Dec 3 20:33:03 my-computer mDNSResponder[15]: Note: Frequent transitions for interface en1 (192.168.1.3); network traffic reduction measures in effect
    Dec 3 20:33:19 my-computer [0x0-0x29029].com.apple.systempreferences[206]: DOCK: CFMessagePortSendRequest returned -2

    I've also tried restarting the router whilst the mac was asleep and fixing the mac's IP address on the router. Still no go

    Like I said, I never had any problems with Tiger so I'm quite certain it's Leopard (and given other posts with similar problems). Hopefully Apple are watching the forums and this helps with debugging the problem. I might even call Apple tomorrow and ask if they want to collect some logs or something. They've had my support call open for quite some time.

    Daz
    Mac OS X (10.5), mac mini
  • marco langmann Calculating status...
    Currently Being Moderated
    Dec 3, 2007 3:29 AM (in response to tbo)
    I got exactly the same problem: I am very, very disappointed with the "so called" geniuses of Apple support. Hours and hours over the phone to sort nothing. My bt home hub apparently needs some kind of update for a system, Leopard, which are not available yet. In order to use internet I had to plug the Ethernet lead....Unbelievable!!!!!
    iMac, Mac OS X (10.5.1)
1 2 3 4 5 ... 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.