Previous 1 12 13 14 15 16 Next 235 Replies Latest reply: Feb 13, 2008 5:25 PM by planetfab Go to original post
  • IanDalgleish Level 1 Level 1 (0 points)
    I've followed Apple's recommendations to the letter but I'm still unable to get TM to work properly. I have a PowerPC G4. I'm using a brand new LaCie 500 GB external drive, partitioned as 'Apple Partition Map'. I changed my computer's name to 'NewG4' (minus the quotes).

    I attempted to repair disk permissions on my internal drive (the one containing OS 10.5.1) but that doesn't wotk either - blue bar moves about 1/4 of the way across, says it will take 1 minute, then takes forever, so I stopped it!

    TM appears to work initially but eventually it will stop working. The System Preference says it's 'backing up' but no blue bar appears and it doesn't back up.

    I cannot use something as unreliable as TM so I'm looking forward to the 'Leopard' release of SuperDuper.

    If anyone else has had similar problems please let me know.
    Better still, does anyone knows how to solve them ?

    Ian.
  • jsruok Level 1 Level 1 (0 points)
    I too got the "Time Machine Error - Unable to complete backup" error message. But happily, I got it fixed. I don't know which of the following steps did the trick, but so far the TM seems to working. (NB. I haven't tried restoring the backup.)

    System: Mac Mini (internal HD is a goner), system on a 500 GB Lacie Brick (USB), TM on a 750GB iomega ext. HD (FireWire).

    Steps I took:

    * updated to OS X 10.5.1 (this wasn't enough, though)
    * renamed TH HD so that the name didn't use any spaces
    * erased the TM HD (using GUID partition as I'm using the HD on an Intel Mac Mini)
    * unplugged the system HD from my USB hub and connected it to mini
    * excluded Applications, Library, System, mini_Users folders from root and Music folder (over 30GB, wanted to make TM work a bit faster) from one user

    And TM worked. I then removed all the folders (exept mini_Users as its backup still was painfully slow) from the TM exclude list, one by one, running TM backup in between. Still worked.

    But as stated, I haven't tried restoring the backup yet.

    (What is the mini_Users folder? It was restored from the backup of my Mini's internal HD, it's Users folder to be more precise. For some reason (maybe because it has the permissions and modes according to the previous system installation) backing up that folder is really slow.)
  • Donna Thomas Level 4 Level 4 (2,465 points)
    Hi jsruok

    I'll bet the slowness you're experiencing is to do with the USB drive. From what I remember the LaCie brick has a slow HD in it whereas the Iomega has a fast HD. Despite the fact the USB2 is claimed to be faster than Firewire (according to the spec), in reality it isn't.

    I'm now using a MacPro with 3 internal drives (1 dedicated to TM) and all have spaces and hyphens in their names and my backups now take 2 or 3 minutes. I do it on-demand when I feel I have done enough to warrant running it.

    I have tested its backing up capabilities by accidently deleting 2 pages of an essay on child psychology. Thankfully TM had the previous day's version for me to recover.
  • dvdz Level 1 Level 1 (0 points)
    I checked with Apple Support by phone to verify that reformatting my Newer Tech mirror disk to GUID format would solve the error problem being discussed in this thread. Support said it would. So I created one GUID partition on the disc.

    Support also asserted that the problem would not appear with 10.5.1, so I also updated.

    With GUID format and 10.5.1, Time Machine backed up 110 GB in a few hours and seems to be operating smoothly.

    It is great to have that annoying mysterious error problem solved.
  • FBL1 Level 1 Level 1 (10 points)
    I've been doing successful Time Machine backups to an external drive that is partitioned into two volumes - one as Mac HFS+ for the Time Machine backups, and one as NTFS for my Bootcamped Windows applications. This drive was formated using the "Master Boot Record" format, not the GUID, but everything seems to be functioning just fine.
  • Geoffrey Packwood Level 1 Level 1 (0 points)
    I installed Time Machine on my 500GB external ECOCase drive about ten days ago.

    After the initial backup which took a long time understandably, it worked perfectly until yesterday and now I am also getting the alert Time Machine Error - Unable to complete backup. An error occured while creating backup directory
  • Steve Sweitzer Level 1 Level 1 (45 points)
    It's working! I hope this fix will help some others.

    I just started this note to report that TM wasn't working and then decided to see what would happen if I created 2 partitions instead of just one. To my total amazement it seems to be working.

    Prior to this I was having no luck getting TM to work on my G4 (it was working on my G5).
    Followed the instructions for reformatting the drive as "Apple Partition Map" as instructed by Apple for PowerMacs. Made sure there are no funny characters in name (TimeMachine) and upgraded to 10.5.1
  • Jerry D Level 1 Level 1 (60 points)
    I'm beginning to think that there is a USB Polling problem. I can turn my iMac on and off multiple times and unplug and plug the USB cable multiple times and maybe one out of a hundred (no exaggeration) the System will see the Drive has been added. Recently, I noticed that every time I go to Bootcamp (Vista) and return to OSX Time Machine is gone. SInce Vista can't see the Mac formatted drive, I thought maybe the Drive gets confused (unfortunately, it's a Smart Drive - Seagate FreeAgent) and go into some unknown state that keeps it from being recognized upon return to OSX. So I formatted a piece of the drive as Fat32, which is recognized by Vista (side benefit being that I can transport some file types back and forth). Vista can always see the drive, even when it's gone on the Mac side. In fact, albeit a lengthy process - I can use Vista to wake the drive up when it disappears from Leopard by going back and forth. I must admit this is getting exasperating.

    My G4 with two internal IDE Drives NEVER displays this anomaly of losing the Time Machine Drive. I wish I had not purchased this new iMac and waited for the next MacPro upgrade so I could stick with Internal Drives.

    I honestly think that USB is a Flakey Technology on a good day.
  • rwellscs Level 1 Level 1 (0 points)
    I upgraded from Tiger to Leopard 10.5.1 in mid-Nov, got a Buffalo MiniStation HD PO250U2 pocket USB 250GB disk, and got Time Machine working with it with no problems. The Buffalo is very small and has a short USB cable that wraps around its case, I carry it in a zip pocket of my laptop bag. It backed up flawlessly for over two weeks, the only tiny glitch being that it would periodically drop off line during a backup and then reappear and keep going, without my touching the cable.

    Last Thursday I applied some command line patches from a forum that turned out very badly, and after several desperate hours I decided to rescue myself by inserting the Leopard install disk, letting it reboot, and then using the Utility menu to initiate a Time Machine complete system restore from the backup disk, as of 6:19am that morning, before I woke up and broke it. It took less than 2 hours and worked great.

    BUT: I realized after a couple of days that I had not had a successful backup since the restore. It would take a very long time "preparing...", and then would fail, with the same error others have been reporting in this thread. I read this thread and many others, and came up with the following procedure, which led to a clean full backup and quick and successful hourly backups running smoothly again.

    I'm curious as to whether anyone else has experienced backup failures after a complete system restore to an older backup?


    1. In a terminal window, do the following command soon after a failed backup to get a better idea of what the problem may be:

    more /var/log/system.log

    2. Go to the Time Machine Preferences, turn the big sliding switch off, and pick None in the Change Disk... dialog, to break the association with the Time Machine Backups disk.

    3. Go to Sharing Preferences and set the computer name to something short and simple, composed of only letters and numbers, and change it in both the "Computer Name: " field and the dialog you get with the Edit... button next to it. I use "rwellsmac".

    4. Open a Terminal and do the following commands to remove the Time Machine preferences file (check syntax and exact names, this is from memory, and may get reformatted by the mailer):

    cp /Library/Preferences/com.apple.TimeMachine.plist ~/com.apple.TimeMachine.plist.bad
    sudo rm /Library/Preferences/com.apple.TimeMachine.plist

    5. Run the Disk Utility app in /Applications/Utility, and use it to reformat the failing Time Machine disk drive. I reformatted as FAT, to provoke the 10.5.1 Time Machine to reformat it again to its liking.

    6. Use Disk Utility First Aid on the disk(s) to be backed up, Verify Permissions, and Verify Disk. Do Repair Permissions and Repair Disk if needed.

    7. In Time Machine Preferences, I selected the drive to be used as backup, and let it reformat it (again), which does not take very long. I left it with the default new name of "Time Machine Backups". I turned off the Time Machine so I could control when the backup starts.

    8. In Time Machine Preferences, make sure the Time Machine Backups disk is excluded. Also exclude your VMWare Virtual Machines directory, Parallels directory, and traditional Backup directory, if you have them. Search for "Machine" in the VMWare Fusion release notes for VMware Fusion Version 1.1 RC1, Build 61385, at http://www.vmware.com/beta/fusion/releasenotes_fusion.html, for more information on why VMWare should be excluded. I excluded my Parallels folder for the same reasons. I excluded my Backups folder where I did internal backups before Time Machine, because it is big and redundant.

    9. In Spotlight Preferences Privacy tab, exclude the Time Machine Backups disk, to avoid interference.

    10. Make sure your USB backup disk is plugged into a direct port and not into a USB hub. Also people have reported problems with Bluetooth being used at the same time as the backup, and with trying to back up "corrupted" JPG files. None of these were problems for me.

    11. Shut down applications and Restart your machine. Then turn Time Machine on in the preferences, and wait for it's backup time and let it do the first full backup in peace, without other applications running and complicating things.

    That's it!
  • Jerry D Level 1 Level 1 (60 points)
    You mentioned:

    6. Use Disk Utility First Aid on the disk(s) to be backed up, Verify Permissions, and Verify Disk. Do Repair Permissions and Repair Disk if needed.

    None of my USB connected Drives allow Permissions to be Verified or Repaired. Am I missing something here?
  • Jannis Level 1 Level 1 (0 points)
    Thanks, worked great for me !
  • rwellscs Level 1 Level 1 (0 points)
    Ah, I mean to run First Aid on your working disk, the one that will be backed up to the USB drive, for example the internal 80GB HD in my MacBook. It will repair permissions on the OS X installation files, and some people have reported that this helps get Time Machine working successfully.
  • ian314159 Level 1 Level 1 (0 points)
    Let's face it people, TM is buggy. Sure works for some people, but the "solution" people have discovered on this thread is NOT a solution.

    Exclude Library, System and Applications folders from TM to get it to work? Those are the most important files! What a joke. There's no point in using any backup program if you can't backup the most important stuff. Sign...

    I'm gonna try one last time a suggestion on this board. I refuse to exclude those folders in any of my backups.

    And if it doesn't work, no more TM until a reliable patch is found. I've wasted too much of my time tinkering with this goddam problem.
  • Kami78 Level 1 Level 1 (0 points)
    Yes it is buggy ! No geek discussions will change that. You are perfectly right not to use TM as long as Apple does not offer a decent patch and you are not alone !
  • VERN ROBERTS Level 1 Level 1 (0 points)
    Apple has posted a resolution to this issue. It appears to be tied to the type being set to MBR which is used for Fat32 & NTFS Partitioning.

    The fix is to reformat the drive using:

    "Apple Partition Map" partition scheme if the disk will be used with Time Machine and a PowerPC-based Mac

    And "GUID" partition scheme if the disk will be used with Time Machine and a Intel-based Mac.

    Full details available in the KBase at:

    Mac OS X 10.5: Time Machine stops backing up to external disk
    http://docs.info.apple.com/article.html?artnum=306932

    Hope this helps!