Previous 1 2 3 Next 69 Replies Latest reply: Feb 20, 2008 11:42 AM by jaguar_man
barrydix Level 1 (5 points)
I have an SMB NAS drive that connected fine in 10.4. However, with 10.5, on my MacBook Pro I can connect to it and can see the 2 volumes on it but can't do anything with them, and can't disconnect from it once connected. On an iMac G5 also upgraded to 10.5, it starts to connect and then locks up. I can connect to the NAS with FTP with no problem but not through sharing.

MacBook Pro, Mac OS X (10.5)
  • Kevlong Level 2 (330 points)
    Yes, same problem here.

    I've updated a new, (1wk old) MacBook Pro with Leopard and cannot connect to any shares on my trusty Synology NAS. NAS works fine and is accessible by both a Windows XP machine and an iMac G5!!

  • Kevlong Level 2 (330 points)
    Me again,

    Poking around, I found a temporary fix. Type in:
    Where IP-ADDR is the address of the NAS. Leopard requested a password again and this time it worked OK!!

  • Serge Germain Level 1 (0 points)
    Sorry, i try and my computer freeeze also.

    iBook G4

  • snowmusicman Level 1 (0 points)
    Same problem here, my MB used to connect ok to my NAS drive in Tiger (although not as reliable as through windows) but after a clean install of Leopard I can see the drive but can't see any folders. Very disappointing, since I was waiting to see some improvements on this field, which has been very left aside by apple...
  • realityCzar Level 1 (5 points)
    I, too, am unable to mount an SMB NAS on a G5 running 10.5 via the Finder. Using Go->Connect to Server and specifying any combination of hostname or IP address with or without user name, I am prompted for the password and a dialog box (that cannot be closed except by relaunching Finder) pops up saying it is connecting, but no connection is ever made.

    I can mount the drive from the command line using mount_smbfs if I manually create the mount point in /Volumes, and it is then usable for reading and writing, and will unmount via the Finder GUI. It sure would be nice not to have to go to all that trouble, though.
  • Jeffe16 Level 1 (0 points)
    I'm in the same boat with the dialog with the status bar never going away. I've also tried a ton of combinations. I can connect to any share via smbclient, but I can't use mount_smbfs, I get a "broken pipe" error. This is driving me crazy. I'd really be happy to just get mount_smbfs working, I can live with running a single command when I boot and need to connect (not any more effort than using "connect to server...", really).
  • Stm10 Level 1 (0 points)
    How do you use mount_smbfs from the Terminal to mount your SMB Shares that Finder will not mount?

    An example of the command you are using would be great.

    I get the "Broken Pipe" error too when running mount_smbfs.

    Message was edited by: Stm10
  • barrydix Level 1 (5 points)
    Tried this but still not working

    This is really bad. I have upgraded two of my machines to 10.5 but left a third (20 inch iMac G5) on 10.4. That one has no problems connecting to the NAS drive. That and finding out that you can't use Time Machine with an SMB drive, I'm beginning to wish I hadn't bothered upgrading.
  • Nicholas Dring Level 1 (15 points)
    I can confirm that the smb://username@ip address workaround is working.
    I only had to do this connecting to xp boxes.
    My windows 2003 servers and windows 2000 run fine.
    I think they are other pc connection issues that hopefully apple will get straight on with fixing. I do think once these problems are fixed we will all agree that the mac to pc part has been greatly improved in Leopard.
  • Jeffe16 Level 1 (0 points)
    Ok, I got it working at 3am last night, and I'm embarrassed to say how. Case sensitivity. My logins differ by the case of the first letter, so I used the syntax to add that and it worked. And I'd swear I did that already at some point, and/or when using the full mount syntax, so I don't know.

    The thing that now ticks me off is, why did this all work fine in Tiger??? I have a theory which I won't get to explore until after work - perhaps the Keychain corrupted? I wonder since whenever I try mounting via the go menu (that still doesn't work, by the way), it prefilled my long name as the user. Now, logically, when I first connected months ago, I would have added the capitalized username in that dialog the first time and been done, which is why I took it for granted that it just would work. So now I'm wondering if no matter what I type, it's ignoring me and trying to log in with my long name from the go menu or the network thing in the finder. There have been some rumblings about some people's Keychains getting borked a bit, so maybe...

    Strm, since you asked specifically, I was using (I hope this is right, I'm not on the Mac right now) mount_smbfs //User@machine/sharename /Volumes/whatever
    If I'm wrong, the @ is a colon. It's annoying that there are all these subtle differences in syntax Also, when I trashed the volume in the UI, it seemed to automatically delete the directory I mounted to, so you may have to keep recreating it. Anyhow, that brings up something else interesting (or not)...I'm not having the IP problem...I can refer to my PC by it's network name in the command line no problem. I think that may be further evidence that my problems, at least, aren't in the smb setup per se, but in the Finder interaction.

    Message was edited by: Jeffe16
  • realityCzar Level 1 (5 points)
    Yes, "mount_smbfs //uSeR@host/share /Volumes/share".

    And Jeffe16 is correct, I also find that trashing the drive in the Finder that the mount point I manually created in Volumes is deleted.
  • emmanuel.gomez Level 1 (0 points)
    I was previously unable to connect to SMB shares on the windows network where I work. My password to access resources on said network contains some symbol/special characters.

    What worked for me was URI escaping my password prior to submitting it. To try this yourself, type (in Terminal):
    ruby -ruri -e 'puts URI.escape("YourPasswordHere")'

    Copy/paste the result to the username/password dialog and connect away! I suspect this will only help if you have special characters in your password (*^%$#@!~`, etc), but if you do, it may be worth a try.
  • realityCzar Level 1 (5 points)
    Well, well. The URI-encoding worked for me. Thanks, Emmanuel.
  • darknater Level 1 (10 points)
    Wow, worked for me too:


    type in the result from the ruby command for the password.

    My password did have one of those characters in it.
Previous 1 2 3 Next