Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Inconsistent Ping Times with MacBook Pro

I have a MacBook Pro 2.2 15" (Santa Rosa), and I also have a PowerBook G4 1.5ghz. I have them both on my desk sitting next to each other.

Both of them are pinging my wireless router (a Linksys WRT300N). The PowerBook gets consistent ping times of around 4-5 milliseconds, sometimes a bit higher, up to 20 or so.

The MacBook Pro gets ping times ranging from 5ms to about 1200ms, in regular patterns. About every 6th ping is over a second (sometimes as high as over 2 seconds). It's absolutely regular, and only happens on the MacBook Pro, not on the PowerBook.

This happens with different routers as well, so it seems to be a problem with the Mac. Sound like a hardware problem? Anyone else have a problem like this?

MacBook Pro 2.2ghz, Mac OS X (10.4.10)

Posted on

Reply

Page content loaded

Oct 31, 2007 12:38 AM in response to eyepaq In response to eyepaq

Bummer, latency. I'm thinking that the MBP has TCP/IP set differently for initial contact than the PB? Are the two laptops running the same version of OSX? Does only the MBP have firewall on (System Preferences > internet > personal > sharing. Ascertain settings are duplicated for both laptops. I would turn off bluetooth, etc, for this testing also. In system preferences > network, click on "Show: Network Port Configurations," and have "on" only airport, both laptops, for this comparison ... just to level the playing field?

I use Sustworks NetTuner: 21 day free trial; then, like $30. The ping is I think affected by your MBP configuration, which must be different than the PB's initial, starting-point, TCP/IP

check these sites:

http://www.sustworks.com/site/prodiptxoverview.htm
" ... Why is it Sometimes Necessary To Tune TCP/IP?
TCP/IP is not controlled by any manufacturer and is designed to
work on almost any kind of underlying network with widely varying
characteristics. To meet this challenge, the protocol designers made TCP adaptive. TCP is self monitoring and optimizes its own behavior to match the
network environment. Adaptation takes time and the default
settings cannot optimize for every possible kind of network. Why can't somebody just write a utility that analyzes my network and automatically selects the optimum settings? Such a tool would be both useful and popular. The answer is they already have, it's called TCP/IP, but sometimes it needs a little help. In most cases, TCP works remarkably well all by itself. Tuning is needed
in those cases where TCP doesn't quite get it right because the the
network behavior is outside the expected range. Typical problems include:
Asymmetric connections that are much faster downstream than
upstream.
High performance connections with relatively long latency
(measured in bytes) such as fiber optic, satellite, or PPP via
cellular network.
PPPoE implementations that restrict the network MTU without
support for "Path MTU Discovery" or fragmentation.
Heavily congested links. Tuning can't solve everything. You may
need to restructure your network or use packet shaping to control
traffic flows <http://sustworks.com/site/app note1006.html>.
The key to optimization in such cases is to measure, adjust, repeat.
Notice it's not necessary to find the perfect settings, only to get close
enough that TCP works efficiently in your environment. The tools included
with IPNetTunerX are designed to make this easy and show how well TCP
is actually working.

http://www.freesoft.org/CIE/Topics/53.htm

" ... Fluctuating Round Trip Times
Another fact of life. Pretty much caused by the same things that cause packet loss. Again, not serious cause for alarm, but don't expect optimum performance from TCP. Remember that TCP generates an internal RTT estimate that affects protocol behavior. If the actual RTT changes too much, TCP may never be able to make a satisfactory estimate. Both dropped packets and RTT fluctuations may occur in a periodic nature - a batch of slow packets every 30 seconds, for instance. If you see this symptom, check for routing updates or other periodic traffic with the same period as the problem. Poor network performance can often be traced to slow links being clogged with various kinds of automated updates. ..."


http://www.apple.com/macosx/leopard/technology/unix.html

Self-Tuning TCP.

Leopard gets the best possible bandwidth from either broadband or narrowband networks by optimizing buffer sizes according to the local resources and connection type. Starting with a larger window helps TCP with ongoing dynamic optimization. This is especially valuable when connecting to high-bandwidth/high-latency networks like Verizon’s FiOS, which previously required specialized tools such as Broadband Tuner. ...

http://www.psc.edu/networking/projects/tcptune/
Tuning TCP for Mac OS X
Mac OS X has a single sysctl parameter, kern.ipc.maxsockbuf, to set the maximum combined buffer size for both sides of a TCP (or other) socket. ... blah blah

Beam me up already. Just work, and be fast about it already~

Oct 31, 2007 12:38 AM

Reply Helpful

Nov 1, 2007 4:51 AM in response to Poha In response to Poha

So to answer your questions..

- Both are running Leopard
- Firewall is off on both.
- Only Airport enabled on both

I can understand tuning to try to maximize throughput but the kind of latency I'm seeing is way beyond what tuning would be able to help with. Check this out:

PING 192.150.23.1 (192.150.23.1): 56 data bytes
64 bytes from 192.150.23.1: icmp_seq=0 ttl=64 time=2.457 ms
64 bytes from 192.150.23.1: icmp_seq=1 ttl=64 time=1107.883 ms
64 bytes from 192.150.23.1: icmp_seq=2 ttl=64 time=109.092 ms
64 bytes from 192.150.23.1: icmp_seq=3 ttl=64 time=3.383 ms
64 bytes from 192.150.23.1: icmp_seq=4 ttl=64 time=2.060 ms
64 bytes from 192.150.23.1: icmp_seq=5 ttl=64 time=2.034 ms
64 bytes from 192.150.23.1: icmp_seq=6 ttl=64 time=1107.129 ms
64 bytes from 192.150.23.1: icmp_seq=7 ttl=64 time=108.167 ms
64 bytes from 192.150.23.1: icmp_seq=8 ttl=64 time=2.111 ms
64 bytes from 192.150.23.1 : icmp_seq=9 ttl=64 time=2.049 ms
64 bytes from 192.150.23.1: icmp_seq=10 ttl=64 time=2.161 ms
64 bytes from 192.150.23.1: icmp_seq=11 ttl=64 time= 1103.365 ms
64 bytes from 192.150.23.1: icmp_seq=12 ttl=64 time=104.465 ms
64 bytes from 192.150.23.1: icmp_seq=13 ttl=64 time=1.947 ms
64 bytes from 192.150.23.1: icmp_seq=14 ttl=64 time=2.157 ms
64 bytes from 192.150.23.1: icmp_seq=15 ttl=64 time=2.041 ms

I tried using IPNetTunerX, and it didn't help.

Nov 1, 2007 4:51 AM

Reply Helpful

Nov 3, 2007 11:40 AM in response to eyepaq In response to eyepaq

Aloha Eyepaq, the IPNetTunerX I use, to initially tune the (dynamic) TCP/IP so I can more reliably get a connection on my at&t aircard ...

To resolve the latency issue, maybe try Eamonn's suggestion, here:
http://discussions.apple.com/thread.jspa?messageID=5393123&#5393123
"Hi. This may seem like a very simplistic suggestion but I make my living as a Mac Consultant and see this problem regularly. It is my only (?) criticism of the Apple Networking Preference pane (actually I have a few!). Unlike Windows (am I actually saying this??? 🙂 ) the Mac doesn't intuitively pick up the DNS server addresses and the delay is while it is searching forlornly for a server to translate www.whatever.co.uk into machine speak. I ALWAYS (through ** or high water) find out what DNS Server addresses the ISP is using and manually enter them into the Network Preference Pane. This usually resolves slow loading. If you are already doing this then you have some other router issue or a browser issue. Are you using Firefox perchance? I find it dreadfully slow despite all its good press.
Good luck, Eamonn"

So, if you would check on both laptops the System Preferences > Internet and Network > Network > TCP/IP > DNS Servers (optional), see if the faster laptop has the DNS Server named, and your MBP is blank? If so, enter the DNS Server address and re-ping?

The import of Latency is delved into, here:
http://rescomp.stanford.edu/%7Echeshire/rants/Latency.html

Nov 3, 2007 11:40 AM

Reply Helpful

Nov 4, 2007 3:59 AM in response to eyepaq In response to eyepaq

I talked to Apple Support about this problem and while the Product Specialist I eventually got to speak to hadn't heard of any problem like this, he had me delete a number of configuration files, and that actually fixed the problem!

It looks like the one that did the trick was:

/Library/Preferences/SystemConfiguration/com.apple.airport.preferences.plist

Deleting that and rebooting caused the latency to just go away; now I have a consistently fast wireless connection.

Diffing that file between what I had before and what I have now, I can't see anything that would obviously cause this problem, but some 802.1X settings are gone, and a number of settings like InterferenceRobustness and JoinMode that were previously specified are not in the new file. Maybe it was some interaction between the settings in this file that was causing it, I don't know.

Anyway, just wanted to pass on my resolution. The files he had me delete were (all in the same folder):

NetworkInterfaces.plist
preferences.plist
com.apple.airport.preferences.plist
com.apple.network.identification.plist

Nov 4, 2007 3:59 AM

Reply Helpful (1)

Nov 5, 2007 9:20 PM in response to eyepaq In response to eyepaq

such great joy that you are resolved, by deleting those files, and now have the speed. So after the files are deleted, the next time up they are recreated like pref files? So they were corrupted ... a system restore would have helped same ?

I see w/TextWrangler, in my MacintoshHD/library/ Preferences/ SystemConfiguration/ com.apple.airport.preferences.plist, the interference robustness <0>

Maybe I specified that in a config. I'll delete those 4 files, reboot, and check out my latency in airport soon. My ping in AT&TAircard is like 0.3ms, same for 10 pings. The JoinMode <0> and List of known networks > Scan Channels <6>, is delay-inviting, IMHO? Like not having the DNS address specified?

Happy you are fast now.

Nov 5, 2007 9:20 PM

Reply Helpful

Nov 23, 2007 11:32 AM in response to eyepaq In response to eyepaq

I would just like to add that this solution fixed my latency problems in Leopard with a 15-inch 1.33GHz PBG4 that was upgraded from Tiger --> Leopard.

I was having the same issues, where over an 802.11g network I was getting ridiculous ping times, varying from 600ms - 50ms where my other computers on the same network were getting 1-5ms times.

Many Thanks!

- Rick

Nov 23, 2007 11:32 AM

Reply Helpful

Nov 23, 2007 1:58 PM in response to eyepaq In response to eyepaq

WHEW! This was a really wacky problem and I was starting to wonder if I'd ever figure out how to fix it.

/Library/Preferences/SystemConfiguration/com.apple.airport.preferences.plist


I deleted just that one file and rebooted and the problem is gone! THANKS!

BTW here's a tip for folks trying to identify this issue. Try this:
1) Quit Terminal.app (it won't notice the system sound change unless you do so)
2) Change your system sound to something very short, like Tink.
3) Open Terminal.app and run this command:
sudo ping -a -i .25 192.168.0.200

'-i' sets the ping interval, so '-i .25' is 1/4 second.
sudo is required so you can ping more than once per second.
'-a' makes the echoes audible.
The IP address is for my wireless base station, so you'll need to customize that.

If you have the problem, the sounds will be very irregular, bunched up every few seconds, with a second or so of silence between bunches.

After you've fixed it, you'll hear a very steady rhythm of ping responses.

This is also a useful technique for detecting packet loss - you can also switch out the -a for the uppercase -A, which makes a sound only for dropped packets instead of for all successful packets.

Thanks for the solution!

Nov 23, 2007 1:58 PM

Reply Helpful
User profile for user: eyepaq

Question: Inconsistent Ping Times with MacBook Pro