1 4 5 6 7 8 9 Previous Next 124 Replies Latest reply: Jan 23, 2009 11:32 AM by wolfcakes Go to original post
  • 75. Re: Audio cd disappears after confirming import
    StarDeb55 Level 6 Level 6 (19,685 points)
    No, there is no fix. Several people have posted workarounds. You might see if one those works for you.
  • 76. Re: Audio cd disappears after confirming import
    Chlorinedream Level 1 Level 1 (0 points)
    Should I just return the unit for a replacement drive? I've only owned the MBP for 4 days
  • 77. Re: Audio cd disappears after confirming import
    StarDeb55 Level 6 Level 6 (19,685 points)
    No, there is no fix. This is happening on brand new systems which have shipped with Leopard. It's happening on newer systems that were upgraded from Tiger to Leopard. It's happening on IntelMacs, & PPC Macs. There is absolutely no guarantee that a replacement drive will fix the problem. I can say that for a fact as the the drive on my 2 year old PPC crashed about a month ago & had to be replaced, the new drive on my system still does this.
  • 78. Re: Audio cd disappears after confirming import
    Matt Goldey Level 1 Level 1 (30 points)
    This EXACT scenario happens to me. It started the day I upgraded from 10.4.x to Leopard. My workaround is to go into Disk Utility, find the CD (which shows up as unmounted). Click on the CD. Then click the "Mount" button at the top. It works, but I'd like a real solution. Right now, I just leave Disk Utility open while ripping CDs.
  • 79. Re: Audio cd disappears after confirming import
    GreenSky Level 1 Level 1 (0 points)
    I have been experiencing this bug a lot recently, ever since I upgraded to Leopard and changed my iTunes settings to import CDs more efficiently. Before that I never had it.

    I have a workaround that. In the preferences/Advanced/importing panel I turned off "Automatically retrieve CD track names from Internet" (which I had turned on when I modified my settings).

    Now when I insert a CD it shows up in iTunes and on the desktop as "Audio CD". Wait a couple of seconds and then manually choose the "Get Track Names from Internet" in the Advanced menu. It loads the names and everything works. I found that if I did this too quickly after the CD mounts it dismounts it just like in the original bug.
  • 80. Re: Audio cd disappears after confirming import
    StarDeb55 Level 6 Level 6 (19,685 points)
    1 or 2 other people have posted this as a workaround earlier in this topic. I tried it, & personally, it doesn't work for me. I'm glad it does work for you..
  • 81. Re: Audio cd disappears after confirming import
    Bonga Bonga Level 1 Level 1 (0 points)
    After having major problems importing a bunch of CDs tonight, I stumbled upon this forum. My problems were exactly like described above: the majority of the CDs would disappear once I clicked "import", after approx. 20 CDs I was getting rather annoyed. If anyone's interested, I'm running OSX 10.5.2 and iTunes 7.6.2. (9).

    But...I tried a method which has worked for the last 10+ CDs. I hope I won't jinx it:

    I play a song (any song), and click the triangle in the iTunes display so I get the equalizer.
    Then I insert the CD, and hit the return key the second I get the import-question.

    Again, I use the return key on the keyboard -- not the mouse.

    I have absolutely no idea if this makes any difference or if I'm lucky, but like I said, it's worked for me. (just tried another CD to be sure, and no problems what-so-ever).

    I'm interested in seeing if it works for anyone else.
  • 82. Re: Audio cd disappears after confirming import
    StarDeb55 Level 6 Level 6 (19,685 points)
    Actually, there is a 2nd thread concerning this issue that a new poster, in the past couple of weeks, had posted a workaround that I had not seen before, so I gave it a try & it has worked without fail. I simply changed my importing preferences where it says, "On CD Insert" to read "Import CD & Eject", rather than "Import CD or ask to Import CD".
  • 83. Re: Audio cd disappears after confirming import
    BfromB Level 1 Level 1 (0 points)
    I can confirm that the same problem occurs for non-English versions of iTunes and Leopard (Dutch version). Pleased to hear it's not a hardware problem of my new iMac. I'll try some of the suggested workarounds (already used the Disk Utilities workaround). Hopefully a solution will be provided soon (though Dutch version fix will very likely be released later), as I started building my iTunes library from scratch as the transfer from PC to Mac didn't work.
  • 84. Re: Audio cd disappears after confirming import
    BfromB Level 1 Level 1 (0 points)
    This one works for me, thanks!
  • 85. Re: Audio cd disappears after confirming import
    whthfrll Level 1 Level 1 (15 points)
    I had this exact same problem on my brand new iMac purchased April 2008.

    Root cause: faulty optical drive.

    Remedy: Replace optical drive.

    Problem solved.
  • 86. Re: Audio cd disappears after confirming import
    StarDeb55 Level 6 Level 6 (19,685 points)
    I'm glad it worked for you, but there is most definitely something else going on. I had a total drive failure last February, replacing the drive did nothing to resolve this problem for me.
  • 87. Re: Audio cd disappears after confirming import
    DeCeccoNET Level 1 Level 1 (0 points)
    StarDeb55, I agree with you...

    I have been having this problem on both my internal Superdrive, AND my FireWire Lacie DVD Burner (iTunes 7.6.2 and Leopard 10.5.3)

    In both instances, I have been finding that removing and reinserting the disk a second time has allowed me to continue with the import, but it is REALLY annoying!
  • 88. Re: Audio cd disappears after confirming import
    StarDeb55 Level 6 Level 6 (19,685 points)
    DeCecco, you might try changing your importing preferences to "import & eject". This was reported to be an effective workaround on another thread concerning this issue. I tried it for about a month, but this, too, has failed as the last CD I attempted to import wasn't even recognized by either iTunes or the G5. Fortunately, the eject key on my keyboard did get the disc to spit out of my drive.
  • 89. Re: Audio cd disappears after confirming import
    Phoenix-Ashes Level 1 Level 1 (0 points)
    Hi

    I bought a Mac Pro 2 months ago , I also have this problem importing CD's. It's very annoying.

    I have two superdrives, it happens with both drives. I've tried different combinations, ie trying to insert CD while the other is importing, putting them in at the same time, putting one in while other is already in, nothing works.

    I've tried changing the import setting from "Show CD" to others but to no avail.

    I upgraded from a 933Ghz Quicksilver G4 and this never happened (with leopard and the latest version of iTunes).

    I don't think it's a hardware issue as this seems to be happening on Macbooks, etc, although I could be wrong!

    Mac Pro (2 x 3.2Ghz Quad Xeons, 2xSuperdrives)
1 4 5 6 7 8 9 Previous Next