Skip navigation
This discussion is archived

mdnsresponder and configd

99823 Views 90 Replies Latest reply: Aug 19, 2010 7:19 AM by Jay Bullock RSS
  • swixo Level 1 Level 1 (95 points)
    Currently Being Moderated
    Feb 16, 2009 1:41 PM (in response to SolRayz)
    I can confirm that on my system that is having the problem:

    1. Files configd and mdnsresponder were signed by "adhoc"
    2. Also file nmbd had wrong signature
    3. Copying these files from another system fixed it.

    Thanks for a correct solution to the problem.

    MB Air v2, etc, Mac OS X (10.5.6)
  • Andrew Jones 2009 Calculating status...
    Currently Being Moderated
    Feb 26, 2009 10:07 PM (in response to SolRayz)
    Thanks for the idea to use Time Machine. From the finder I went to the Go menu and selected Go to Folder. I then entered /usr/sbin and clicked OK. I just went back to my last backup before the problem and restored both configd and mdsnresponder. After a reboot all is back to normal. If you aren't backing up with Time Machine, what are you waiting for?
  • Mikeyhp Calculating status...
    Currently Being Moderated
    Mar 17, 2009 3:42 PM (in response to Arjan van Bentem)
    I'm having this issue where configd gets blocked by the firewall. The allowing all connections in firewall is allowing me to work around it. However I'm relatively new to the Mac world and when you say enter this, "codesign --display -vvv /usr/sbin/configd" in the command line in shell. How does one get to that, is that the same as "Terminal"?

    I really would like to fix this issue but am worried about mucking about to much as I really don't want to screw something up and have to do a fresh install.

    I really don't remember what might have caused the issue or when it started (relatively recently). All I know is that now after I reboot I've had it where my clock is set wrong and now the issue is being unable to get online due to firewall blocking dhcp info for configd.

    Thanks for any info you can provide.
    MacBook Pro 15" (Late '08), Mac OS X (10.5.6)
  • Mikeyhp Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 21, 2009 12:24 AM (in response to 4marcus)
    If anyone could help, when I run that command line in terminal, the configd shows up as adhoc.

    Although... how do I find the file so I can go into time machine and get a backed up version? I type configd in spotlight and nadda. Unfortunately I don't know where to find this thing. Any info would be appreciated.
    MacBook Pro 15" (Late '08), Mac OS X (10.5.6)
  • Annorax64 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Mar 26, 2009 11:32 AM (in response to jamus j)
    I can confirm that the restoration of the configd and mDNSResponder files from my Time Machine back-up resolved this issue.

    I had to verify that the copy of the files was taken prior to my system having been serviced before copying back to the /usr/sbin directory.

    Note: After I had started Time Machine, I had to go into Terminal and change directory to my Time Machine backup volume below the /Volumes directory. Once there, I found the directory of the last known good date prior to having my Macbook Air serviced, and then performed a "sudo cp" from that directory to /usr/sbin directory. Apparently there is some way to include /usr/sbin in the files displayed by Time Machine; however, I did not know the trick to doing this.
    Macbook Air 1.6GHz Intel Core 2 Duo, 2GB 667MHz SDRAM, Mac OS X (10.5.6), Recent convert
  • Mikeyhp Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 29, 2009 1:02 PM (in response to Annorax64)
    Well I replaced the configd file from my last good backup. After I rebooted, I checked in terminal and it stated adhoc... BUT I was able to get an ip with the firewall on so maybe it's fixed?

    The command to show hidden files in finder so you can view it in time machine is:

    defaults write AppleShowAllFiles TRUE

    When you want to remove the ability to see hidden files remove "TRUE" from the statement and replace it with "FALSE".
    MacBook Pro 15" (Late '08), Mac OS X (10.5.6)
  • Mikeyhp Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 29, 2009 5:48 PM (in response to Mikeyhp)
    nevermind, I must have did the restore wrong the first time I guess. It's no longer showing as adhoc after I restored it again. Working well now with firewall on.. hope it stays that way.
    MacBook Pro 15" (Late '08), Mac OS X (10.5.6)
  • theolog Level 1 Level 1 (105 points)
    Currently Being Moderated
    Apr 12, 2009 2:53 AM (in response to SolRayz)
    Running Combo Update fixed it for me:
    Seems the most straightforward and least risky solution suggested here. Give it a whirl!
    1 GHz PowerBook G4 12, Mac OS X (10.5.6)
  • David Bruce Calculating status...
    Currently Being Moderated
    May 13, 2009 11:11 AM (in response to SolRayz)
    This is a 10.5.7 update the this long topic. I had my MacBook Pro in for service to fix a failed graphic component, and began to have the same problem as described above related to not being able to get the new DHCP wifi connection, and also getting the configd incoming message dialog.

    Just as I was about to do the 10.5.6 combo update, there was 10.5.7 appearing in Software update. I gave this a try, and then checked in Terminal as mentioned above, but configd still had an Signature=adhoc.

    I then went and got the 10.5.7 combo update, and this fixed the configd signature, and I seem to be running fine now.
    MacBook Pro, Mac OS X (10.5.7), also PowerMac G4, iMac G3s, iBook
  • D.R.C. Level 1 Level 1 (145 points)
    Currently Being Moderated
    May 18, 2009 1:28 PM (in response to David Bruce)
    This is another 10.5.7 update.
    My MacBook was running 10.5.6 last week. It went in for service, and returned with a new motherboard. While it was at the (Apple-authorized) shop, they tested battery and almost certainly reset the PMU.

    When I got the machine back, it would no longer get a lease from DHCP over WiFi or ethernet unless the firewall was set to accept all connections.

    While troubleshooting, Software Update conveniently downloaded the 10.5.7 update, which I installed. This did NOT fix the problem. I confirmed that the configd and mDNSResponder both had adhoc signatures following the update

    I subsequently downloaded the 10.5.7 combo updater from and ran it. Voila - problem solved. Had the combo updater not worked, I had a SuperDuper clone that I had made prior to taking the MacBook in for service. Fortunately, the combo updater did the trick.

    Thanks to all who have contributed to solving this nasty little problem over the last several months.
    MacBook, Mac OS X (10.5.7), iPhone 3G
  • kg23 Level 1 Level 1 (115 points)
    Currently Being Moderated
    Jul 7, 2009 1:36 PM (in response to theolog)
    Running the combo update (10.5.7) did fix the DHCP issue for me by re-signing the suspect binaries.

    I am still getting firewall complaints about "nmblookup" however. It is listed as "adhoc" signed. I added it manually to the firewall whitelist.
    MacBook Pro 2.4Ghz, Mac OS X (10.5.7)
  • bphendri Level 1 Level 1 (115 points)
    Currently Being Moderated
    Jul 17, 2009 8:19 AM (in response to seehundnz)
    Was reading a threat regarding the issue of AFS being blocked by firewall.

    Can you try entering this in the terminal
    %>codesign --display -vvv /usr/sbin/mDNSResponder

    Let me know if this signing authority is Authority=Apple Code Signing Certification Authority
    or AdHoc

    Mac Pro 8-Core 3.0GHz. , 15in Powerbook G4, Mac OS X (10.5.7)
  • bphendri Level 1 Level 1 (115 points)
    Currently Being Moderated
    Jul 17, 2009 8:21 AM (in response to bphendri)
    Disregard, Intended to respond to another post, and wasn't paying attention..

    Mac Pro 8-Core 3.0GHz. , 15in Powerbook G4, Mac OS X (10.5.7)
  • iMystic Calculating status...
    Currently Being Moderated
    Jul 31, 2009 4:37 PM (in response to Andrew Jones 2009)
    I can absolutely confirm that this method did the trick.

    I recently updated my Safari browser to version 4.0.2 and then exaclty what has described here in regard of the processes poppuing up for permission, happened to me.

    I really did everything to my knowledge what I could, until I read the option, Time Machine. (this must be so obvious that I have missed it)

    So in my finder window I went to Go - Go to folder, and then pasted the path you provided, making the hidden folder visible.
    I activated Time Machine and selected the 2 processes (configd and mdnsresponder) and hit the replace button in Time Machine.

    I confirmed the necessary warnings and rebooted the machine.

    The problem dissapeared as swift as it appeared.

  • actuarius Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 23, 2009 12:29 AM (in response to Arjan van Bentem)

    To answer your question on allowing or denying configd the first time; I denied it at first and thought that screwed the whole thing, but later on it asked again and allowing it didnt fix the problem.
    macbook, Mac OS X (10.5.4), 1.256 gb RAM
1 ... 3 4 5 6 7 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.