Skip navigation
This discussion is archived

Can't get space back from expired rental movie!

6257 Views 33 Replies Latest reply: May 25, 2008 8:54 PM by TElder RSS
1 2 3 Previous Next
Kim Hill1 Level 2 Level 2 (160 points)
Currently Being Moderated
Feb 2, 2008 2:19 AM
I had a rental movie on my iPhone that expired. It doesn't show up under the "Rented Movies" section of the "Video" tab in iTunes anymore. No movies there.

But the iPhone disk space indicator shows 1.74 GB of video content on my phone, which obviously includes the expired movie. I have tried syncing multiple times. I have toggled "Sync movies" on and off. Nothing works- I'm stuck with the inaccessible expired movie.

Help!
PowerBook G4, Mac OS X (10.4.11), iPhone 1.1.3
  • Mike Kelley Level 7 Level 7 (29,275 points)
    Currently Being Moderated
    Feb 2, 2008 8:42 AM (in response to Kim Hill1)
    Go ahead and do a refresh of the phone (it's harmless as all of your stuff is backed up on your computer) and I'm sure things will be back to normal.
    Windows XP Pro
  • Nathan C Level 5 Level 5 (6,260 points)
    Currently Being Moderated
    Feb 2, 2008 9:06 AM (in response to Kim Hill1)
    Kim Hill,

    Reset the iPhone by holding down both buttons until you see the Apple logo, and then reconnect it to iTunes and Sync.

    Hope this helps,

    Nathan C.
    iMac G5 (work), Mac OS X (10.5.1), Home Built Athlon XP 2300+ 1 GB DDR XP Home SP2
  • matt_mac Calculating status...
    Currently Being Moderated
    Feb 4, 2008 8:54 AM (in response to Nathan C)
    Nathan,

    I was having the same problem as Kim and this did work for me. Hopefully this gets fixed soon. I do love the movie rentals.


    Thank you,

    Matt
    Macbook Pro, Mac OS X (10.4.7)
  • Michael Seelye Level 1 Level 1 (40 points)
    Currently Being Moderated
    Feb 10, 2008 3:19 AM (in response to Kim Hill1)
    When you delete your files on your Mac, the operating system is only forgetting where those particular files are placed, (pointer removed, a bit was changed in the file header.) while the data still physically remains on the drive.
    This sounds similar, however
    Maybe the new file deletion process they created is similar. You have 24 hours after you start watching a rental and a month to start watching it. Once the movie is watched or the time is up they twiddle the bit, but don't wipe the data immediately.

    I would think that a synch would correct the issue. The file needs to have a "timer" built into it, or iTunes will need to have the timer. What I'm getting at is what would make the file know "it's time is up?"
     MacBook Pro;  MacPro; TV;  iPhone;  iPod, Mac OS X (10.5.1), Intel Core 2 Duo - 2.4 GHz
  • amenki Calculating status...
    Currently Being Moderated
    Feb 12, 2008 8:19 PM (in response to Nathan C)
    A full restore, initiated from within iTunes, and re-sync finally removed an expired movie that I had been stuck with for over a week.

    Customer Service Tanget: This user experience was flat out lousy. Started the rental by learning - post payment - that I couldn't view it on my iPod video, then I can't get it off my phone. Apple's thoroughly convinced me not to rent movies, even if I could finish it within 24 hours (yeah, that hasn't happened either).
    12" G4 PowerBook, Mac OS X (10.5.2), 8G iPhone 80GB iPod Video 15" MacBook Pro
  • matt_mac Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 18, 2008 6:30 AM (in response to matt_mac)
    Well two movies stuck and the reset does not work this time. Any idea whena fix will be coming? A refresh is a bad option for me right now.
    Macbook Pro, Mac OS X (10.4.7)
  • Windoodoo Calculating status...
    Currently Being Moderated
    Feb 18, 2008 4:27 PM (in response to Kim Hill1)
    The same thing happens to me all the time and my brother as well this is what we do and it seems to work for us hopefully it will work for you as well.

    Plus using this method you WONT NEED TO RESTORE!!!!!

    On your phone open up the iPod app and navigate to Video hold down the Home Button until the app quits and your are back at the main screen next turn off your phone wait 30 seconds then power it back on the movie should be gone.
    MacBook, Mac OS X (10.5.2)
  • noahharlan Calculating status...
    Currently Being Moderated
    Feb 19, 2008 12:54 AM (in response to Windoodoo)
    Thanks! I was having this same problem and voila! You fixed it without a restore!
    15" MBP 2.4GHz, iPhone, Mac OS X (10.5.2)
1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.