Previous 1 2 Next 16 Replies Latest reply: Jul 20, 2008 8:21 AM by OregonFarmer
I am curious. Level 1 Level 1 (20 points)
My iphone won't seem to want to connect to WiFi and always defaults to Edge. I restarted it and I toggled off airplane mode but when I try to go to a page or open up iTunes buyer it turns to edge. Help?

iPhone, Other OS, It is awesome!
  • producerkeith1 Level 1 Level 1 (0 points)
    I have the exact same problem. Hopefully someone else has an idea on how to fix this.
  • Allan Sampson Level 10 Level 10 (123,365 points)
    Is this at Home where you have a wireless network?

    If so, have you ever been able to connect to your wireless network with your iPhone?

    What type of encryption are you using with your wireless network - WEP or WPA?
  • I am curious. Level 1 Level 1 (20 points)
    It works at home only... for some reason it doesn't work at my other house which is password protected (WPA I think...) and then at the restaurant we own it isn't password protected at all but it defaults to edge even though it is selected on the wifi signal. I have been able to connect at home though which is nice... please help, oh yeah, I got it for my b-day too so I want it to be perfect.
  • Allan Sampson Level 10 Level 10 (123,365 points)
    If it works when connected to your wireless network at home, then wi-fi is working.

    Were you able to successfully connect to your wireless network at your other house after entering the password for the wireless network?

    And the same for the wireless network at the restaurant - you were able to successfully connect to this unlocked/non-password protected network, but the connection is lost?

    Once connected to these problem networks, select the network on your iPhone, and then Forget This Network.

    Or on your iPhone, go to Settings > General > Reset and select Reset Network Settings. This will erase all existing wi-fi network settings on your iPhone, and will require reconnecting to all networks.
  • I am curious. Level 1 Level 1 (20 points)
    Ok, lets see...
    I was able to see the wifi logo up at the top at both places but when I tried using something that used internet (safari) it defaults to edge. I will try to do the forgetting option.
  • RaiderNation Level 1 Level 1 (5 points)
    I have the same exact problem and while this offers no solution but another problem, i went to the AT&T store and the representative I talked to said he didnt know what was wrong and that he hasnt ever come across the problem before.

    Just to verify that we have the same problem...My iPhone will connect to wifi but as soon as i get on safari it reverts right back to edge. Maps, youtube, safari, etc all seem to be slower on edge now too. I can barely connect to youtube on edge and it takes literally 30 mintues to watch a 2 minute video.

    Any help would be greatly appreciated. Thanks
  • mbbezy Level 1 Level 1 (0 points)
    I had the same issue as the users on this page and I finally figured it out!!!

    I'll give some background on what I was experiencing first. When I got my phone, it was able to detect and connect to my home wifi. I saw that wifi icon on the phone so I knew that I was connected. When I would launch Safari or YouTube, it discards the wifi connection and defaults to the edge network. Opening up iTunes would prompt me to connect to a wifi network.

    At first I thought it was the phone until I was able to connect to my work wifi. I tried rebooting my wireless router and modem...no success. I tried restoring my iPhone...no success. I tried the "forget the network" and "renew lease"...no success. After trying those different things, I narrowed it down to the actual wireless router setup.

    Since my laptops were able to connect to my home wifi, I figured that the iPhone was not able to connect even though I was entering the correct key. So what I did to test out the connection was I turned off the security and made my network invisible just in case I would be testing for a long period of time. Right away, I was able to connect with my iPhone! Knowing that I was able to connect, I checked the type of security I was using. I was using a 64 bit WEP encryption and I switched it to WPA (more common with Macs). That worked too! If you want to use WEP, try using a 40 bit or 128 bit encryption. That might work as well.

    Hope that helps out some people. Good luck.
  • I am curious. Level 1 Level 1 (20 points)
    Thats great! I think you may be able to help some of us out with that experience!
  • Lawrence Finch Level 7 Level 7 (28,515 points)
    If it works with some WiFi networks the problem is in your router, not the phone. FIRST, go to the router manufacturer's web site and make sure you have the latest firmware revision. Older revisions of Linksys, Belkin and some other routers are not compatible with the iPhone.

    See if you have MAC Filtering enabled on the router. This is a feature that prevents unauthorized computers from using the router. It is off by default, so you (or whoever set up your network) would have had to enable it. If it is enabled you must enter the MAC address of the iPhone into the Allowed list. You can find it by going to Settings/General/About and scrolling to WiFi address. At this point make sure there IS a WiFi address; if the field is blank see: http://support.apple.com/kb/TS1559?viewlocale=en_US

    If these are not problems connect to the WiFi network, then tap the arrow to the right of the network name and look at the entries. If IP address begins with 169.254 this is not a valid address; it means that the router is not honoring a request from the phone to assign an IP address. For most routers the first two numbers should be 192.168.

    Next look at the DNS entries. Compare them to the entries on your computer. They should be the same. If there is more than one DNS entry try deleting the first one.

    Let us know if any of this was useful.
  • Fletch88 Level 1 Level 1 (0 points)
    I had the same WIFI problem at home w/ the Linksys router. Tried everything on the list... restarting and resetting everything. No WIFI.

    However, deleting the 1st DNS entry from the automatically acquired WIFI info on my phone actually worked! Thanks for the help.
  • dans23 Level 1 Level 1 (0 points)
    I am having the same problem with my iPhone 3G. my IP address starts with 169.254 not 192.168. but i don't know how to change this?

    i don't know what DNS stands for and i was wondering how Fletch88 deleted the 1st DNS entry, and if that would possibly work for me?

    thanks for the help in advance.
  • ultimaonliner Level 1 Level 1 (20 points)
    I had a similar problem which was driving me nuts since my 2G iPhone worked fine. What finally worked is that my 3G iPhone could not be stable with WEP enabled, while the 2G iPhone handled it fine. WEP is an old security protocol anyway. I changed my router's settings to WPA and it worked just fine.
  • mannyp02 Level 1 Level 1 (0 points)
    Okay let me add another twist to all this. My iPhone will connect to my password protected home network. At work, however, I am having the problem where it says I'm connected but when I try to use the App Store or something it switches to Edge. This is strange because we haven't changed our WiFi settings (I work in our IT so I would know) and my iPhone has always connected just fine at work since I bought it last July. Also our other IT people have iPhones and are able to connect no problem. I have restored, reset network settings, forget network, all those steps and still no luck. It says I'm connected but if I actually go into my network settings, it is all blank. No IP address, subnet mask, etc. all blank! Any ideas?!
  • mannyp02 Level 1 Level 1 (0 points)
    Bump*
Previous 1 2 Next