Previous 1 2 3 4 5 Next 65 Replies Latest reply: Sep 11, 2008 8:32 AM by Kevin kevin Go to original post
  • iBuferd Level 1 Level 1 (0 points)
    I am having this same problem with my 3G. It seems that even when I exit out of the sms screen back to the home screen that is still won't make the alert sound. I have also tried the headphone trick and that doesn't work all the time. I really hope that the 2.0.1 firmware update will fix a lot of the bugginess with the current firmware. I love Apple products to death but I have to admit that the 2.0 firmware has been too buggy for Apple to have their name on it.
  • Austin Wondolowski Level 1 Level 1 (5 points)
    I think I may have fixed this.

    When you sync your iPhone in ITunes...

    Under the tab named Ringtones, make sure your have *Sync ringtones* checked, even if you don't have any ringtones to sync.

    I did this...and now I am getting all of my text message sound alerts!

    Let me know if this works for you too! I hope it helps!
  • Wobbit45 Level 1 Level 1 (0 points)
    I always sync my ringtones, and that doesn't resolve anything. I went to apple and got my phone replaced because there was something rattling inside, I though hopefully that was the reason for the lack of sound.....I get the new phone..it works flawlessly for 2 days....then WHAM!!! No text message sound then NO SOUNDS!!!
    ***!!! second iPhone same problem, and it's with the newer firmware version also, it came out of the box with it. They better fix this issue, or I am demanding my money back. lol
  • iBuferd Level 1 Level 1 (0 points)
    Downloading the new 2.0.1 software.... hopefully this fixes a lot of problems!
  • jub-jub-bird Level 1 Level 1 (0 points)
    My iPhone has played neither new mail alert sounds nor new text message alert sounds since I've purchased it. It plays the incoming call ringtone just fine, but new mail and new SMS messages only cause the phone to vibrate.

    (Yes, I've confirmed that I see this behavior specifically when the Ringer switch is in the ON position. The phone vibrates on incoming SMS and e-mail because I've left the default factory setting that vibrate is on even when the ringer is on.)

    I've never heard the phone play an SMS or mail alert since I purchased it on Aug. 2. In fact, I don't even hear the alerts play when I'm switching between SMS sounds in the Settings->Sounds panel, even though the incoming call ringtones will play as I switch between them.

    The problem persists after the 2.0.1 upgrade.

    The bug is a nuisance and I want Apple to fix it at elevated priority, but let's be reasonable, people; if you really want to moan about a buggy phone, try the Motorola Q I'm sure this problem will be fixed once Apple notes it.
  • TommyWillB Level 1 Level 1 (10 points)
    I have the old Edge (non-3G) phone, and this problem started for me immediately after installing software v2. It never did this before.

    I not only see this in the SMS app, but upon leaving the app, it the keyboard is always silent in any other app. So it's OS-level and not App specific.

    So far rebooting has always fixed it, but I've been rebooting a LOT because of this. I think I only rebooted 4 times in the 6 months before software v2.
  • TommyWillB Level 1 Level 1 (10 points)
    I use the Glass sound, and it happens to me.
  • TommyWillB Level 1 Level 1 (10 points)
    That's not the solution, since I've always had that selected.

    Which is not to say un-selecting it couldn't cause a similar problem.
  • TommyWillB Level 1 Level 1 (10 points)
    Really? Is this available for non-3G?
  • SebringGirl Level 1 Level 1 (0 points)
    Same problem. Thought i was nuts. Kept shutting the 3G off and turning it back on but now nothing. Ever. And I'm a big text messager so it ****** me off. I hope they resolve this. i upgraded to 2.0.1 and still nothing. Always use tri-tone but switched. Nothing.
  • dhp1080 Level 1 Level 1 (0 points)
    The 2.0.1 update still hasn't resolved this issue. Come on Apple, I'm sure you could've worked that into "Bug Fixes."
  • MorganRW Level 1 Level 1 (0 points)
    2.01 did not address this one. It may just be in my mind but it seems to fail faster after resets now. I want my **** DING!

    Otherwise I love the phone.
  • Wobbit45 Level 1 Level 1 (0 points)
    I don't know if this just a fluke, but i noticed when my text alert doesnt work, if I put it on vibrate by clicking the little lever on the side...and i receive a couple of messages, when i turn it off vibrate mode...my text alert sound is back....GO FIGURE!!!

    You guys should try this and see if it works for you.
  • Andrew 3G Level 1 Level 1 (0 points)
    I actually took my iPhone into Apple to either have them fix it, or swap out my 3G. The man did a software update for me, got me on 2.0.1, and the issue seemed to be resolved --


    UNTIL NOW. No sound again. I just re-booted my phone, which works, but it seems temporary.

    Anyone find anything?
  • johnnysd5 Level 1 Level 1 (0 points)
    I have the same exact issue as well. Also, now it seems to knock out many other sounds. The clicking when I turn my phone on and off isn't working either. It has to be some sort of lag with the new software (2.0). I hope that they fix this darn issue soon! I am sick of restarting my phone over and over again...