Previous 1 2 Next 26 Replies Latest reply: Aug 26, 2008 10:11 AM by drtork
mrerikcollins Level 1 Level 1 (0 points)
Hello -

I am a new iPhone 3G user. When I first set up the phone, everything worked great including email. However, I have noticed that at least once a day, my mail will stop fetching to the phone...it will simply just not connect. This seems to happen at different times throughout the day. Turning the phone off and on will reset this, but I shouldn't have to do that every day!

I am starting to think that this is from turning 3g on then off (I turn it off to save battery and on to use data). Could this be the cause?

Any body else having an issue, please let me know! Thanks!

Message was edited by: mrerikcollins

Powerbook 15" G4, iPhone 3G, Mac OS X (10.5.3)
  • phonebird99 Level 1 Level 1 (0 points)
    This is happening with me too. I have the old iPhone with the new iTunes and new iPhone software. I have had this happen in the past but not as an everyday experience.
  • mrerikcollins Level 1 Level 1 (0 points)
    This does not have to do with turning 3G on and off...It just happened again (for the second time today) and I have not changed any network settings as of yet.

    I also have it set up to "fetch" my mail every 15 minutes.
  • David L. Zwang Level 1 Level 1 (35 points)
    Same problem with my phones. I have an old one and a 3G. Both have 2.0 SW, and are set for 'Fetching' mail every 15 minutes. You can't even force it to get it by hitting the arrow in the lower left like you used to???

    This is a real pain bug...

    dave
  • phonebird99 Level 1 Level 1 (0 points)
    It's just gets "stuck in stupid." This has always happened with my iPhone....but not on a daily basis. It probably happens once every three to four weeks or so. I usually have to reset the phone when it does. Now, my mail fetching is getting "stuck in stupid" a few times a day. I have found turning it off/on has helped get it un-stuck rather than causing the problem. (I never, ever turn my phone off unless there is a problem.)
  • curbside5000 Level 1 Level 1 (0 points)
    Same problem here. Older phone, new software updates. Problem rarely occured prior to software update. Can only retrieve e-mail if I shut phone down and restart. VERY FRUSTRATING. Any one discover a fix?
  • awejr Level 1 Level 1 (25 points)
    This has been happening daily to me. I bought one of the new 3G phones and it worked fine for three days and then it just started and sometimes I have to power off/reset the phone three or four times a day to get it to connect again.

    While not connecting to my email accounts, (One MobileMe, One Gmail and two POP accounts) it continues to operate just fine in every other way incluyding browsing the web, the maps function, etc.

    I can't find a pattern to the stoppage.

    I'm happy to talk this through some more if anyone has any ideas.
  • GregGrant Level 1 Level 1 (0 points)
    Happening to quite a few users of both the original iPhone and the 3G version.

    Anyone else see/hear that the restore method actually works?

    <Edited by Moderator>
  • mrerikcollins Level 1 Level 1 (0 points)
    I have not heard it this will fix the problem or not, but if you have a few, I would suggest it. I plan on doing just that when I get home tonight.

    I have heard that some of the iPhone 3g's came with an older firmware version then others. Although we all have 2.0, there is a different build or firmware. Restoring the phone will give you the latest firmware. I am assuming I have the older one, and that the newer firmware will e my fix!

    Will let you know tomorrow if this does not fix it.
  • Alan Somers Level 6 Level 6 (9,345 points)
    I'm having the same problem, and mine came with the newer firmware. It is quite annoying. I may have to try the restore trick myself, although I have doubts that it will work.
  • awejr Level 1 Level 1 (25 points)
    I have "restored" my iPhone to the newer firmware and then today updated the software. So far, after several hours, it is connecting on its own regularly and operating perfectly. Time will tell of course.
  • awejr Level 1 Level 1 (25 points)
    Update:
    The phone is back to its old tricks and I am having to restart it again daily to get it to connect and get my email. Restoration may have helped, (restarting daily instead of almost hourly) but it hasn't solved the problem.
  • CoachArmstrong Level 1 Level 1 (0 points)
    The previous is another work-around.

    If you check this thread out you'll see that MANY people are having the same issue.
    http://discussions.apple.com/thread.jspa?threadID=1603761&tstart=0
  • CoachArmstrong Level 1 Level 1 (0 points)
    A quick *"Forced Quit" of mail* app is a faster way than a full power down.

    +how to do it:+
    While in mail, hold down the HOME button (the concave button at the bottom of iPhone).
    It will do a forced quit of the mail app and your iphone should go out and search mail (albeit only once) like when you do a full power down.

    Not perfect or even acceptable, but still a faster workaround than powering the whole iphone down.

    APPLE PLEASE FIX IT BEFORE YOU LOSE ALL THE MOMENTUM YOU'VE GAINED WITH iPODS & iPHONES.
  • drsailer Level 4 Level 4 (1,495 points)
    I have the first iPhone running the new software, and have seen this happen a number of times. I think I have an idea why it happens, at least on my and my wife's phones. When you are on the edge network you can't make a call, and vice versa. If I am on a call when the email program is supposed to do its fetch check, it will fail, and will not start again. When I am on my home or work wi-fi, I never have this problem, as the phone can do wi-fi and calls simultaneously.

    Now people with 3G iphones: when this happens, are you using 3G or edge? I'm curious if our situation might me the case for others also.

    FWIW, I set my fetch interval to 1 hr rather than a short time period, and I haven't had any problems in over 2 weeks. When I had it set for 30 or 15 min it would happen every few days. I have a feeling that setting fetch to manual would eliminate it completely
Previous 1 2 Next