Previous 1 2 3 Next 83 Replies Latest reply: Jul 21, 2009 11:58 AM by grahum
aBitGone Level 1 Level 1 (0 points)
Hi all,

After updating with the 2.1 software this afternoon, my Apple TV no longer shows up in the Devices list in iTunes.

I've tried everything listed in http://support.apple.com/kb/TS1453, but still no joy.

My current setup is:
Mac OS X 10.5.4 (Build 9E17)
iTunes 7.7 (43)
Apple TV 2.1 (Build 227, 8N5519 - EFI 00DA.B00 - IR 2.4.4 - GF 3.1.0/2.9.50)
Apple Time Capsule (Version 7.3.2)

Everything works fine - the Apple TV shows in the devices list, and syncs as expected - when I'm using the 2.0 software, which leads me to believe that there is a problem with the 2.1 software in my setup.

Does anyone know of any solutions or workarounds, other than the obvious of doing another Factory Restore and reverting to the 2.0 software?


Best regards,
Anthony

MacBook Pro, Mac OS X (10.5.4)
  • Winston Churchill Level 10 Level 10 (84,595 points)
    Welcome to the  Discussion Forums.

    Sorry the page you have linked to is not available (at least for me at this time), so I'm not sure what you have tried.

    Have you tried re-linking the library with the tv: settings/computers/connect to itunes library.
  • swanksalot Level 2 Level 2 (150 points)
    http://support.apple.com/kb/TS1453 is the article aBG mentions, and item number 2 is to reconnect the Apple TV to iTunes. I just had the same problem, Apple TV showing up in iTunes, but nothing syncing, my solution was to connect to a different library, then reconnect to the library I wanted. Is taking forever, but at least there is progress visible finally.
  • aBitGone Level 1 Level 1 (0 points)
    Hi Winston,

    Falling short of using some sort of network packet tracing software to see what's going on between my MBP and the TV, I've tried pretty much everything I can think of - on both iTunes and the TV settings menus.

    Thanks,
    Anthony
  • aBitGone Level 1 Level 1 (0 points)
    Sounds like it could be a workaround - luckily, I've got another iTunes Library on another computer, so I'll give that a go later this evening.

    Thanks for the hint.
  • aBitGone Level 1 Level 1 (0 points)
    A new version of iTunes (7.7.1) has just shown up in Software Update, so when I get back home this evening, I'll try it out and let you know if this solves the problems.

    Regards,
    Anthony
  • Chunk72 Level 1 Level 1 (0 points)
    I'm having the same frustrating problems as you.

    My ATV is missing from the devices list on my main iTunes library, but is showing as available for setup on my Powerbook and on the Mac Mini.

    I've updated to the new iTunes version, I've tried downgrading and all the fixes suggested so far short of deleting my iTunes library and starting again or reinstalling OSX.

    The annoying thing is the ATV will sync fine with the other machines, I can ping it all day long but it refuses to show up in Bonjour Browser or iTunes on my Mac Pro.

    It just works Grrrrrrrrrrrrrrrr!
  • aBitGone Level 1 Level 1 (0 points)
    Nope - tried connecting to another library, still no joy.

    I also tried updating to iTunes 7.7.1, but the tv still won't show up in iTunes' devices list.

    I think there could well be a problem with the 2.1 software.
  • Winston Churchill Level 10 Level 10 (84,595 points)
    When you tried the change library and change it back again thing, did the tv show in the other library.
  • Crave Level 1 Level 1 (25 points)
    I've been having the same problems off and on for weeks (before the upgrade as well as after). I've done everything the on-line troubleshooting page says multiple times. The first time I fixed it by re-setting up my Airport Express network. The second time I fixed it by plugging the ATV directly into an Airport Express. I've had success with each of those fixes for about two weeks each, but now I'm on my third time and I'm out of ideas.

    All of my software is up to date. I don't have any firewalls. I don't even have any password needed for network. I don't have any problems with the ATV connecting to trailers or the store. I don't have any problems with my two macs, a dell pc, and a printer connecting to the network and talking to each other. I ONLY have a problem with ATV showing up in iTunes... and it happens ALL THE TIME.

    Everything should be working just fine but they're not, so I don't know what to do. Really disappointed.
  • aBitGone Level 1 Level 1 (0 points)
    A little more digging hasn't yet got my v2.1 tv showing in iTunes' device list.

    I've tried running a cable between the ethernet ports of my MacBook Pro and the tv so that they can talk directly to each other, and still there is no joy.

    I've downloaded Bonjour Browser and, after following the instructions in http://support.apple.com/kb/TS1453 again, I've still got nowhere. However, when I ask the v2.1 tv to connect to iTunes (tv > Settings > Computers > Connect to iTunes), I'm seeing the following Bonjour entry:

    appletv-pair.tcp
    67E90599C3D8AF0C
    192.168.1.113:3689
    txtvers=1
    PrVs=65537
    OSsi=0x1F5
    MniT=123764765


    Compare that to the entry that shows up in Bonjour Browser when asking the v2.0 tv to connect to iTunes:

    appletv-pair.tcp
    ECE1D8964DB4BFB1
    192.168.1.113:3689
    txtvers=1
    PrVs = 64437
    Name = Apple TV
    Ossi = 0x1F5
    MniT = 123764765


    Looking back to Bonjour Browser for a second, once I've actually got the tv (v2.0) and iTunes (7.7.1) talking to each other, the following items show in Bonjour Browser:

    appletv-itunes.tcp
    FEA254D3C42EB625.1E8D619FA6DA6562
    192.168.1.123:3689
    [fe80::21e:c2ff:febb:d5a0]:3689
    192.168.196.1:3689
    192.168.14.1:3689
    txtvers=1
    pass=0
    DpPV=196614
    PrVs=65537
    iTPV=196608
    OSsi=0x1F5
    MdKd=111
    MaID=0xC52Ed31FF448
    Name=Anth's iTunes Library

    appletv.tcp
    ECE1D894DB4BFB1
    192.168.1.113:3689
    txtvers=1
    PrVs=65537
    Name=Apple TV
    OSsi=0x1F2
    MniT=123764765


    After an update to v2.1, the output is exactly the same as above, except that for the appletv.tcp entry, there is no Name value being set.

    The v2.0 software appears to be setting a 'Name' parameter in the Bonjour settings, whereas the v2.1 software does not. Is this what's causing all the problems?

    Please - if anyone from Apple is reading this, can you help? Does anyone else know how I would go about creating a formal support request on this?


    Thanks,
    Anthony
  • monty77 Level 1 Level 1 (0 points)
    Having exactly the same issue here, very annoying!

    To get mine to reappear I have to reset the router for some reason which is really irritating. I've just disabled DHCP today on the router to see if that helps, I have a lot of wireless devices and was concerned that IP address changes could be impacting the Apple TV.

    Adam
  • Winston Churchill Level 10 Level 10 (84,595 points)
    Have you removed the tv entry in itunes/prefs/tv, before you try tv/settings/computers/connect to itunes.
  • aBitGone Level 1 Level 1 (0 points)
    Yeah, I tried that - still no joy. I've tried different routers, I've tried different IP addressing schemes...

    The problem is still, however, that it works with 2.0, but not with 2.1 - and that sounds to me like it's an issue with the software, not the physical setup.
  • aBitGone Level 1 Level 1 (0 points)
    Yup - tried that. It didn't work.
Previous 1 2 3 Next