Previous 1 2 3 4 Next 56 Replies Latest reply: Aug 26, 2008 5:25 AM by eccparis Go to original post
  • jsebooth Level 1 Level 1 (0 points)
    OK. Here's a thought. How do I restore the FIRMWARE. I think when I "restore" the iphone using itunes it is not changing the possibly corrupted firmware. How do I make it reinstall the firmware when itunes thinks that "your iphone is up-to-date" and doesn't offer the option??
  • jsebooth Level 1 Level 1 (0 points)
    I just spent an hour on phone with an apple support guy. We tried everything in the book. Including re-downloading the firmware update to make sure I wasn't reinstalling a corrupted file. Still nada. =(
  • aschro Level 1 Level 1 (10 points)
    Yes, was hoping this update would solve my problems... as far as the iphone bricking on App install so far so good, but now I've lost wifi as well. Wife's phone, 2.0, full bars, mine, 2.01, can connect even though I'm sitting in the room next to the access point. Have tried turning off and on, resetting, resetting network connections, etc. Still no luck.

    Oddly, one of the times when I reset network settings the wifi was grayed out as others described, but another reset fixed this, but still won't allow me to connect.
  • aschro Level 1 Level 1 (10 points)
    Lots of talk about this apparent wifi problem with 2.01: (see comments)
  • jsebooth Level 1 Level 1 (0 points)
    yes. i'm in that discussion already. heh.
  • Frank Marks Level 1 Level 1 (0 points)
    Hello, I am experiencing the same. "No WIFI" where an on/off switch should be.
    Not only that but I have another symptom. My bluetooth says "Unavailable" My iphone is a PURE iphone. no hacks or anything like that. I restored the phone via itunes twice already and still no luck.
    Could anyone help?
  • JoshuaJudd Level 1 Level 1 (0 points)
    I'm in the same boat. After finding no viable solution online, I made a genius bar appointment for tomorrow. I'm hoping he/she will either solve the problem or switch me out a new one.

    I didn't pay $200 + tax + monthly service charges for a phone that doesn't do everything it is supposed to!
  • Dave McGuire1 Level 1 Level 1 (35 points)
    I'm having the same problem.
    Which did you folks install first, the firmware update or the iTunes update? I called Rogers tech support today and he told me that I have to delete iTunes and then reinstall. The problem occurs, he claimed, when you install one before the other...I just can't remember which is supposed to be first. (I called in the car this morning.)

    I'll let you know how I make out.
  • dfury7 Level 1 Level 1 (0 points)
    I am in the same boat as everyone else.. did the 2.0.1 update and now blue tooth and Wi-fi are greyed out and unavailable... Tried resetting network settings..tried erasing all settings and info on the phone, and not to mention about 5 restores and NOTHING works.... very dissapointed...
  • Jason L Community Specialists Community Specialists (10,520 points)

    Does the iPhone have a Wi-Fi address listed in Settings> General> About?

    If it does not this article will provide options for resolving the issue.

    If the article does not resolve the issue, the iPhone may need hardware repair. Make a reservation to have a Mac Genius take a look at it or call AppleCare.
    U.S. iPhone technical support: 1-800-MY-IPHONE (1-800-694-7466)

  • Bender33 Level 1 Level 1 (0 points)
    My wifi was grayed out after the 2.0.1 install
    I reset the network setting on the phone (path below) and had to re-input the network password ect. and now it works fine

    settings/general/reset/reset network settings

    good luck!
  • jeenoyon Level 1 Level 1 (0 points)
    I had the same exact issue, "no wifi" grayed out. I did a hard reset (hold home button and top lock button simotaneously for about 10 seconds). I booted back up and wifi is now back to normal! Please try.
  • Dave McGuire1 Level 1 Level 1 (35 points)
    I appreciate the advice but neither of the suggestions above has worked for me. (And I've been on hold for over an hour-- first with my carrier, now with Apple).
  • Frank Marks Level 1 Level 1 (0 points)
    I am pleased that some people are getting good results but I am in the same boat as Dave, and a few other's that have had no success so far.
    Please keep posting your success stories. As one is bound to do the trick for the rest of us.
  • JoshuaJudd Level 1 Level 1 (0 points)
    I have tried all solutions listed as well, and nothing seems to do the trick. Hard reset, soft reboot, several restores, attempt to downgrade, cleared network settings etc...

    I have a Genius Bar appt. for 3:15 tomorrow. We'll see where that goes.