Previous 1 2 Next 18 Replies Latest reply: Dec 2, 2008 11:24 PM by patrickm1965
gretchengh Level 1 (15 points)
I have an iMac intel, iBook, and iPod touch.
All 3 successfully sync and push with MobileMe EXCEPT the address book on my iMac.
I checked all sync settings, deleted all contacts on the iMac, created test cards, deleted plists, etc but nothing works.
So, I created a new user on my iMac named TEST. In System Preferences I registered the TEST user to MobileMe. Then I reset the Advanced options sync data so that the MobileMe contacts would go to the computer. This worked.
So, something is corrupting Contacts syncing on my user account. But other users are OK.
How can I solve this problem?
Thank you,

24" imac intel, Mac OS X (10.5.4)
  • touch2know Level 1 (0 points)
    Similar issues here too Gretchen.

    I attempted all suggestions in this article:

    To no avail. MobileMe would not accept "Reset Sync" for the Contacts, and although all my Address Book contacts are present on my laptop, none are arriving on MobileMe.

    Later, I took off the MobileMe Contact Syncing on the iPhone, and attempted to overwrite my Address Book contacts onto the iPhone, also to no avail.

    I attempted to Reset SyncFolders: check out this article:

    Reseting SyncFolders as suggested did not work for me.

    In the console, I noticed these errors came up when attempting to sync to iPhone and to MobileMe.

    8/26/08 9:44:12 PM AddressBookSync[230] AddressBookSync (client id: error: Exception running AddressBookSync: CoreData could not fulfill a fault for '0x66d9d60 <x-coredata://2BF4D0E9-C434-4305-8756-D346FDB8EC2E/ABCDEmailAddress/p1260>'

    8/26/08 9:44:12 PM[222] 2008-08-26 21:44:12.757 AddressBookSync[230:10b] AddressBookSync (client id: error: Exception running AddressBookSync: CoreData could not fulfill a fault for '0x66d9d60 <x-coredata://2BF4D0E9-C434-4305-8756-D346FDB8EC2E/ABCDEmailAddress/p1260>'

    Not sure how to work around. I attempted other suggests on threads including deleting Address Book folder and restoring from exported Address Book Archive File.

    I tried restoring Address Book & SyncFolders from Time Machine; to no avail.

    I'm open to other suggestions!?
  • RodneyW Level 4 (3,030 points)
    G'Day Gretchen,

    Welcome to the forums.

    Can you please describe what happens when you attempt to reset your Address Book data in your normal account? (System Preferences -> MobileMe -> Sync -> Advanced -> Reset Sync Data... -> Replace: Contacts on this computer with sync info from MobileMe)


  • blufiresw Level 1 (0 points)
    I'm having the same issue. MobileMe won't receive any Address Book information updates, no matter how many resets and MobileMe data replacements I try. I get the following in the system log:

    Aug 27 08:13:58 Macintosh-2 AddressBookSync[1303]: AddressBookSync (client id: error: Exception running AddressBookSync: CoreData could not fulfill a fault for '0x1ade7d0 <x-coredata://63ABDC16-ABCB-4DEF-9B9F-37F3DBFB58DA/ABCDPostalAddress/p974>'
    Aug 27 08:13:58 Macintosh-2[1239]: 2008-08-27 08:13:58.083 AddressBookSync[1303:10b] AddressBookSync (client id: error: Exception running AddressBookSync: CoreData could not fulfill a fault for '0x1ade7d0 <x-coredata://63ABDC16-ABCB-4DEF-9B9F-37F3DBFB58DA/ABCDPostalAddress/p974>'
  • connectjunkie Level 1 (0 points)
    I had the exact same problem, which I have managed to solve. Be warned though, the solution is not for the faint of heart and I would highly advise backing up your Address Book before trying this.

    In my logs (from Console) I had the following entry when I restored a backup of my Address Book which seems to indicate some corruption which has made its way into my Address Book over time:

    27/08/2008 17:12:51 AddressBookManager[512] Records without metadata: {(

    In order to delete these records without metadata, I opened the SQLite database file the Address Book uses directly (located at ~/Application Support/AddressBook/AddressBook-v22.abcddb) using a free tool - SQLite Database Browser, and looked for these references. I found these in the AABCDRECORD table, in the ZUNIQUE field.

    What I did was to delete the records that contained these unique IDs - these all appeared to be Address Book groups in my case. Once this was done I reset my sync data to push the Address Book from my Mac to MobileMe and it all started working.

    Message was edited by: connectjunkie
  • touch2know Level 1 (0 points)
    I'm sure Gretchen will reply.

    However, what I experienced, was the seeming appearance of a proper "sync" coming from MobileMe. However, when I login into the Me Account (and after clearing Firefox cache files), no update has occurred (in fact, now no contacts are being uploaded to the "cloud").

    Again the errors mentioned above (listed in Console) occurs both with syncing to the cloud and syncing to an iphone.

    Thanks for the update about seeking to clear out corrupt files. I noticed similar issue, did not know what to do about it, thanks! Will play further.
  • touch2know Level 1 (0 points)
    Right on connectjunkie!

    Definitely works. Similar issue of 4 of my contact groups causing a "metadata" error. You can find this error by exporting your AddressBook Archive to back it up. By importing the Archive, you can identify an errors (using "Console" under Utilities).

    The SQLite Database App works well:

    For my database, the record was ZABCDRECORD & ZUNIQUE ID. Recommend copying the Console entry to TextEdit and doing a search in SQLite for each entry.

    Good luck all & THANK YOU connectjunkie!
  • blufiresw Level 1 (0 points)
    I attempted the fix by editing the SQLite database, but I have a lot of contacts and groups, so it was too big of a pain to rebuild all my groups. Fortunately, I had fairly recent versions of my Address Book on another computer (originally synced with MobileMe) as well as Time Machine backups. So I replaced the contacts on MobileMe with that from another computer, replaced the data on the problematic computer, and then used Time Machine to retrieve the few contacts that I lost in between. It's working fine for now.
  • gretchengh Level 1 (15 points)
    Thanks to ALL who responded to my question. I knew there must be others who understood this and knew it was not the MM preferences.
    I printed out all replies in this thread and will find a solution. I should find some time this Labor Day weekend.
    If I feel I am getting in too deep I'll wait until my next MUG meeting on Sept 13. When I first described this problem months ago they attributed it to my MM settings. I thought I was going crazy trying to tell them: I KNOW IT IS NOT THE SYSTEM PREFS SETTINGS!

    Thanks again. I'll keep you updated.
  • gretchengh Level 1 (15 points)
    Thank You!
    My iMac AddressBook now syncs with MM. I don't know if I can accurately describe each step I went through, but I could not have solved this without everyone's help.
    I archived my AddressBook.
    I went to the Console logs and identified AddressBook errors.
    I went to my Gretchen>Library> ApplicationSupport> SyncServices>Local>ClientData and trashed the error file.
    Then I reset MM to replace my iMac AddressBook from the Cloud. It worked!
    I needed the AddressBook that I archived so I imported that back to my iMac AddressBook. The import replaced what was synced from the Cloud.
    So, I reset my MM settings to merge the iMac and the Cloud and it worked again!
    Then I manually added some new contacts to my iMac.
    Did not work! Some of these contacts did not sync to the Cloud. (164 contacts on the iMac and 154 on the Cloud)
    At this point, I did some more snooping in my Library and Console, but now I can't remember what I found.
    Anyway, I opened the iSync app>Preferences>reset Sync History.
    Yes, this worked! I've added new Contacts, they go to the Cloud and back to all devices. I believe the problem is solved.

    I referred to the Apple Support updates you suggested and used your ideas in identifying the error culprits. I learned quite a bit about troubleshooting my OSX from this episode.
    Thanks again to all,
  • ChristopherCotton Level 1 (0 points)
    I had a similar issue of my iPhone and AddressBook not sync'ing. In my console I had:

    9/3/08 5:29:36 PM AddressBookSync[86999] AddressBookSync (client id: error: Exception running AddressBookSync: CoreData could not fulfill a fault for '0x1ab0960 <x-coredata://CE6FB572-E0E8-4298-9F25-1056193EFEF8/ABCDPostalAddress/p251>'

    The thing I ended up doing that fixed it, was to delete some of the groups I had. I'm not sure which group had the problem, or if it was an empty group. But, deleting some of my groups helped. I didn't have to delete all of them.

    Hope this helps!
  • Carlien Level 1 (0 points)
    I have an Macbook pro, Imac and I phone. I have the same problem as described before, though with one slight difference in that my Macbook actually did manage to push some 35 contacts to the mobileMe cloud and no more, no matter what I do.

    I've tried several things, but nothing changed so far, to my great frustration as auto syncing all my devices and then particularly contacts and calendars was one of the reason I switched to this setup. I'm not a very happy customer I have to say.

    If anybody figures out what the problem is, please let me know!

    If I find one I'll share it.

  • grayhair Level 1 (0 points)
    I have exactly same problem

    Contacts entered directly into mobile me (on the web) sync to my iphone fine but not my desktop and nothing I enter on desktop address book gets synced to mobileme me or iphone.

    There is something wrong with the desktop address book!

    Please help!
  • gretchengh Level 1 (15 points)
    I had the same problem. Go back to the original post and read the thread.
    You will find several suggestions to solve the problem.
    My post on Sept 1 describes how I solved my problem.
    I identified an error in the Log in my address book sync and also reset my sync history.
    Good Luck. Let us know how you do.
  • James Kurtz III Level 1 (0 points)
    Thank you to everyone on this thread as I have gotten closer to fixing my problem but still need a bit more help.

    I have identified the errors in Console and I have opened the file AddressBook-v22.abcddb in SQLite Database Browser. However, from here, I am stumped. I cannot find the records referenced in the console (see below), and even if I did, I'm not sure I'd know what to do with them. Sorry, It's probably a dumb question, but what do I do once I'm in SQLite Database Browser? How do I find what I need to delete? I enjoy technology, but this is about as techy as it gets for my level of knowledge. Thank you!

    9/21/08 3:46:05 PM[487] 2008-09-21 15:46:05.982 AddressBookSync[491:10b] AddressBookSync (client id: error: Exception running AddressBookSync: CoreData could not fulfill a fault for '0x205cea0 <x-coredata://5590BB85-95C9-42D7-8D9A-0CBD20FD9E47/ABCDEmailAddress/p376>'

    9/21/08 3:57:53 PM AddressBookManager[518] Metadata without a record: {(
Previous 1 2 Next