Previous 1 2 3 4 5 Next 71 Replies Latest reply: Dec 8, 2009 8:16 AM by mfinzel Go to original post
  • Poseidon Level 1 (0 points)
    This finally worked for me. Thanks Casper. 2.1 is awesome.
  • db3520 Level 1 (0 points)
    Well said CG.

    I have a level 2 direct contact number at apple who is trying to look more deeply into this error. We all know that any given number of 3dr party aps reside on the same OS system. This may be part of the problem as some seem to work fine.

    I am wondering why apple has added the 64 bit version when the 32 bit version worked fine with 64bit....Or at least I am unaware of 32 bit 7.6 itunes problems.

    I have unregistered and re registered windows installer 4.5 and all aps including quicktime and a few other apple aps open fine.

    Only apple mobile device and itunes64 are popping a windows installer error and I believe its popping from within the apple program not from vista.

    I will post update comments from apple tech if it proves positive results.

  • skcud9880 Level 1 (0 points)
    I'm running Vista 32-bit on a Dell 1720, and iTunes 8 will not install due to the Mobile Device Support error. I have tried 7 times to install iTunes8. I am the "set" administrator and only user of the computer, but the error message instructs me to verify that I have access to that directory that the installer cannot write to.

    The error message during install of iTunes 8 is: "Error writing to file: C:\Program Files\Common Files\Apple\Mobile Device Support\bin\EventFixer.exe. Verify that you have access to that directory."

    After I choose to Cancel the installation (since I have no choice, because "Retry" fails) I get a new error message: "Error writing to file: C:\Program Files\Common Files\Apple\Mobile Device Support\bin\AppleSyncNotifier.exe. Verify that you have access to that directory."

    I successfully uninstalled iTunes7. I have tried to uninstall Apple Mobile Device Support leftover from iTunes 7, but Vista cannot uninstall it. I have tried repeatedly, but get the error message: "The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2330." Keep in mind this was an uninstall and not an install.

    I thought if I could uninstall this unnecessary (left-over) piece of the software, that I could successfully install iTunes8 without getting the Mobile Device Support install write error. I've tried a few other things under the support strings for iTunes installation, but after failing to resolve the issue, I hope someone can forward this on to the Apple executives.

    It's probably a known issue, but nothing on the internet is acknowledging the issue has been identified. The problem goes beyond the 64-bit version of Vista. I hope for a fix in-the-works.
  • skcud9880 Level 1 (0 points)
    Also, I forgot to mention an experience with the previous version, iTunes7, with all of its updates. For a few months, I had been getting the error message that my Apple Mobile Device Support bin is corrupted and to run chkdsk. However, when I hit schedule chkdsk, it does not run at restart. I have administrator status.

    Now I wish I had iTunes7 back...Those error messages don't seem so bad, now that I do NOT have iTunes at all, because I can't install iTunes8. Even creating a new user account with Admin rights in Vista, I could not install iTunes 8.
  • CasperGemini Level 5 (4,305 points)

    Have you tried using the Windows Installer Cleanup Utility to remove the Apple Mobile Device Support application? It's available at It tends to work better than Programs & Features in Windows... Perhaps if you can get the older, possibly damaged software completely removed, you'll have an easier time getting the newer software installed.

  • skcud9880 Level 1 (0 points)
    Yes, and thanks for the suggestion. I tried about 2 weeks ago and again 5 minutes ago. The download for msicuu2.exe won't install either.

    I get a Windows Script Host error message:
    Script: C:\Users\Skcud\AppData\Local\Temp\IXP000.TMP\StartMsi.vbs

    Line: 17
    Char: 1
    Error: Permission denied
    Code: 800A0046
    Source: Microsoft VBScript runtime error

    Luckily, I found my install file for the last updated version of iTunes7 and re-installed it. I guess I'm an iTunes7 user for life now I can't be the only 32-bit Vista user experiencing this issue. I also updated my drivers and bios version last night off of Dell's website. I hope Apple or Microsoft will acknowledge that one of the products is flawed and they are investigating it for a resolution. That's what I'm really looking for.

    I appreciate any further suggestions that you might try.
  • EmeraldICE Level 1 (0 points)
    I'm having this exact problem as well.
    I've spent about 3 hours googling this and can hardly find any information at all, but I did find a few threads of people having the same problem. Good to know it's not just me.
    To make a long story short, something went wrong with iTunes so I decided to uninstall and reinstall it. I did so, and got the errors mentioned above. I can't sync my iPod anymore because when I plug it in it says im missing the required software. I also get that "windows has stopped working" error when trying to install and when it tries to install mobile device support it just rolls back the install.
    Itunes still works and I can listen to my music on the computer but I can't sync my phone or iPod.
    Also, even though I install the 64 bit version, it still runs as 32.
  • endever81 Level 1 (0 points)
    I'm having the same problem. 64 bit vista fails to install AMDS. I extract the specific install file from iTunes864setup and it tells me there was an error and it rolls back the install and installs nothing. I tried the alt admin account with no luck. It's been a week since any posts on this thread. Has anyone had any luck getting around this problem?
  • blairmi2 Level 1 (0 points)
    same problem here...add me to the list
  • IronStar7 Level 1 (0 points)
    I have this same problem.
    This needs to be fixed.
  • nsun1975 Level 1 (0 points)
    same problem, too.

    but i guess there is still no sol'n yet.

  • gumbi66 Level 1 (0 points)
    Same problem on the 32 bit, only I just bought the sucker so I can't even do the initial sync to put anything on it!
  • nsx241 Level 1 (0 points)
    Hi all.

    Been watching this topic for well over a month. Having the same issues. It seems that starting with iTunes 8.0.1 and onwards, this issue causes AMDS to flake out on install. With the latest, it still occurs.

    Here's what I found:

    Take the latest iTunes 64 bit download (or versions 8 onward), then extract the installer (*.msi) to a folder. Run the "AppleMobileDeviceSupport64" from the command line as follows:

    C:\>AppleMobileDeviceSupport64 /log c:\log.txt

    which will the installer output to file c:\log.txt. The error happens here:

    DIFXAPP: INFO: ENTER: DriverPackageInstallW
    *DIFXAPP: INFO: Installing INF file 'C:\Program Files (x86)\Common Files\Apple\Mobile Device Support\Drivers\usbaapl64.inf' (Plug and Play).*
    *DIFXAPP: INFO: Could not open file C:\Windows\System32\DriverStore\FileRepository\usbaapl64.inf_dc8244e3\usbaapl64 .inf. (Error code 0x3: The system cannot find the path specified.)*
    *DIFXAPP: ERROR: PnP Install failed. (Error code 0x3EE: The volume for a file has been externally altered so that the opened file is no longer valid.)*
    DIFXAPP: INFO: Attempting to rollback ...
    DIFXAPP: INFO: No devices to rollback
    DIFXAPP: INFO: RETURN: DriverPackageInstallW (0x3EE)
    DIFXAPP: ERROR encountered while installing driver package C:\Program Files (x86)\Common Files\Apple\Mobile Device Support\Drivers\usbaapl64.inf
    DIFXAPP: InstallDriverPackages failed with error 0x3EE
    DIFXAPP: RETURN: InstallDriverPackages() 1006 (0x3EE)
    Action ended 20:30:15: InstallFinalize. Return value 3.
    Action 20:30:15: Rollback. Rolling back action:
    Rollback: MsiInstallDrivers
    Rollback: MsiRollbackInstall
    DIFXAPP: ENTER: RollbackInstall()
    DIFXAPP: 'CustomActionData' property 'DIFxApp Version' is 2.1.
    DIFXAPP: 'CustomActionData' property 'componentId' is {9AA3828A-F852-11DB-8E29-6C6B55D89593}.
    DIFXAPP: 'CustomActionData' property 'flags' is 0x17.
    DIFXAPP: 'CustomActionData' property 'installState' is 2.
    DIFXAPP: 'CustomActionData' property 'ProductName' is Apple Mobile Device Support.
    DIFXAPP: 'CustomActionData' property 'ManufacturerName' is Apple Inc..
    DIFXAPP: This was the component where the install failure occurred. The rollback for this component must have already occurred at the time of failure. No need to rollback again
    DIFXAPP: Rollback failed with error 0x2
    DIFXAPP: RETURN: RollbackInstall() 2 (0x2)
    Rollback: Copying new files
    Rollback: Moving files
    Rollback: Creating folders
    Rollback: Removing system registry values
    Rollback: Deleting services
    Rollback: Stopping services
    Rollback: Updating component registration
    Action ended 20:30:21: INSTALL. Return value 3.

    However, if I use the drivers (AMDS installer) from iTunes 64 bit, I don't get the error and the install finishes. Unfortunately, iTunes requires a newer driver, so I'm stuck at Those having the same problems, try the above and see if you get the same output. I'm going to log a bug against this in any case.

    In the meantime, the workaround if you can't get you phone to sync is to not install Or if you have, uninstall it, download iTunes, extract it to a folder (use winrar or winzip), and run only the "AppleMobileDeviceSupport64" installer. Then grab, and run only the "iTunes64" installer.

    Here are the download links:

    iTunes 127.20080731Mlo9i/iTunes64Setup.exe

    iTunes 20080911.gtre4/iTunes864Setup.exe

    Apple, please fix ASAP!

    Message was edited by: nsx241
  • happycamel86 Level 1 (0 points)
    Hi, i just came across this thread after a few days of googling information and once i got it down to AMDS64 being my issue, i found this thread

    basically i'm having the exact same issue as the OP is, and in reponst to nsx241 i which to know about the following

    my iPhone is updated to version 2.2, i believe this version absolutely requires version 8.0+ of iTunes to work together. will the 7.7 AMDS64 work with 8.0 and if so will it still be able to communicate with my iPhone when it's using 2.2?

    my OS is Windows Vista Ultimate x64 with SP1

    i formatted on saturday (6th dec) and have been running into this issue with iTunes / AMDS64

    it would be wonderful if apple would come out of hiding and admit there is an issue there and they are working on it, instead of keeping us all in the dark
  • nsx241 Level 1 (0 points)
    Yep, I upgraded to 2.2 using the drivers and iTunes Syncing and everything works fine. Until Apple admits the problem and fixes it, don't upgrade your iTunes version.

    Message was edited by: nsx241