Previous 1 6 7 8 9 10 Next 145 Replies Latest reply: Feb 5, 2009 7:16 AM by Hakko Go to original post
  • Gregory Lazarchik Level 1 Level 1
    I applied the fix(changed APOP to Password and saved) and it appeared to be working. An hour later I got the pop up again, I reentered the password then checked the advanced account preferences and the APOP was again chosen. There may be something more to this than changing the APOP to Password cause mine shifted back again without me doing anything.
  • kpalmal Level 1 Level 1
    So glad to see I wasn't alone on this! Have Verizon and just posted this same problem which I have been having for about a week in another thread in this forum. Someone on that thread alerted me to the APOP/Password problem. I changed to Password (moments ago) and so far so good. I am discouraged, however, to see Gregory Lazarchik's comment above.... Hope it doesn't revert spontaneously!
  • thedarkhalf Level 1 Level 1
    Same issue over here. I have 4 accounts in Apple Mail. 3 of which are Verizon. They all ask me for my password every 10-30 minutes. I have a 4th account with my own domain name. That is running on an Apple xServe under 10.4 and it retains the password without an issue.

    My wife has her Verizon account under Entourage and it retains her password. So this is obviously a Apple mail issue with Verizon (and judging by the posts) Comcast and other external services.
  • geomaura Level 1 Level 1
    Foremike thank you so much...changing the preference to password from APOP has fixed the problen in all 3 of our computers. 2 days later and not 1 request for a password
  • thedarkhalf Level 1 Level 1
    Confirmed.. changing from APOP to Password works
  • amcf Level 1 Level 1
    You can count me as another Verizon user whose problem seems to be solved by changing the authentication setting from APOP to password.

    I have also been having this problem for about a week. It started for me on 11/16 or 11/17 as far as I can tell. I found this topic tonight because it's been driving me crazy. I changed the authentication setting a few hours ago and have been prompt-free ever since. This is the first time all week I've gone more than 5 minutes without at least one prompt. Thank you!
  • Ned Burks Level 1 Level 1
    Ditto here. Changing to Password from APOP does not hold. Changes back to APOP by itself and problem continues.
  • Ned Burks Level 1 Level 1
    Maybe for you . . . but for me and others the change to password from APOP does not hold. System changes back to APOP on its own.
  • thedarkhalf Level 1 Level 1
    Try it in this order

    Change from APOP to password.
    Quit Mail
    Delete passwords from Keychain.
    Run Keychain First Aid
    Check Mail and add passwords.
  • Goldsta Level 1 Level 1
    I also experienced the same problems with rejected passwords from my five verizon email accounts. I changed my authentications from apop to password, but my preferences kept changing back to apop!! - how? i donno. I left my preference window open, and that seemed to keep someone or something from changing "password" back to APOP. how? i donno. I closed the pref window after 15 minutes or so, wham...back to APOP and back to rejects. I opened the pref window, changed all back to "password", left the window open for a couple of hours-all good... no rejects... closed the window, and all remains well two hours after closing the window. how? I donno...what a stupid solution.

    Please note I still think it had something to do with my iphones, i have upgraded to 2.2 but i still experienced the rejects problem with all phones off, before and after that upgrade.
  • kentech Level 1 Level 1
    Hi, all. I'm another victim of this, and several of you have described it so precisely, I have nothing to add -- except to note I'm using a Mac Pro, System 10.5.5, Verizon FIOS 15/5. I'm amazed to see this problem "cluster" last week. For me, I thought I had done it to myself somehow when I swapped PCIe cards in slots 3 and 4 to try to get a SATA interface to work, a real stretch. (Conclusion: IOGear 2-port is hopeless!)

    I tried everything listed, including restoring various parts from Time Machine and other backups. I tried changing the access to those (2) account passwords in Keychain Manager. Tests would show the password working fine -- until sometime later, when the dialog would pop up. I finally stumbled across the Password/APOP distinction, and tried "Password." Problem gone. (I may have set it to APOP initially because that once worked when I was setting it up, I can't remember. But . . .

    I have to comment for those still having trouble: I have had password grief before (outgoing, in that case), and I found that changing anything having to do with accounts and passwords doesn't "stick" until you Quit and relaunch Mail. You think it's now changed because it asks you to Save when you are still in Prefs, and you agree. But, no, indeed! Not until you Quit and relaunch. I'm wondering if those who think the APOP setting is returning on its own are caught up in this hidden-cache issue. By all means, try quitting Mail!

    Is there a disk cache responsible? I haven't determined this -- could be in RAM only, and killed when Mail quits.

    Thanks to all who took the trouble to post about this. Now I know I'm not crazy in this way, at least.
  • Goldsta Level 1 Level 1

    not so. Actually my preferences that I changed to "password" and saved, came back on two of four of my email accounts as "APOP" after I quit and relaunched Mail. So quitting and relaunching Mail allowed someone or something to change MY preference settings!!!
  • kentech Level 1 Level 1
    Goldsta: "So quitting and relaunching Mail allowed someone or something to change MY preference settings!!!"

    Yikes, this is crazy! Do a Get Info on <Home>/Library/Preferences/ to check permissions on that file. What I see on mine is

    ken (Me) = Read & write
    Everyone = No Access

    This is pretty restrictive!

    The enclosing Preferences folder has the permissions:
    ken (Me) = Read & write
    Staff = Read & write
    Everyone = Read Only

    Are yours the same?

    More technically, if I examinee the plist in PList Editor, I see that my accounts are listed as items under MailAccounts. For each recognizable AccountName heading, the "AuthenticationScheme" item is blank. I don't know if this means it is at its default setting, but I don't think I'll experiment any further, lest I break something. Note that this plist seems to be in binary format, and you'll need a plist reader to see the contents, not just a text editor.

    It would be interesting to see what your values of AuthenticationScheme are (1) while you are having trouble (APOP) and (2) after you change it back to "Password."
  • Ned Burks Level 1 Level 1
    Thanks, but I'm a bit of a novice with Keychain. Could you tell me step by step how to delete keychain passwords? And do I need to restore these afterwards, or do they restore automatically.

    Thanks. Appreciate your help.
  • Ernie Stamper Level 8 Level 8
    The thing that must be considered is that something else is happening when connecting to the server, and the APOP authentication change is taking place after Mail is unable to connect for a time. I have one example of this with an account on the server of my church. During the period when that server went down before being replaced, the authentication changed changed from Password to APOP. I then had to change it back to Password myself.

    Please recheck everything, especially any setting you might have changed before discovering the APOP changeover.

Previous 1 6 7 8 9 10 Next