Skip navigation

"Cannot Get Mail - The connection to the server failed" problem SOLVED

189152 Views 38 Replies Latest reply: Dec 22, 2013 9:11 PM by Clairekaui RSS
1 2 3 Previous Next
GoneMobile Level 1 Level 1 (0 points)
Currently Being Moderated
Sep 26, 2008 11:58 AM
Hi All,

I had been getting a the dreaded "Cannot Get Mail - The connection to the
server failed" error on my first generation iPhone (firmware version 2.1) when syncing e-mail with an Exchange server. After many troubleshooting steps I found the problem was the size of the inbox (9K messages). After archiving older messages into folders the iPhone could again sync.

I hope the helps others.

BMc
MacBook Pro 2.33GHz, Mac OS X (10.5.5), 1st Gen iPhone ver 2.1
  • GSBTom Level 1 Level 1 (0 points)
    BMc, that did it for me and my iPhone 2G too, but with the addition of a HARD RESET. In my case, my Inbox only had ~900 messages, however.

    Steps I did:
    1. Created folder called "Temp"
    2. Move all messages (but one) from Inbox to Temp
    3. Do a Hard Reset (Hold down HOME and POWER for approx 10 seconds)
    4. Go into Mail, view the exchange Inbox

    Lo and behold, I see the single messages, and new emails appear. Cool! So I go ahead and move the messages from Temp back to Inbox, and all those emails (at least the last 3 days worth) now appear in my Inbox.

    Joy!
  • Bunchesinoz Level 1 Level 1 (0 points)
    I searched High and Low, followed every article.. Created the second virtual directory. I have been around the world.

    i resolved this by enabling Integrated authentication on the Exchange Virtual Directory in IIS in Security.

    Try it, you won't be sad.. It worked straight away for me....

    "Cannot Get Mail - The connection to the server failed" is all i got ever.. Every time i would recreate the account, account would get verified, etc etc.

    Try it....
    Heaps of them
  • James Berkery Level 1 Level 1 (0 points)
    I keep seeing these posts but there never is anyone afterwords that has said it worked. Our research and department says that Basic Authentication is what has to be set for the Active Synch to work at all. I paid an outside expert as well and he said that this is not the correct answer and that active synch requires basic authentication so someone is wrong here. All of our windows devices work fine it is only the Iphone and the Iphone works however it is constantly saying "Cannot Get Mail - The connection to the server failed". It is an annyoing popup that showes up then downloads the email calendars & Contact anyway. Enabling Integrated Authentication would break Active Synch
    Dell, Windows XP Pro, teset
  • ranjeetsodhi Level 1 Level 1 (20 points)
    Any updates on this issue guys? It seems that I have to add-and delete my exchange server settings from my iphone every other week to get it to sync. It stops syncing once I get this error till I delete and re-add my exchange account.
    Mac Pro, Mac OS X (10.5.5)
  • gobbledegoo Level 1 Level 1 (0 points)
    I was having the "Cannot Get Mail" problem on a new Exchange Server 2003. Turned out all I needed to do was install Exchange Server 2003 Service Pack 2 on the server. Now I'm as good as gold.
    Dell Optiplex, Windows XP
  • ranjeetsodhi Level 1 Level 1 (20 points)
    Another solution that works (i have tested it twice now) assuming that you don't have any control on when your company upgrades the exchange server:
    - Archive all the large emails, and limit the number of emails in your inbox.

    If you are like me, and leave all your emails in the inbox, then you will have to set the archive up to be more aggressive (I archive any emails older than a month).
    Mac Pro, Mac OS X (10.5.5)
  • OliG Level 1 Level 1 (0 points)
    We have the same problem with our iPhone 3G v2.2.1 / Exchange 2007 SP1 installation. Windows Mobile devices, like the HTC Touch Diamond, are working fine, but iPhones are not working correctly (I tried two iPhones).
    On the iPhones there often comes a popup message saying "cannot get mail, the connection to the server failed". Then if I wait some minutes and try again I can see that it has syncronized.
    Is there any solution to this. I'm using WiFi to syncronize all of the phones.

    Message was edited by: OliG

    Message was edited by: OliG
    Apple iPhone 3G, Other OS, OS ver 2.2.1
  • mcable Level 1 Level 1 (0 points)
    I got this to work.
    On the iphone (3G), go to settings/general/network and set up a VPN connection. (your network admins/help desk will know how to do this).

    Open mail on the iphone - should work now. Then turn off the VPN connection as it likely will prevent you from accessing other internet sites. Mail mysteriously still works though after the initial connection though.

    If you get the above mentioned error message in the future, toggle VPN on and off to get mail working again.

    A little annoying, but functional.
    iphone
  • raderuckus Level 1 Level 1 (0 points)
    I got this to work by moving all emails my user received on the day that the problem started to a Temp folder. The problem that he was having is that his inbox would download, flash emails then disappear. after a while he would get cannot get mail error. I moved all of the emails from that day to a Temp folder and synchronized again with success. he did have over 30000 emails in his inbox but that was not the problem apparently. hope this helps someone.
    iPhone OS 3.1.2
  • brianedow Level 1 Level 1 (0 points)
    Did you figure out what type of email would cause the iPhone to lose of the email. It has happened twice so far to me, I can not figure why?
    3gs, iPhone OS 3.1.2
  • grapejoos Level 1 Level 1 (0 points)
    raderuckus' solution worked for me. My iPhone was unable to get mail from my Exchange server inbox starting around 4:00pm yesterday. Several times I tried adjusting the email server address etc, and it would try to get mail again, but always fail around 4pm on 2/10/10. I moved the emails from around 4pm into a personal folder and that fixed the issue - it is now able to connect and get mail normally. I also did a hard reset shortly before trying this, though it did not seem to help.

    What's strange is that I've been using my iPhone with this same Exchange server for over six months and this has never happened before. Oh well. Thanks to raderuckus.

    Message was edited by: grapejoos
    iPhone 3G 32GB (Black), iPhone OS 3.1.3
  • Tame1248 Level 1 Level 1 (0 points)
    Phew finally something that worked and made sense.

    My history. I have 2003 server sp2 exchange server sp 2. been using mobile phones for a couple years and iphones since Oct 2009 no problems. had a failed raid controller which caused hdd corruption and after I got everything back up had to do a repair install and recovery. 2 out of 5 Iphones had issues connecting and syncing mail. calendar and contact sync properly.

    did what they said above. created another PST folder and moved all mail from inbox to it. Then sent test message worked fine. after that I moved current day mail from PST folder to inbox and sync was still good. then moved next 2 days and still good. I opted to leave the other 4000 messages in the old PST and had the User clean it up.
  • purd002 Level 1 Level 1 (0 points)
    I will always get this error when I'm in the office and connected to our wireless network. I forget that it automatically connects to the wifi and cannot connect to our OWA from inside our office with the settings I use to access the exchange server outside of the office.
    MBP, Mac OS X (10.6.2)
  • NeoDavid Level 1 Level 1 (0 points)
    A hidden fix for this is in active directory, under the persons 'advanced' security permissions. You must 'check' the "include inheritable permissions..." at the bottom of the window.

    In Active Directory Users and Computers (be sure that View > Advanced Features is on) , you go into the user account that is having the problem (yours in this case), and right click, Properties.

    Once you’re in the user account properties, click the Security tab, then the Advanced button. “Include inheritable permissions from this object’s parent” needs to be checked. This means top-level permissions from the Exchange server itself are able to propagate down to user account settings.

    We found this out using the Exchange remote connectivity analyzer at https://www.testexchangeconnectivity.com which is a great site (owned by Microsoft) for troubleshooting all sorts of problems with remote Exchange access.
    macbook pro iphone, iOS 4
1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.