Previous 1 2 Next 19 Replies Latest reply: Oct 2, 2009 7:37 AM by porko8833
Alorain Level 1 Level 1 (0 points)
Hey guys, I've recently come across an annoying issue with my iphone (3g) with regards to connecting to the internet when not on a wifi connection. I recently returned (to Hong Kong) from a trip to Nepal on which i brought my iphone. My phone several times connected to the local Nepal carriers, but I didnt make any calls, receive/send any mail or texts or attempt to access the internet. When I returned to HK however, I noticed at the airport when I once again connected to my own carrier, I received the following message whenever I try to access the internet (even through maps) "Cannot Open Page" [Safari cannot open the page because it is not connected to the internet]. The odd thing is, my phone calls and sms's still work, so my carrier is still connecting, but there is absolutely no data being transferred over the network!! The problem has persisted for nigh on 2 weeks now, and I have tried several reboots of the iphone, to no avail, as well as removing my sim card and re-entering. Any ideas? Was it connecting to the carrier in Nepal? Or is that likely unrelated?

Macbook Pro C2D 2.33ghz 2gb, Mac OS X (10.4.11)
  • realhiphop0331 Level 1 Level 1 (75 points)
    I do not see why the trip to Nepal is relevant.
    Go to…
    settings>general>about
    check to see that under the listings "network" and "carrier" the same name appears. it should be that name of your carrier. if they are not the same then the phone is not connecting to your network for data. if this is the case then go into...
    settings>general>network
    enable "data roaming" and "3G"
    if this is not the problem I'm out of ideas
  • Alorain Level 1 Level 1 (0 points)
    thanks for the help, but unfortunately, this did not resolve the issue. My carrier and network both indicate the same, 3 (HK). Its very odd.
  • chamsters Level 1 Level 1 (0 points)
    same issue here. did you have any luck fixing it? i'm on o2 UK, haven't touched a thing!

    when i reset to factory defaults it starts working again. but the second i restore the backup (even before i install any of the apps - this is the base backup restore including voicemail + sms + settings i guess) it stops working again.

    looks like i'm restarting from fresh.
  • paulsalter Level 2 Level 2 (465 points)
    Have you checked in

    Settings->General->Network->Cellular Data Network

    This should have a username/password for the country you use data in
  • Alorain Level 1 Level 1 (0 points)
    Hmmm, mine is blank, though I do not recall having filled it out before while it was working. How would I find out what should go there?
  • John Ransdell Level 1 Level 1 (5 points)
    Hi there, did anyone get this problem fixed?

    I'm having the same problem with an iPhone 2G. After the firmware update the phone works find, except that I hvae not data service over my carrier, in this case Orange CH.

    Cheers, JP
  • Grhyme5s Level 1 Level 1 (0 points)
    Yeah, me too. I am a AT&T user that is subscribed with everything they require. I have the iPhone 3G and just now (for no apparent reason) I cannot connect to the internet via my service provider. I was literally using my 3G internet capability (got to love Pandora) less than four hours ago. However when I attempted to listen to some more just now, I found that my 3G was unavailable. All of the problems the original poster described is true for my phone as well. I have restarted 3 times, turned it on and off (in case somehow it would react differently), and I have restored it through iTunes. I am even running the current update. I am at a loss and I really want to fix this because I honestly listen to Pandora aprox. 4 hours a day. Also, the last time I restarted it, my phone froze and would not let me do anything until i connected it to my computer. I am so confused please someone come look at this and help me (us) out.
  • Kons21 Level 1 Level 1 (0 points)
    Hey guys. I stumbled upon this forum as I was experiencing the same problem. Nevertheless, as I was reading the discussion here I also restarted my phone and it now works. I think the phone probably did change networks and couldn't switch back. Restarting the phone seems to have cleared that up. I hope that helps.
  • mrcoffee03 Level 1 Level 1 (0 points)
    I too are experiencing the same problem on a 8gig 3G Telstra Australia iPhone that was bought outright. I also have another (same) iPhone and the settings on both are identical yet the new phone refuses to connect. I have tried a few ideas/suggestions including: settings, general, network, cellular data network and changing it from telstra.iph to telstra.internet. this works but I think something is wrong because to .iph refers to iPhone (I have switched it back until to confirm with telstra about this).
    I have also tried settings, reset, reset network settings but this did not help but has worked for others.
    I have also tried turning off the unit and taking out the sim card and restarting the iPhone but again no luck yet.
    I plan to speak to both Telstra and Apple to see if this problem has a simple solution and will post a new thread titled "solution to cellular network problems".
    Personally by all the trials and errors so far I believe it is a carrier problem and having to re-enter the pin on this phone everytime I re-boot it suggests it could be sim card related.
  • mdmcholet Level 1 Level 1 (0 points)
    I have this problem on O2 in the UK on a pay and go deal...the settings change on their own to mobile.co.uk (ie the contract setting) from payandgo.co.uk

    Its happening more and more sometimes 4-5 days now

    I go and change the data network settings and sometimes it sticks, sometimes I have to restart, sometimes I take out the sim and put it back in...no one things works.
  • atom43 Level 1 Level 1 (0 points)
    hello everyone.. Just a question (hope i dont get banned or so for mentioning..): is your iphone jailbroken maybe??
  • Whizzkid Level 1 Level 1 (0 points)
    Hi guys i also had the same problem you are having with my iPhone 3G on 02. The only way i found to solve it was to reset the network connection on our phone.
    To do this go to: Settings>General>Reset>Reset Network Settings.
    Your phone will then shut down and restart and it should then be able to connect again.

    Hope this helps
  • mn101 Level 1 Level 1 (0 points)
    Hi, I am just having the same problem .
    I bought my iphone in Italy and now i am in New Zealand.
    well..............does not connect with 3g not even trying a new zealand sim card with the appropriate plan.
    Did you work this out some how ?
    I feel a bit nervous about resetting as the machine is from overseas.
    anybody could help me to find the settings for vodafone new zealand '
    here the vodafone people are terrible
    thanks
    mn
  • Luke George Stewart Hamilton Level 1 Level 1 (0 points)
    LEGEND! Its fixed!! by doing the network settings reset it worked first time. Awesome. THANKS
Previous 1 2 Next