Previous 1 27 28 29 30 31 Next 457 Replies Latest reply: Apr 24, 2016 9:12 PM by alienimplant Go to original post
  • iBananaJoe Level 1 Level 1

    @Jorge Castillo S.: Any success so far not having kernel panics by replacing the kext file?


    Hi everyone, till yesterday I'm reading through all these posts and articles affecting the MBP Mid-2010. And sadly I'm also affected. I already installed gfxCardStatus to monitor the used gfxCard. In my case I cannot exactly blame the swichting process, having some kernel panicks in inconspicuous situations. For example yesterday I just enlightened my MB after turning the screen off while it downloaded a file. Without explicitely selecting the open finder window I tried to move a file in there and bam, the almost each and every day seen black screen appears.

    I installed the MBP video update from here for Lion, hoping it prevents some crashes. In respect of the warranty I'm not sure whether my MBP would fail that mentioned test and I would have the extended warranty. On the other side, having read many posts from you, replacing the logic board seems to fix the issue in some cases. But honestly I'm not sure whether I got the nerves to first having to discuss my warranty extension with apple and afterwards having my logic board exchanged twice. Like you all I'm really disappointed in Apple and their missing participation in this discussion about that issue!


    my crashes:

    - kernel panicks during startup

    - kernel panicks during usage of MBP

    - endless white-screen on shutdown



    my data:

      MacBook Pro 15'' i7 (Mid-2010)

      Chipset Model:          NVIDIA GeForce GT 330M 512 MB

      Revision ID:          0x00a2

      ROM Revision:          3560

      gMux Version:          1.9.21

      OS X Lion 10.7.3

      (upgraded to Lion from SL 10.6.8 hoping to get rid of these crashes)


  • Jorge Castillo S. Level 1 Level 1

    Hi iBananaJoe,


         In my case the most of freezes were related with NVDA(OpenGL): Channel exception or similar messages. Until the moment, after delete or changed the .kext file, I've not had new freezes, excepting once that system did not respond after being loaded. In such ocassion, I reviewed Console and I didn't find any error message (none related with Channel exception, I think). Perhaps, similar responses are linked with differents systems malfunctions...



  • iBananaJoe Level 1 Level 1

    I didn't have any crashes while running the system after that video update I've mentioned in my last post. Just one while booting my machine without touching it on login-screen for around 20 min it got stuck.

  • madweasel Level 1 Level 1



    Having the frequent Parse Error etc problems, causing artefacts, freezing etc.


    Well, I did as Adel suggested and things were much much better. But then, as I was browsing on Firefox, it happened again (I keep console open all the time to monitor this). And lo and behold, I discovered that it only happened when I used Twitter on Firefox. Could this be just a coincidence? I can replicate it now. Load Firefox, go to Twitter's main site and then the Kernel: Channel exceptions start after a couple of seconds.


    Is this signficant, do you better informed people think?


    I leave the Twitter page and the Kernels disappear.


    I will keep monitoring this but would welcome any explanation from you all.


    PS - no problem with Twitter on Safari. Odd, eh?

  • neoark Level 1 Level 1

    Now i am getting this error... I took computer to genius bar and they keep refusing to acknowledge the error:


    5/1/12 8:19:21.000 AM kernel: NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error

    5/1/12 8:19:21.000 AM kernel: IOVendorGLContext::ReportGPURestart

    5/1/12 8:19:21.000 AM kernel: NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error

    5/1/12 8:19:22.052 AM sandboxd: ([124]) DumpGPURestart(124) deny file-write-create /Library/Application Support/SubmitDiagInfo

    5/1/12 8:19:22.062 AM sandboxd: ([124]) DumpGPURestart(124) deny ipc-posix-shm apple.shm.notification_center

    5/1/12 8:19:22.063 AM sandboxd: ([124]) DumpGPURestart(124) deny ipc-posix-shm apple.shm.notification_center

    5/1/12 8:19:22.065 AM sandboxd: ([124]) DumpGPURestart(124) deny ipc-posix-shm apple.shm.notification_center

    5/1/12 8:19:22.067 AM sandboxd: ([124]) DumpGPURestart(124) deny ipc-posix-shm apple.shm.notification_center

    5/1/12 8:19:22.068 AM sandboxd: ([124]) DumpGPURestart(124) deny ipc-posix-shm apple.shm.notification_center

    5/1/12 8:19:22.070 AM sandboxd: ([124]) DumpGPURestart(124) deny file-read-metadata /Library/Managed Preferences

  • Rick Auricchio Level 2 Level 2

    I too did what Adel suggested. So far so good, but it's hard to know whether that fix works, since I don't have a quick way to reproduce the problem.


    Adel suggested this: "I deleted the Apple Power managent KEXT inside the extensions folder, and now I have auto switching enabled, and no more halt at the login screen or what so ever.. everything is working fine..."


    I have two concerns here:


    1. With this kext removed, I suspect the kernel is not managing power to the NVIDIA chip, which tends to nullify the advantage of graphic switching in the first place. It may be no better than simply turning off graphic switching. Sure, we switch, but if the NVIDIA chip stays powered-up, we save nothing over simply using it all the time.


    2. Jorge's use of the early-release 10.8 version of the kext has a few drawbacks. First, the 10.7 kernel may be ignoring it due to incompatibilty. If so, then the result is the same as simply removing the original kext. Second, the 10.8 kext may change as we approach the 10.8 release. Third, it may have other side effects.


    So, for now, I'm running without the kext. I'm not sure how hard to press Apple for another MLB swap, when the first MLB passed their special graphic test. I do want the computer to work as intended, so I'm mulling it over.

  • bulletproof. Level 1 Level 1

    I have the exact same error you guys are getting on a brand new Retina MacBook Pro.  It is triggered when I log back into my computer while the screensaver is running.  I enter the password and I log in, but the screen saver stays up and I can only move the mouse cursor.  I can't get to the desktop or any application.  The only thing I can do is hold down the power button and force a power off.  When I check the console afterwards, I see the error:


    8/30/12 1:32:59.191 PM WindowServer[75]: MPAccessSurfaceForDisplayDevice: Set up page flip mode on display 0x18c148c1 device: 0x1092c9d30  isBackBuffered: 1 numComp: 3 numDisp: 3

    8/30/12 1:32:59.000 PM kernel[0]: NVDA(OpenGL): Channel exception! exception type = 0xd = GR: SW Notify Error

    8/30/12 1:32:59.000 PM kernel[0]: IOVendorGLContext::ReportGPURestart


    So far Apple support has been pretty worthless.  They don't even want to see the error in the console log.  They had me reset the PRAM and System State and said call back if it happens again.


    It happens two times a day, typically after the screensaver has been running for 5 or 10 minutes when I step away from my desk.

  • madweasel Level 1 Level 1

    I realise that this might be a bit flippant, and you might already have considered this among the posting above, but my NVDA(OpenGL): Channel exception! problem went away when I started to address Flash as the possible cause. I have been using ClickToFlash ( for safari and it has worked a treat.

  • bulletproof. Level 1 Level 1

    I formatted the computer and reinstalled OS X Mountain Lion from scratch and did not install Adobe Flash at all.  It seemed better for a while but it still happens and I still get the same error in the console about the graphics card and a channel exception.  Apple support has been useless and I hate that I have to call them instead of emailing.  In fact, they refuse to allow me to email them the console log.  The support guys says he doesn't have email and I get the impression that he doesn't even know what the console is.

  • julien banchet2 Level 1 Level 1

    I'm having a huge display corruption issue as well, and hope I'll manage to finish this reply before it starts:


    Happened for the 4th time in a row this afternoon, in the middle of code editing (no screen saving involved) on a 2 week old installation of 10.8 installed from USB key + Server component from the App Store and barely updated to 10.8.2 today


    It's a late 09 mac mini server (bought with my EPP rebate at the time;-) )


    This unit went over the atlantic 3 times, compiled billions of lines of code, hosted half a dozen websites, launched hundreds of VMs with it's little RAM...

    And never had a glitch until a few hours ago following the 10.8.2 update.


    Visually speaking, 3 times out of the four: got moved around crops of the image filling up in clouds of purple with green speckles, the fourth time, just heavily repeated crops of display a bit everywhere, here's a pic:


    I can still manage to save a few docs before it becomes unresponsive, the audio buffer (listening to music) stalls after a couple of minutes.


    Here's a piece of system.log



    Hope this get's fixed, I'm already feeling the mockery of devs around me using Linux (that I do appreciate) or Windows stations...


    In the meanwhile, is it possible to downgrade kexts since ML ? doesn't the system look to much into consistency since all the security/sandboxing rattling ?




  • julien banchet2 Level 1 Level 1

    Oh, these nice ones, minutes away, barely had time to open textmate:


    (the diagonal reminds me of some canvas redrawing done in Firefox, but I doubt it's the culprit, as the Dock gets squashed as well)

  • StephenCCH Level 1 Level 1

    Julien, these look just like Nvidia hardware issues. They happened with my MBP Nvidia card. Have you run a hardware diognostics test to help rule out the graphics hardware? Instructions located here:

  • stefanschuler.215 Level 1 Level 1

    It indeed is an harware issue with the nvidia graphics. Same for me. Had two exchanges of the logic board on my macbook pro 6,2 and now everthing wokrs fine. AASP confirmed that the issue is related to faulty nvidia graphic chips. Seems like apple is even shipping faulty Repalcement logic boards with this issue :(

  • Drake411 Level 1 Level 1


    This is my result of running the hardware test. Note the line Unknown video device.  My iMac is well past warranty.

    I also got some FIFO errors which are "First In First Out" which I take to mean that because there is a poor connection between the graphic chip and the board  data is lost. I believe the cause is poor solder joints fatigued by repeated heating and cooling. You my find youtube videos where people baked their screen cards in the oven to "reflow" these joints.  An electronic repair shop can do this too and it is often called "reballing" because the solder is applied as tiny balls that are sandwiched between the chip and board and then melted with hot air. This ensures good electrical contact and repairs the board. I wish I could say I know for sure that this will work but I believe it is worth some study.

    My prejudice is that the move to non-leaded solder is a factor in part failure and should anyone get their boards repaired out of warranty  to use the best quality reball/solder available by law. i.e using lead (Pb) where available. Your repairman will have more informed advise about this. Out of warranty disassembly is a big job only for the patient and the calm. My screen card can be replaced new from parts dealers for $250 so a reballing should be offered competitively to that. Of course used parts are suspect. Finally the baking in the oven is the least expensive option with the risks as great or little as you can believe from the various posts and DIY videos you can find.

    I hope your warranties are in place and do not need to resort to your own repairs as certified technicians charge so high as to make a new computer seem attractive.

  • julien banchet2 Level 1 Level 1

    Hmmm Stephen...


    The odds of it happening the hour I did the 10.8.2 were thin (even though the machine rebooted to process the update, having possibly avanced electronique fatigue, i really had a doubt) btw: some might find it weird, but I usually sense things well served me well in R276 ;-)


    And, the device being a late 09 mac mini server, I, of course, have long lost the AHT CD (online AHT isn't available for this little guy)...


    Though, I have downgraded to 10.8.0 friday, left the machine running over the weekend, update to 10.8.1 this morning (will not try 10.8.2), and deactivated Flash (because we all know Flash is the source of all illness in the world, ain't it :-) )... So far so good... and I'm also putting a bit of load on it


    I re-update later today to say if I got any crash or so, but really, 10.8.2 embedded many framework updates, including OGL and possible (but not sure) fresher Nvidia drivers... Too bad I don't really know how to use Pacifist to nail down the problem.


    Cya'all later !