Previous 1 11 12 13 14 15 16 Next 233 Replies Latest reply: Sep 7, 2009 12:36 AM by pgpenc Go to original post
  • ducksauz Level 1 Level 1 (5 points)
    After applying the 10.5.7 update to my MacBook 4,1 I found that I also had this problem. Reading through this thread, I did the absolute minimum that I thought would be required.

    * Deleted /Library/Preferences/SystemConfiguration/com.apple.PowerManagement.plist
    Reboot, Sleep, Wake, Sleep, Freeze

    This didn't fix it on its own.

    * Deleted /var/vm/sleepimage
    * Re-enabled ethernet(en0) in my Network profile
    Reboot, Sleep, Wake, Sleep, Wake, Sleep, Wake

    W00t! Fixed.

    It would seem that it's definitely the lack of having en0 enabled that is causing this problem. I would be dollars to donuts that deleted the sleepimage doesn't matter.
  • Jae B Level 1 Level 1 (0 points)
    Ditto, since deleting the sleepimage did not solve the problem for me. Might have freed up some space, though, because my sleepimage file is only 1 GB now, and it was much larger before.

    I am so glad I did not disable Safe Sleep as the top Google search result for this problem suggested. I did, however, install this app: http://www.jinx.de/SmartSleep.html so that my computer doesn't have to go into Safe Sleep anymore unless my battery level is low!
  • Braumeister2 Level 1 Level 1 (0 points)
    Ducksauz' suggestion worked for me. I believe the key was deleting the sleep image, but finding its location wasn't exactly easy and a Spotlight search didn't show any results. From another forum I found instructions to use the Go menu from Finder, Go To Folder, and enter the following:

    /var/vm/

    This revealed the sleepimg file which I deleted. I've successfully awoken from sleep several times since rebooting, so I hope my problem is finally solved. Good luck.

    B.
  • AdamH Level 1 Level 1 (60 points)
    Kigh wrote:
    I've found a solution or a work around that helps in my case.
    Problem: deactivated ethernet port in my active network environment while using airport alone!
    Mith my MBP I usually connect to the internet by WLAN and I use an environment setting with ethernet deactivated (maybe you too?).
    I've activated the ethernet port, saved the environment - apply - voila.

    Sleep mode works as usual.


    Wow, that worked GREAT! I thought the 2-sleep problem might have been because I would play games for a while before sleeping it a second time, making the computer VERY hot, but that's not it. I'll keep that Ethernet connection there just in case

    This solved my problem and I didn't have to delete any preferences or do any resets or reinstall any OSes. THANK YOU!
  • Braumeister2 Level 1 Level 1 (0 points)
    Well, I spoke too soon. After happily awaking from sleep several times, my Bluetooth icon changed to an X and indicated it wasn't available; a short while later, Bluetooth disappeared from my System Preferences and does not show as a piece of installed hardware in System Profiler.

    After doing a search for this problem, users reported rebooting solved it for them, but no love for me. So I reinstalled from my Leopard DVD, restored from my Time Machine backup, and installed 10.5.6 combo update only to have the exact same problem occur again; no wake from sleep, then disappearing Bluetooth.

    I was really really enjoying my new MacBook right up to the moment I installed 10.5.7. Guess I'm going to cash in on that AppleCare Protection Plan now. What a PITA.
  • Level 6 Level 6 (11,035 points)
    Enabling the Ethernet port fixed the exact same problem I had as described above.



    As others have also noted, this is the first time I was starting to lose my rag with Apple as I had to keep relying on autorecover across my apps to save any work i might have done when it went into sleep mode never to return again.



    Many thanks Kai, the work around was successful but I hope Apple take this seriously as it puts doubt in my mind over the quality of the future release of Snow Leopard.



    Stefan
  • Brian Dawson1 Level 1 Level 1 (10 points)
    Thanks Kigh! I activated the ethernet port and my MBP has been running and sleeping fine for weeks.


    Kigh wrote:
    Hi,

    I've found a solution or a work around that helps in my case.
    Problem: deactivated ethernet port in my active network environment while using airport alone!
    Mith my MBP I usually connect to the internet by WLAN and I use an environment setting with ethernet deactivated (maybe you too?).
    I've activated the ethernet port, saved the environment - apply - voila.

    Sleep mode works as usual.

    Greetings from Germany,
    Kai
  • William Dalzell Level 1 Level 1 (15 points)
    I'm experiencing the exact same behavior, and it is repeatable and only happened with 10.5.7. The MBP will sleep if I chose it from the menu, only fails to sleep and hangs the whole computer if I close the lid. Has anyone figured a way to get it out of the hang other than holding down the power button to force quit? I haven't found any button combination that gets its attention.

    I read in another thread on this problem that resetting SMU and PRAM would correct the problem, but I haven't had any success with this remedy.

    Anyone have any other ideas?
  • spogburn Level 1 Level 1 (0 points)
    My Ethernet was already active and I tried making it inactive, then active again, but that didn't work. Deleting the plist files worked - pasting from an answer above, this is what I did:

    The files are located here:

    HD> Library> Preferences> SystemConfiguration

    These files need to be deleted:

    preferences.plist
    com.apple.smb.server.plist
    com.apple.network.identification.plist
    com.apple.nat.plist (This one was not in that folder so I didn't delete it.)
    com.apple.airport.preferences.plist

    Drag each one to the trash, and you will need to enter your system password each time you place one into the trash.

    **

    This appears to be working for me.
  • William Dalzell Level 1 Level 1 (15 points)
    update:

    FWIW I tried the Ethernet activation as advised in this thread and after two days it still seems to be working.
  • audioblood86 Level 1 Level 1 (0 points)
    I have tried the Ethernet option and it doesn't work for me. As much of an annoyance this is to me, I am wondering, is restarting by holding the power key down going to be detrimental to the computer if you have to keep doing it once or twice a day? I cannot believe this has not been fixed yet.

    I will try your fix next. I want to be sure before I do anything, so are those files necessary for anything?

    Message was edited by: Lindsay B
  • Bruce Etnyre Level 4 Level 4 (1,440 points)
    Doing a hard power down by holding the power button can be very detrimental if the computer is doing any directory updates, which it does regularly. It will corrupt those files and eventually the system will become very unstable.

    Removing those files only temporarily removes them. On a restart, the system generates new ones that are needed. I hope that solution works for you.
  • audioblood86 Level 1 Level 1 (0 points)
    Ok, thanks for the info. Now, if I remove the files and they regenerate, does the problem come back?
  • Roy Hooper Level 1 Level 1 (5 points)
    Same problem; 10.5.7 hanging on second attempt to wake from sleep.

    I had a second Network Location defined, but was not using it (I was using Automatic). Its presence was sufficient to cause the hang. Removing it and leaving only Automatic (with both Wifi and Ethernet available) fixed it.
  • ELeonard Level 1 Level 1 (0 points)
    Same exact problem. Second sleep machine locks up. Tech support said to reinstall after trying several fixes that did not take.

    E Leonard