Previous 1 3 4 5 6 7 Next 233 Replies Latest reply: Sep 7, 2009 12:36 AM by pgpenc Go to original post
  • Si262 Level 1 Level 1 (0 points)
    Adding Ethernet to my Network Service list appears to have worked. Many thanks for suggesting it, Kai.
  • Network 23 Level 6 Level 6 (11,875 points)
    fromagique wrote:
    If this link to the Ethernet port is true, it makes me wonder. Oddly enough, as I mentioned in one of my other posts, I've had a problem very similar to this in the past: the machine freezes in the same way as we've been seeing here, when the AirPort card is powered down. Any chance these are related?


    All I know is that I reported a bug a few months ago where the machine would lock up if you switched Network Locations under certain circumstances. When 10.5.7 came out I was happy because it seemed like Apple fixed that bug. But it is possible that fixing that bug caused this crasher. I don't really know, but they sure are in the same area.

    Does anyone know how to force a connection to be used over another one (besides turning off the one that's not desired?) Thx!


    In theory OS X is supposed to use the services in the order they are listed in the Network preference. You click the gear and choose Set Service Order to rearrange them in the order that you want them to be used. I'm not sure it always works right, though.
  • aduritz Level 1 Level 1 (0 points)
    great job Kai! adding ethernet interface fixed the sleep issue for me.

    cheers,

    Stoyan
  • BDJeep Level 1 Level 1 (0 points)
    Hopefully someone can help me as I have the same problem. I am connected only wirelessly. I am in my network preference and I see built-in ethernet. It says not connected. What exactly do I need to do to 'activate the ethernet port'. I also see ethernet settings under the advanced button for this location. All help is appreciated.
  • Network 23 Level 6 Level 6 (11,875 points)
    There is a difference between activation and connection. If the Ethernet icons are brightly colored, they are "active" and you should have no problem. It is not "connected" until a cable is plugged in. Active means it is ready to be connected. If it was not "active" then nothing would happen when a cable was connected.

    You activate and deactivate each network interface using the gear icon menu at the bottom of the list. When an interface is deactivated, it is dimmed.
  • AJM83 Level 1 Level 1 (0 points)
    Kigh wrote:
    Hi,

    I've found a solution or a work around that helps in my case.
    Problem: deactivated ethernet port in my active network environment while using airport alone!
    Mith my MBP I usually connect to the internet by WLAN and I use an environment setting with ethernet deactivated (maybe you too?).
    I've activated the ethernet port, saved the environment - apply - voila.

    Sleep mode works as usual.

    Greetings from Germany,
    Kai



    Many thanks Kai,
    Problem is solved for now. Would still like the underlying bug fixed tho!
  • StoryMan Level 1 Level 1 (5 points)
    My Macbook (May 2006) beach balls a lot after the install. I notice the beach ball in Safari more than any where. The CPU was running at 40%. I tried to repair permissions inside of OS X, but the disk utility would also experience the rotating beach ball. I had to repair permissions using the Leopard install Disk. It took a few hours and found a lot of issues. I haven't tried it since then. Anyone else experience this?
  • gurb Level 1 Level 1 (0 points)
    Yes!
    This seems to solve the problem.

    But how this should make the MBP kneel, beats me...

    Have fun.
  • nfmoll Level 1 Level 1 (0 points)
    Used your method and sleep freezing cured! Finally.
  • Brian Corchiolo1 Level 1 Level 1 (10 points)
    I was having trouble with sleep also. Deleting these worked for me:

    preferences.plist
    com.apple.smb.server.plist
    com.apple.network.identification.plist
    com.apple.nat.plist
    com.apple.airport.preferences.plist
  • William Kucharski Level 6 Level 6 (14,890 points)
    Network 23 wrote:
    The system log messages immediately preceding a forced restart are not consistent, so it's hard to identify a specific message that happens when sleep fails.


    That's fine, it simply means there may not be one in particular; that's why I asked, it's another data point on the issue.
  • rgolub Level 1 Level 1 (0 points)
    Same problem here with a MB except it only happens when I close the lid. If I send the system into sleep mode via the menu - it behaves....
  • Norby Wells Level 1 Level 1 (0 points)
    Hats off to Kai from Germany! Thanks for solving this problem... I think a job awaits you at Apple.

    I have a MacBook Pro 4,1 (2008) that was experiencing this very problem immediately after upgrading to 10.5.7 via the combo updater (don't think it matters whether you use the combo or the incremental) - would sleep the first time just fine but would not sleep the second time and locked up... only solution was to press and hold the power button to shut it down and then boot it back up again... realizing that you only got to close the lid once as it would lock up the second time.

    My network location was set to a custom configuration that I called Airport Only... the Airport was the only available "port" for network connectivity as I had deleted all others (ethernet, Firewire, etc.). Once I added back the ethernet port to my Airport Only location the lock up on second sleep problem went away. I configured the ethernet port in the second position (priority-wise) and did not have a ethernet cable plugged in. Saved the settings, rebooted for the heck of it and voila... no more freeze on second sleep.

    I don't believe that users that leave their network location to "Automatic" with all ports available will experience this problem. I have not tested this theory but would be willing to bet a beer on it!

    Thanks again Kai!


    Norby
  • rhentsch Level 1 Level 1 (0 points)
    Very strange problem. It seems to occur when only the AirPort interface is active and the machine is put to sleep.

    *OK, here's a woraround:*
    Look at the settings in your active network environment. If there is only 'Airport', your Mac will crash every second time it enters sleep mode.

    Add 'Ethernet' in your active network environment. Now it should work.

    @Apple: please fix it soon
  • irishfloyd Level 2 Level 2 (205 points)
    Hello all,

    I've tried most of the solutions here, including deleting the pref files, the sleep cache, and then called Apple. Was escalated to 2nd level, told there are some sleep issues with OS X 10.5. Referred to Genius Bar at Apple Store Sacramento to isolate hardware issue.

    Genius Bar was successful booting my machine from their boot drive, everything was totally fine with no sleep problems....though it was not system 10.5.7. They recommended Archive and Install (which they were totally willing to do even though I am a couple months out of 1 year warranty). Made me happy it did not appear to be a serious hardware issue.

    Did the Archive and Install reinstall, and all was fine until 10.5.7 update then I freeze every single time on the 2nd sleep. So strange.

    So until Apple publishes the fix to 10.5.7 I have to disable sleep on the MacBook. Slightly lame, but I am certain they will make this right.
Previous 1 3 4 5 6 7 Next