Previous 1 2 3 Next 2,123 Replies Latest reply: Feb 24, 2012 2:47 AM by Rightohh
Dan Gibbons Level 1 (0 points)
Just thought I'd see if anyone else is having the same strange problem with the WiFi on their iPhone after the 3.0 update.

Essentially, WiFi works fine after the phone has been freshly booted (i.e. right after a restart) - however, once it has put itself into standby mode it will no longer download data over a WiFi connection after the phone is turned on again. It remains able to find the WiFi network, but simply refuses to download data over it.

Have tried restarting my phone and changing the WiFi security from WPA to WEP, but to no avail...

iPhone 3G, iPhone OS 3.0
  • forty fort Level 1 (0 points)
    Same problem here.
  • Wally Van Wallenstein Level 1 (0 points)
    Same issue here as well.

    WiFi works very sporatically (usually for a brief period right after re-boot).
  • tommo3310 Level 1 (0 points)
    Yep, same issue here too.

    Works okay for a while, but then stuff stops downloading (safari/itunes store/app store etc), even though the wi-fi indicator says I'm still connected.

    No problems with wi-fi connection before 3.0 upgrade.

    It definitely seems to stop data transfer after a resume from standby, even though it's still connected. The only way to resolve is to turn wi-fi off and on again in the settings menu.

    Message was edited by: tommo3310
  • ManilaByNight Level 1 (0 points)
    same problem here too .... and not only is my wifi affected but also 3g internet access although the 3g icon appears, I am unable to access the internet via my wireless carrier.
  • Chronologie2 Level 1 (0 points)
    Same problem here too...
  • expresso3 Level 1 (25 points)
    similar problem....had wifi after upgrade, then this morning i had to reenter the security key.
  • JonIND Level 1 (0 points)
    Exact same problem here on an original iPhone trying to connect to a WPA2 Enterprise network after upgrading to 3.0.
  • iFidoBark Level 1 (0 points)
    Same problem here. Ran the 3.0 update yesterday and now notice the following problems with WiFi networking:

    1) Once iPhone goes to "sleep" WiFi connection is terminated and the phone stops pulling data (i.e. NO push e-email!)

    2) After "waking" phone up, the WiFi connection has been terminated. When i go to settings to reconnect, it cannot find ANY wireless networks (just keeps searching).

    3) WiFi becomes disabled by itself - I'm not making this up!!

    4) None of the above happens when the phone is plugged in/on a charge.

    5) None of the troubleshooting steps or articles resolve this issue.

    6) I don't have sufficient cellular network coverage during the day so I can't comment on the above also impacting 3G & Edge connections.

    What I do know is that the 3.0 update breaks WiFi and I really hope someone from Apple is reading this and can help!

    Message was edited by: iFidoBark

    Message was edited by: iFidoBark
  • ausher1880 Level 1 (10 points)
    i must be the only one not having an issue with this...
  • iFidoBark Level 1 (0 points)
    I wouldn't say that. Two co-workers also ran the update. One is having the exact same issues as me and the other isn't - although his phone was plugged in for most of the day and I bet he'll come in tomorrow with the same issues.
  • Davor Pasaric Level 1 (0 points)
    Today I have received my brand new iPhone 3G 16GB as a replacement for the old one with a dead mic. I have waited 4 weeks for a replacement unit (Vodafon Italy).

    It worked fine at first (old software), wireless worked fast and smooth and then I have updated to 3.0. It worked for 2-3 hours and now it can't find any wireless network! My friend's iPhone with old software still works and finds networks with no problem.

    Is it a 3.0 problem or I am extremely unlucky with another brand new faulty iPhone?
  • droolik Level 1 (0 points)
    Davor, I've knew that it would be better to wait for 3.1, but...
  • Irish2DaBone Level 1 (25 points)
    ditto... noticed some quirky behavior on my home Wi-Fi since R3.0 upgrade. With me, my signal will just become non existent at times regardless how close I am to it?
  • DarthAndroid Level 1 (0 points)
    Try disabling push email (drop it back to fetch on 15-minute intervals).
Previous 1 2 3 Next