Previous 1 2 Next 21 Replies Latest reply: Dec 16, 2009 4:39 AM by DP90
RUOkie Level 1 (0 points)
Just got a 3G iphone and the camera will not work. All other aspects of the phone are fine. I can open the cameral app, but the shutter will not open.

Whats the deal?

iphone 3G, iPhone OS 3.0
  • Ingo2711 Level 7 (21,515 points)
    Did you try to reset the phone by holding the sleep and home button until you see the Apple logo?
  • Anticravate Level 1 (0 points)
    Same here! any solutions anybody? help
  • RUOkie Level 1 (0 points)
    Yes, I shut down. No dice
    I did a hard reset. No dice
    I even went into preferences, disabled all apps, reset, enabled all apps. No dice.
  • Ingo2711 Level 7 (21,515 points)
    The next step would be a restore. In order to prevent corrupt files from installing again set it up "as new iphone"
  • jeffd1375 Level 1 (0 points)
    I'm having the same problem with the 3GS. Camera shutter never opens. Tried restoring as a new iphone. Didn't work.
  • bootrup Level 1 (0 points)
    Got the same problem. Restarting works only sometimes, but the problem persists.

    A pain.
  • Saraken Level 1 (0 points)
    I might have to try this - it's just a huge pain to lose all of my texts and Mail settings. This shouldn't be a problem in the first place, you know? I've had my iPhone for over a year, and this problem just arose a few weeks ago (it probably coincided with some sort of update - I don't recall). Rebooting and restoring don't help at all (unlike some people who say this helps for a while, my shutter is perpetually shut). Is Apple even aware that this is a problem?
  • Jones205 Level 1 (0 points)
    I was having the exact same problem. Camera shutter would not open at all, ever. I tried a restart, hard reset, retore and restore to new. Nothing worked. I even deleted and reinstalled iTunes from my computer (PC/Windows XP). Nothing. So I just got back from the Genius Bar. And I swear to you all the Genius had to do was restore to new phone on his computer namely a Mac. The camera shutter reopened like magic. As far as he told me that is all that he did. Crazy? Yep. Do I understand it? Nope. SO IF YOU ARE HAVING THIS PROBLEM AND HAVE BEEN TRYING/FAILING AT RESTORING ON A PC FIND A FRIEND WITH A MAC. I hope this helps somebody.
  • MungoBBQ Level 1 (0 points)
    I've got a Mac and I have the same problems, so obviously there is no difference in using PC or Mac during a restore, the problem remains still.
  • KigaliQT Level 1 (0 points)
    Same problem here. Any luck finding a fix yet?
  • Danny Mo! Level 1 (0 points)
    hello fellow iphone 3g users. in response to all the camera shutters not opening concerns, i have to ask one question; have any of your phones been exposed to water? you know, like, did it get wet while walking in the rain or has it been exposed to moisture somehow?
    my reason for the question is quite simple. my new iphone 3g did get wet during a rainstorm and i figured there goes my new iphone. some features continued to work immediately however the screen kept flickering. to my surprise i aired it out for sometime and wala! it continued to work like if nothing ever happened. the camera worked fine as well.
    about 2 weeks later i noticed that the shutter would not open. i called apple support and explained my situation but left out that i had exposed my phone to the rain. interestingly, the rep never asked if i may have been negligent somehow. he just proceeded to reset(new phone)/restart/reboot/reinstall you guessed it he did just about everything to try and help but to no avail. he eventually made me an appointment to the "Genius" Bar", assuring me that if it's a hardware issue or software issue they would replBce it with a new one.
    well, when my name was called the service rep said he would take it to the back to check on it. he came back and stated that "their indicators identified a wet spot" but couldn't explain why the shutter wasn't working because the wet spot indicator was on the other end of the phone. well, obviously the phone is not covered in this case. as i weighed my options, i realized that evertything else about the phone worked well and i would just be without a camera.
    my only gripe or peev would be that if the initial service tech had asked the proverbial question "has your phone gotten wet somehow?" i would not have waisted precious time in trying to get my camera shutter working again.
    i think apple should cut right to the chase and aske, "has your phone been exposed to water?" as this will alleviate the process and waist of time in trying to recover the (i believe, defective) camera shutters.
  • da braddah Level 1 (5 points)
    Aloha; I was having this same problem on my 2 month old non JB 3GS. Tried all the things people had suggested-even resorting to doing a restore in DFU mode and setting it up as a new phone. My phone has never been wet, dropped or abused in any way. Finally gave in and took it to my local Apple Genius Bar today. After they attempted to restore in DFU, it was determined that it's a hardware not software issue, and they just exchanged it no problem. The tech was so intrigued by it, that he had another tech come over to see it also-apparently they had never seen or heard of this before, even though I told him that there was a discussion on this forum about this exact topic. I would strongly suggest that anyone having this issue do the same. Any fix accomplished be powering off, resetting, or even restoring in DFU will in all likelihood be temporary at best. Might be OK for a week or a month, but guarantee it will resurface at some point. There is no updating or restoring away a hardware issue like this. They didn't know what is actually causing the hardware issue, but all the technical info from my visit will be forwarded to Apple so that all stores and Genius Bars will be aware and/or have access to the info-hopefully helping out everyone else that has this problem, as well. Although I don't know if this is true if your phone is out of warranty-they wouldn't tell me how they would handle that because they hadn't been confronted with it yet
  • Saraken Level 1 (0 points)
  • Todd Wilkinson Level 1 (5 points)
    Same problem with iPhone 3G with latest operating system. Only thing that works (sometimes) is to open another app, push power button/home button together (which takes a screenshot) and then switch back to camera.

    It's worked twice for me. Maybe it would have opened anyway. I don't know. Anybody else try this?

Previous 1 2 Next