Previous 1 2 3 Next 1,146 Replies Latest reply: Aug 19, 2013 7:35 AM by Landshark2007
blenderman345 Level 1 Level 1 (0 points)
Hi, I've got a problem with my Time Machine. It is an awesome thing. Used for storage, backup, and as wireless router. Was working last night, then this morning, I woke up and I got on my Mac and opened the internet. Nada. Then I went to my PC (ethernet connected to the TC). Nada. Followed by trying to reset it's setting, unplugging, replugging, etc. Then I looked, and the front status light is blank. It's not green, amber, blinking, nothing. In the back, when I plug it in, the back lights will blink(like it does when you plug it in) but nothing else to indicate it turns on. What should I do? Any help? Anybody else with this problem?

Macbook Pro 2.4 Ghz 2 GB RAM, Mac OS X (10.5.7)
  • Patrick Matheson Level 2 Level 2 (300 points)
    Have you had it long?
    There is a reset button on the back, it explains what to do in the manual. It will reset the TC back to factory defaults, but doesn't delete the data on the disc. You could try this to see if it was a corrupted firmware problem. (this is at your own risk)
  • Larsan Level 1 Level 1 (5 points)
    You are not alone.
    Last night my Time Capsule died in the same way after working without problems since March 2008. (I have also tried resetting according to the instructions.) It seems to me as a hardware fault. I had expected more than 16 month of operation.
  • nytcrwlr70 Level 1 Level 1 (10 points)
    My Time Capsule died last week just from unplugging the power (I was re-arranging my office). Fortunately it was covered under AppleCare but it wound up being a bad hard drive.

    If you Time Capsule has no sound or vibration then it's probably a bad hard drive or perhaps a bad power circuit. Either way, I recommend seeing someone at the Genius Bar and getting advice from them.
  • Cyclotrode Level 1 Level 1 (0 points)
    Weird...the same thing happened to me this morning. Just looked over at the TC and no light on the front. I tried the troubleshooting tips from the manual and still nothing. I did a search and found a post from a year ago on another forum where the poster let the TC sit unplugged for a couple of hours and it worked again. I'm going to try that first before making a Genius Bar appointment.
  • Cyclotrode Level 1 Level 1 (0 points)
    Update: Tried the two hour wait and plugged it back dice. Made an appointment with the Genius Bar for 3pm today and just came back. They plugged it it and saw the same thing I did, but were unable to replace it because it's out of warranty. Oh well, I had a nice 16 months of use out of it. I just wish they offered a repair option or something.
  • DBeal Level 1 Level 1 (0 points)
    My Time Machine died this week also. No power light in the front and all ports in back show a green light with no ethernet cable plugged in. I'm going to try and pull the hard drive to troubleshoot.
  • kenhotto Level 1 Level 1 (0 points)
    This seems to be the time of dying Time Machines. Mines is stone dead - just after the warranty is over. Thought it should have last a little bit longer... Have to crack it open to see what the problem is.

  • Calico Salsa Level 1 Level 1 (0 points)
    Well this is disturbing - add another dead TC to the growing count. Apple Support rep said she didn't have many reports, but searching this forum seems to show a regular instance of dead TCs.

    Mine too - drive dead, no light. Apple says they will replace the drive. DriveSavers estimates it would be between $900 - $2700 to recover the data on it.

    Hmmm - for $180. I can get a new TC, and I'll have to see what it would cost me to get something to try and pull the drives out and plug them into a bay to recover them myself. Not a clean room here, but maybe enough to pull off the data? Never done that before, but might be worth the learning curve.

    Would everyone please go to and register their feedback on the dying TC problem?
  • G5gyrl Level 4 Level 4 (1,465 points)
    Mine just died an hour ago! No power light at all. When I plug it in, the green lights on the back flicker briefly but that's the only sign of life. Any chance my MBP Apple Care might cover this? (2.5 years in)
  • Housewarmer Level 1 Level 1 (0 points)
    Wow, freaky, add one more to the dead Time Capsule list. Were they programed to all self destruct at the same time!?
  • G5gyrl Level 4 Level 4 (1,465 points)
    Very freaky, isn't it?! I'm going to take mine to the Apple Store this afternoon to see what they say.
  • chadders Level 1 Level 1 (25 points)
    My Time Capsule has died too. No green light indicating no power. I have checked the fuse but nothing. It seems as though the internal power unit has failed. Not good.

    No way of retrieving the backed up data either as far as I can see.

  • G5gyrl Level 4 Level 4 (1,465 points)
    Apple Care does cover it, I'll get a free replacement in the next day or two. YAY!

    I lose all of my backups of course, but I needed to clean up anyway.
  • Stefman Level 2 Level 2 (230 points)
    Add me to the list of dead time capsules. Its out of warranty so I'll most probably not replace it. Totally disappointed in this product and never buying one again.
Previous 1 2 3 Next