Previous 1 5 6 7 8 9 10 Next 137 Replies Latest reply: Feb 22, 2013 1:57 AM by Londoner86 Go to original post
  • screth Level 1 Level 1 (0 points)
    Well, after trying everything, I finally went and bought a CD drive cleaner and now it is working! The odd thing is I also tried these DVDs on a BRAND NEW PC, and they would give the the same errors as my MacBoook Pro. For those who are still having problems, I suggest buying a DVD cleaning disc.
  • Paul Downie Level 1 Level 1 (0 points)
    I’m getting Error Code 0x80020022, every time I’ve tried burning DVD’s under Snow Leopard. At least, ever since I had the 2010-001 security patch installed on my 2007 vintage Mac Mini running Mac OS X 10.6.2. Prior to this patch, dvd’s were burning acceptable well, from when I bought the Mini — with MAC OS X 10.5.2 — and I’d love to know what the holy heck is going on, or if anyone know’s of a fix.
  • t1chb Level 1 Level 1 (10 points)
    The only fix is to backup & install clean snow leopard.
  • Tran Hoang Long Level 1 Level 1 (0 points)
    Hi all,

    I have a same problem on my MBP Uni too. I can burn Tesco DVD-R but not Maxell/Verbatim DVD+R. I got a message something like 'optical drive can not power laser to burn this type of media...'. Tried busting compressed air to clean the laser head as someone here suggested, no luck. Just popped into Apple store today and the 'genius' told me that optical drive needs to be replaced. It takes 3-4 weeks in the queue! I dont really burn DVD that often but this is just frustrating on a 9 months old computer. Anyone got the same problem with powering laser head?

    Cheers
  • RickKC Level 1 Level 1 (5 points)
    Well, at least I'm not alone on this. Seems I'm spending more time on mac problems than actually getting anything done these days. Have to research doing a clean install now?
  • Eric Andrist Level 1 Level 1 (30 points)
    I had some success a few months back when I took my 2 drives out, took them apart and cleaned them. Right after that, I could burn DVD's again. But lately it's stopped burning yet again. So I took them out again and cleaned them, put them back in, and they still aren't burning.

    I read on here that someone said if you reinstall SL, it fixes the problem. Has this worked for anyone else? Has anyone tried just using a different login account to see if it's any different?
  • Eric Andrist Level 1 Level 1 (30 points)
    Are you still able to burn using the cheap replacement?


    bjorncm

    Posts: 9
    Registered: 10/17/09
    Re: Cannot Burn DVDs even with Snow Leopard
    Posted: Jan 6, 2010 5:49 PM

    I couldn't wait anymore so I bought a new external dvd writer one of those small cheap samsung things, and that works.
  • bjorncm Level 1 Level 1 (0 points)
    Yes Eric, works fine
  • Paul Downie Level 1 Level 1 (0 points)
    Same, here, the exterior burner’s working well!
  • Eric Andrist Level 1 Level 1 (30 points)
    1. cleaned 2 superdrives, burned a few disks successfully
    2. then it stopped
    3. Cleaned them again, still not working

    4. Loaded Leopard onto an external drive and booted up. Drives still won't burn dvd's

    5. Purchased a LaCie dvd burner.

    I CAN BURN DVD'S!

    So, not being any kind of an expert on the inner workings of the mac, I have to wonder this...

    When I installed Snow Leopard, did it somehow change the firmware on the superdrives since they no longer will burn in Leopard either (which they used to.)

    Is it possible to get older firmware somewhere to install on the superdrives?
  • aspik Level 1 Level 1 (10 points)
    I came across with this problem also. On some of the machines I upgraded. Not at all of them... It’s a bit weird, didn’t find the clue why / how this happens.

    I’m a bit paranoid, that systems I upgraded via SL disc image (restored DMG to a hard drive) are working perfectly and some of the machines I upgraded with a SL DVD are not able to burn DVDs/DVD DLs

    But still - it drives me mad sometimes - experimenting with the burn speeds etc..
  • PixelRogue Level 1 Level 1 (0 points)
    I've been having troubles as well. Took my machine to Genius Bar, and of course everything was working when in the store.

    Ok, so here is what I noticed. I can burn fine to CD, and 4.7 DVD-R. Memorex DVD-R 8.5 will not work. I inspected the files themselves and they seem fine. When I go back to the Genius Bar, they tell me there is something corrupt in the file, so I recreated everything and can burn each piece fine to smaller media.

    Error:
    The disc can’t be burned because because communication between the computer and the disc drive failed (error code 0x80020022).
  • mhibbs Level 1 Level 1 (0 points)
    I backed up, did a clean install and then restored my backup. Still can't burn via Toast or Finder (Medium Source Error). I went and picked up a cheap 3 pack of Maxell DVD-R and it WAS able to burn successfully. It still will NOT burn to the spindle of TDK DVD+R that I was attempting to use. It was a spindle of 100...I've burned at least 50 using this same superdrive under Leopard. Not sure if -R rather than +R is the difference or if Snow Leopard just now doesn't like TDK even though Leopard did. Still believe it to be a SL bug b/c these TDKs used to work fine before the update, but at least I found something that will burn.
  • savmagoett Level 1 Level 1 (0 points)
    No matter what burn program, what file source, what file type, what file location, what burning speed, what burning type, what disc brand, what burning drive (native Optiarc internal DVD drive or external NEC DVD drive) I use, NOTHING WORKS!!
    I am very very disappointed by Apple, they could at least acknowledge our issue…

    BTW TDK-Rs Don't work either!
  • quasialibi Level 1 Level 1 (0 points)
    Same here. Spindle of TDK-R doesn't work either.
    I even had TDK send me a new spindle after complaining (so the problem isn't their fault after all... Thanks for the understanding TDK!)
    Neither does it work with an external (LaCie) writer...

    Apple should REALLY address this problem as it's a big deal for professional users.
Previous 1 5 6 7 8 9 10 Next