Previous 1 2 3 Next 40 Replies Latest reply: May 11, 2010 10:40 AM by Meherally
Michael Duffy1 Level 1 Level 1 (140 points)
Since upgrading to Snow Leopard, I've had several instances where I woke up the machine and could not get on the internet. After 10 seconds or so, I get an error message which indicates that another device is using the IP address. The solution seems to be to reset my Airport. I have two AirPort Express stations and they are on a WDS. I turn the Main station off and on and then everything works fine. Nothing about my network set up has changed in months.

24in iMac - 2.4Ghz, Mac OS X (10.6), 4GB RAM
  • William Boyd, Jr. Level 6 Level 6 (10,515 points)
    Michael Duffy1 wrote:
    Since upgrading to Snow Leopard, I've had several instances where I woke up the machine and could not get on the internet. After 10 seconds or so, I get an error message which indicates that another device is using the IP address. The solution seems to be to reset my Airport.


    I don't have a suggestion for solving your problem, but until you can fix that, you may be able to avoid having to reset your AirPort unit with this procedure: (1) Launch System Preferences. (2) Select the "Network" panel. (3) Click on the "AirPort" item on the left. (4) Click the "Advanced" button. (5) Click on the "TCP/IP" tab. (6) Click the "Renew DHCP Lease" button.
  • Michael Duffy1 Level 1 Level 1 (140 points)
    Thanks for the suggestion. I actually gave that a try to no avail. Two other pieces of info:

    1. I have the AirPort in Bridge Mode, which is the default setting;

    2. I am excited about and have been trying to make use of the new 'wake on request' feature that allows you to access iTunes even when the computer is asleep. I do this via the iRemote app on my iPhone. I love the concept of not having to come into our home office and wake the iMac to listen to some music. However, I've found this feature buggy and relatively unreliable. (The iRemote often insists that the remote speakers -- on another AirPort -- are unavailable. When I walk in the office, they're fine.) I'm also suspicious that it is somehow related to this IP address issue.
  • William Boyd, Jr. Level 6 Level 6 (10,515 points)
    Michael Duffy1 wrote:
    1. I have the AirPort in Bridge Mode, which is the default setting;


    If you mean the "main" AirPort unit, then "Bridge Mode" is only appropriate if you have something "upstream" that's providing a DHCP function of distributing IP addresses. If your cable or DSL modem doesn't provide router functionality, then "Bridge Mode" is the wrong setting for that AirPort unit. In that case the proper setting is "Share a public IP address".
  • Michael Duffy1 Level 1 Level 1 (140 points)
    Yes, there is a router from between the main AirPort station and the internet.

    I have to do a little more playing around, but I'm pretty confident I can isolate it to the following. Wake up the machine via the iRemote app. Put it to sleep. On the next wake, this problem will present.

    I have one other AirPort Express. It's part of the WDS and provides music to our Living Room.

    Again, I think it's worth noting that everything has been working fine under this configuration for quite sometime. The only change is Snow Leopard.
  • Michael Duffy1 Level 1 Level 1 (140 points)
    Oh, one other thing... I checked the phone company's router page from my iPhone when the iMac was throwing this error. Interestingly, it indicated the IP address the iMac was referencing was INACTIVE. Which suggests, the issue rests with the iMac or the AirPort. Resetting the AirPort appears to reliably fix everything.
  • Michael Duffy1 Level 1 Level 1 (140 points)
    I have determined a workaround for these issues. I went into the router setup (for the phone company's router) and assigned a fixed IP address to both of the AirPort Express stations. After restarting them, everything is working. I haven't had any issues with the iMac saying that its IP address is being used and the wake via iRemote and connecting to our Living Room speakers via AirPort seems to work much better!
  • devonhub Level 1 Level 1 (10 points)
    fwiw, I'm not running Airport (or wireless) in bridge mode and I get the this "Another device using..." alert a couple times a day while running Snow Leopard. I'm using DHCP assignment. I am not encountering this error on other Macs in the house still running Leopard. If I reboot into Leopard on this same MacBookPro, I don't see the error all day. If I reboot into Snow Leopard, I'll see it within a couple hours.

    A bug report has been filed with Apple.

    Message was edited by: devonhub
  • Snoop Dogg Level 4 Level 4 (1,265 points)
    devonhub, do you have "Wake for network access" enabled in the Energy Saver prefs?
  • Michael Duffy1 Level 1 Level 1 (140 points)
    Since assigning fixed IP addresses via the router (for the Airports), I have not encountered this issue. However, I have had instances where iTunes was unable to connect to the my second AirPort Express and/or my iMac refused to wake on access from iRemote. Until I rebooted the 'Main' station, both of these problems persisted.
  • budgiegurl Level 1 Level 1 (0 points)
    I had this same error message occasionally when running Leopard, and I just got it for the first time on Snow Leopard. Although I have my Mac to wake up at a specific time, this message often occurs in the middle of the day, when no one else is in the house. It's definitely not a wake-up/sleep issue since it occurs when I'm actively working. Because I've had a cyberstalker, I thought at first it might indicate that someone had hacked into my machine, but I ran a demo of MacScan for Trojans, without any hits. Peripherals shouldn't create such an error message.

    Has anyone heard back from Apple about what this could be?
  • devonhub Level 1 Level 1 (10 points)
    Snoop Dogg, no, wake for network access is not turned on in power settings.
  • Christine Dattilo Level 1 Level 1 (0 points)
    We are having the same problem in our house since upgrading to Snow Leopard. My son's and husband's laptops get an error message saying another device is using the IP address. I have to go to the basement and reset the Airport Basestation. Works for awhile and then it happens again.

    Set-up: Verizon FIOS D-Link router/internet connection, Airport Extreme, 3 airport expresses, 2 laptops, 2 iphones. I'm using the Airport Expresses to extend the wireless network. I've tried renewing the DHCP lease - doesn't help.

    Any ideas on how to get this to stop happening?
  • William Boyd, Jr. Level 6 Level 6 (10,515 points)
    Christine Dattilo wrote:
    I have to go to the basement and reset the Airport Basestation.


    I don't have a solution to your main problem, but in AirPort Utility there's a "Restart" option under the "Base Station" menu. That might save you a trip to the basement.
  • davefwilson Level 1 Level 1 (0 points)
    I have the same exact problem, on various macs at various times. Anyone have a real fix?
Previous 1 2 3 Next