Previous 1 2 Next 25 Replies Latest reply: Nov 1, 2009 10:32 AM by wildcaver
jmkeegan Level 1 Level 1
After upgrading without any problems to Snow Leopard, Safari (Version 4.0.3 (6531.9)) won't connect to the standard Facebook login page: https://login.facebook.com/login.php

I get the error:
Safari can’t open the page.
Safari can’t open the page “https://login.facebook.com/login.php?login_attempt=1” because Safari can’t establish a secure connection to the server “login.facebook.com”.

It works fine in Firefox (and worked fine in Safari 10.5.8), so it's definitely a Safari/Snow Leopard issue.

I reset Safari, killed all of the Safari keychain items, and still nothing. I've seen similar complaints out there as well, but no solutions have worked for me. Anyone else?

iMac (9,1) 2.93/4gb, Mac OS X (10.6)
  • jmkeegan Level 1 Level 1
    And add to that Gmail....but not all https sites...Me.com works ok...
  • gvilleBAMA Level 1 Level 1
    I'm having the same issues...my itunes won't allow purchases either.
  • William Kucharski Level 6 Level 6
    expertise.macosx
    Mac OS X
    Works fine here…
  • gvilleBAMA Level 1 Level 1
    I found a solution to my problem.

    Restart your mac and boot to the snow leopard disk (hold the option key at startup until the boot device screen appears).

    One you get to the installation screen you have utilities at the top. Go to the one that says repair passwords. Select your user account and then at the bottom you'll see a button that says repair user permissions. Click this and then reboot. This fixed my problem.

    One way to see if this is your problem is to create a new user and login to that account and see if secure sites work on safari. If they do this should fix your issue.
  • JeridHill Level 1 Level 1
    Not sure where you are getting "repair passwords", is it repair disk? If so, that didn't work for me.
  • mileygwen125 Level 1 Level 1
    I am having the same problem with both safari and firefox I can sometimes get on but when I do I cant comment or do anything with out getting that error message. have u found a solution? This is ******* me off! all my other sites work
  • jmkeegan Level 1 Level 1
    OK I found a fix for this....Go to Utilities > Keychain Access. Keychain First Aid didn't work for me...but choose login from the "Keychains" sidebar, then select "VeriSign Class 3 Secure Server CA certificate". Right click on it and choose "Evaluate..." just use the default options, and it seemed to fix my problem..Hope this works for others!

    -Jon Keegan
  • fisheze Level 1 Level 1
    That didn't work for me. The only certificate that I found under Keychains is my mobileme. - Or perhaps I'm just looking too early in the morning.
  • JeridHill Level 1 Level 1
    Not sure if this worked for me or not either. But in order to find the certificate, in Keychain access, type in verisign in the search window within the Keychain Access window. It should come up.
  • jmkeegan Level 1 Level 1
    Also, I should note that I did boot up via my Snow Leopard DVD, and repair disk permissions first, which didn't list anything needing fixes...

    And I created another user from scratch, and that account didn't have the same problem...maybe just visiting a https site using the other user 'refreshed' or revalidated the certificates at the system level...who knows, but it worked...
    -Jon Keegan
  • JeridHill Level 1 Level 1
    Ok, just got the error again after your suggestion with the certificates. I had already repaired the disk and disk permissions. I can creating a new user, but that won't solve this current issue only isolate it to my current user.
  • mileygwen125 Level 1 Level 1
    this is one of the errors i keep getting on facebook through firefox
    Transport error (#1001) while retrieving data from endpoint `/ajax/updatestatus.php': A network error occurred. Check that you are connected to the internet.

    I cant even get on facebook or twitter on safari im am about to take out snow leopard and reinstall 10.5 cause im so sick of this! Anyone have a solution?
  • mileygwen125 Level 1 Level 1
    it didnt work for me either has anyone called apple do they know what the **** is the problem? All other sites work except facebook and twitter. they load sometimes but then lose connection. Cant comment on **** its so frustrating
  • robert meese Level 1 Level 1
    After installing SL, i cannot get wellsfargo "account login" to work for any account of mine, other financial secure sites work fine, i.e. fidelity or vanguard, I can access the main screen of wellsfargo but login fails ... screen i get says Safari can't connect to the server and as follows: "Safari can’t open the page “https://online.wellsfargo.com/das/cgi-bin/session.cgi?" plus some more gibberish stuff.... i tried switching to firefox and it works fine .... never had any trouble before ..... tried safari reset, safari empty cache, and maintenace that applied ...... still no luck!! hope they get this bug fixed , my other computer an older mac mini works fine. any help????? never had any problem before SL
Previous 1 2 Next