Previous 1 2 Next 20 Replies Latest reply: Jan 17, 2010 9:57 AM by tmaze
SparcUK Level 1 Level 1 (0 points)
Hey all,

I just had my motherboard replaced in my Macbook Pro. Since getting the laptop back I can no longer connect to my internet. When I check my network settings I see the following message attributed to my wifi connection

"Airport has self-assigned IP address and may not be able to connect to the internet"

When I then go into the TCP/IP panel I see DHCP is enabled but I have a weird address of 169.x.x.x (can't remember it exactly). God knows where that's coming from.

I tried renewing the DHCP lease. Rebooting my modem and router. Disabling and re-enabling the airport - all to no avail. At the moment the only way I can connect is to use a wired connection and set the IP address manually and also set the DNS to be my router's address.

Anyone got any ideas what the heck could be causing this?

Macbook Pro 17" (Santa Rosa model), Mac OS X (10.5)
  • Alexandre Level 3 Level 3 (850 points)
    Hiya SparcUK,

    what does your system preferences/network say?
    Is it padlocked? If so, unlock and also launch the "assist me" - but only launch it, do not do anything with it yet
    (if you're passworded, you need to enter the administrator password once, maybe twice).

    then try the DHCP reset or a modem restart - this normally makes the machine connect to the internet again. Any luck?
    Modem address is normally http://192.168.100.1/ and you can access this via your browser (but only once successfully connected)

    NB: sounds unscientific, but whenever I have connectivity issues (I assume your Mac recognises airport) this works a treat

    Message was edited by: Alexandre
  • SparcUK Level 1 Level 1 (0 points)
    Hi Alexandre! Thanks for your reply.

    To answer your questions:
    - my system network preferences are saying that it's a self assigned IP address with that weird 169 subnet address.
    - no, not padlocked. I've freely changed the settings
    - I've tried renewing the DHCP lease and also powering everything off, powering on the modem, then the router, then the laptop but the airport refuses to grab the lease.
    - Yup, I can connect to the router with no problems and all my settings in the router are fine (this HAS worked for 18 months, and also other wireless devices can connect the internet over it)
  • Alexandre Level 3 Level 3 (850 points)
    Hi SparcUK,

    mmh! What does Airport admin utility say? Some internet providers do not like airport sharing IP addresses.
    One thing, I must admit, Virgin sent me two new modems now to replace my old +Motorola surfboard+ which is "outdated"; none of the new modems successfully connect to airport! So I have gone back to my old modem and it works a treat.

    And did you connect the modem to the WAN socket (or the LAN) socket in airport? In the old (round, domed) one, it must go into the WAN socket. If you have a router, that needs to go into the LAN socket of airport.

    Any good?

    NB: You did try the old trick, shutting off the modem unplugging the ethernet cable from it, and then start the modem, waiting till the online light is on; only then connect the ethernet cable from modem to airport.
  • iskranik Level 1 Level 1 (0 points)
    Hi there,

    I have exactly the same problem with my brand new Macbook Pro (13'') running Snow Leopard (Airport self assigns an IP address and can not connect to the Internet). Have you found what was wrong with yours?

    The only thing I can add is that I have connectivity to Internet using RJ45 cable via the Ethernet port and I also have connectivity to other wireless networks such as BT Openzone using the Airport, but can not access the Internet using my own home wireless network. I also have a second Macbook at home (2.4Ghz processor, not Pro) running Mac OS 10.5.8, which can use the same wireless network for access to the Internet without any problems.

    This issue drives me mad... Could anybody help with advice please?

    Thanks,
  • CH.W.D.P Level 1 Level 1 (0 points)
    I have the same problem on 10.6 right now. It only happens when I try to connect to my Universities wifi though. At home I have zero problems. When I ran 10.5 I would occasionally have a self assigned IP address but it would usually sort itself out after a minute or so but now it refuses to get a proper address. All the suggestions I have found are to restart the router and what not but that obviously isn't an option since it is at school. Any body else have any other suggestions?
  • SparcUK Level 1 Level 1 (0 points)
    I ran mine over a fixed line for a few days. Tried today and it's working now. Haven't changed a thing. There is definitely a bug here somewhere but I suspect Apple don't really care about it given I was digging up articles on the net where people have been reporting this since Tiger.
  • rand8us Level 1 Level 1 (0 points)
    this is so strange. when i selected networking preferences, i noticed "megahoc.21" under the heading "device." i tried to delete it from my list of networks, it disappears for a moment but then reappears. i googled for it and found out that it is a viral SSIDs (?) and/or an adhoc network used for gaming. can anyone please please give insight as to how to get rid of this? thank you.
  • CH.W.D.P Level 1 Level 1 (0 points)
    I wish plugging my computer in for a bit was an option but I do now know anywhere on campus where they have plugins, the whole place is wireless. There has to be some sort of fix for this. Pretty ridiculous that Apple hasn't addressed this issue since 10.3 in my opinion.
  • [Nicap] Level 1 Level 1 (0 points)
    After hours of messing with this I think (and hope) I have found a solution.

    I have found that *disabling my Macintosh FIREWALL* from my system prefs caused my wireless card to pull the correct IP information and I was able to access the internet again. Once the correct address is obtained I just re-enable the firewall. It's an annoying step but not as annoying as a life with out wireless access. I hope this helps someone out their.
  • grpgrpgrp Level 1 Level 1 (0 points)
    Thanks, Nicap, that worked perfectly.

    Last night I started seeing some DNS issues (sites I had already been using still worked but not new ones, etc). So I decided to run Software Update to pick up the 10.5.8 update it had been bugging me about.

    After this I was unable to connect to any network server, yet I could see all the wireless SSIDs around me, so I knew the wireless wasn't totally shot.

    After finding your message, I went to System Prefs > Network and set the Firewall to "Allow all incoming connections". In a background window, I could see the network immediately connecting, and then I could re-enable the firewall.

    My firewall settings before this were "set access for specific services and applications” which I had set a month ago, so odd that it finally showed up now. Perhaps the 10.5.8 update triggered something??

    Apple, you should include a firewall check in the Network Diagnostics.
  • DE88 Level 1 Level 1 (0 points)
    I've had the same problem. Saw this on another forum:
    1. Go to Mac/Library/Preferences/SystemConfiguration
    2. Delete the following:
    a. Com.apple.airport.prefrences.plist
    b. NetworkInterfaces.plist
    c. Preferences.plist
    3.Shut down computer
    4.reset PRAM
  • jmcdaid Level 1 Level 1 (0 points)
    Thanks, Nicap -- "allow all incoming connections" solved my problem as well!
  • SheriVan Level 1 Level 1 (15 points)
    I have had this same problem off and on. The quickest fix has been to "allow all incoming connections." As soon as my IP address goes back to normal, I again check "Set access for specific services and applications" and I'm good to go. I prefer not to always allow all incoming connections, and this seems to work fine (until I get another self-assigned IP address).
  • lmilne Level 1 Level 1 (0 points)
    After hours of messing with this problem, I thankfully found your message, Nicap. Thanks to you and the others who confirmed that your solution works. It did for me!

    BTW, the Mac that had the problem (an iBook G4) was the ONLY one of four computers and two iPods in the house which suddenly developed the inability to connect, and displayed a 169..*. IP.

    Last thing we were doing on the iBook was running hulu.
Previous 1 2 Next