Previous 1 3 4 5 6 7 Next 525 Replies Latest reply: Nov 3, 2010 9:22 AM by @martinlabelle Go to original post
  • Dan Andersen Level 1 (15 points)
    I can confirm that turning off the sudden motion sensor does not resolve the issue. It makes the clunking with every slightest move go away, but the maddening pauses still exist.
  • jhaynie Level 1 (0 points)
    I have the same problem. Brand new MacBook Pro with Snow Leopard 10.6.1. Random hangs for up to 30 seconds many times per hour. VERY FRUSTRATING. My previous MBP + Leopard never had any issues.
  • pingudownunder Level 1 (0 points)
    I cloned the working 5400rpm back to the 7200rpm drive - so its an exact copy - and got the lockups back again.

    Triple-checked for SMART errors with SMARTUtility (or whatever its called) and came up clean. Both are Seagate Momentus .4s (the AS model, not the ASG model).

    So at least in my case, downgrading to 5400rpm fixed the issue. This obviously isn't good and needs to be fixed by Apple. Will report as a bug.
  • pingudownunder Level 1 (0 points)
    Disabling the Sudden Motion Sensor had no effect on mine.
  • dlethe Level 1 (0 points)
    I have a fix ... at least it worked for me. I was averaging a 10-30 sec lockup approx every 2 hours of usage. After doing this, zero lockups after 3 days solid use.

    My system is a 17" MBP, latest version.

    1. Repair permissions
    2. Shut system down.
    3. on power-up, click and hold down option-command-R-P after you hear the 1st beep. Keep holding it through two beeps then release.
  • DrewS Level 1 (10 points)
    Had the same issue, very frustrating.

    Kill all your non-standard Safari plugins. For me it seems to have been ClickToFlash plugin, but deleting that plugin solved my (30x or more per day) lockups completely.

    I love that plugin, but not at the current cost with SL.
  • DrewS Level 1 (10 points)
    Sorry, to be more generic, not Safari plugins, but "Internet Plugins" from the root and home directory Library locations, which are maybe(?) used also by Firefox. Anyway, these plugins are definitely used by other Apple apps and deleting them has kept me from a lockup for more than a day now, where I had them a couple times an hour before in normal use.
  • csnook Level 1 (0 points)
    This seems to happen a little more with FileVault enabled, probably due to more expensive pageout to free memory, but it definitely happens either way. I had no such problems with Leopard. I'm not using Safari at all, but I think Adium is using WebKit. It usually happens while I'm using a large memory application (Firefox or VirtualBox), and often starts with the trackpad ceasing to respond in one Firefox tab. Sometimes all of Firefox hangs, and sometimes I can't even switch spaces. I've tried running top while Firefox is hanging, but top doesn't seem to launch until the hang is over.

    Is there any kind of diagnostic data I can collect? In Linux I'd use sysrq, but I'm not aware of OS X having any similar facility.
  • dukemeiser Level 1 (5 points)
    Same here: SMS disabled did not help.

    Running Safari in 32bit mode does not help.

    Will try zapping PRAM as suggested...
  • Arne200_2 Level 1 (0 points)
    I am experiencing the same issue, it has been driving me mad. I even did a complete restore from a Time Machine backup of two days back, before the freezing became chronic, to make sure I did not cause it by installing something or accidental deletion. To no avail. while writing this response, I got a freeze again.

    I was going to do a clean re-install, but judging from the posts it seem it will not solve the problem. It is the first time since using Mac that my trust in OS X has been shaken.

    I have noticed that my hard drive makes a scratching type of noise lasting 4-5 seconds - a sound it never used to make. (it is not the faint cluck sound when moving the machine suddenly)

    My wife's MacBook doen't seem to have any of these problems after upgrading. Will keep trying to find a solution - uninstalling stuff etc.
  • Ed Grimley Level 1 (0 points)
    I, too, am having this problem with my MacBook Pro 13" on 10.6 and 10.6.1.

    Removing all my Internet Plugins (except Quicktime and Flash) did not help. I don't have FileVault enabled. I have tried Repair Disk Permissions, and that seemed to help, but the problem soon returned. This morning, it happened when running Opera (Safari was not loaded) and iTunes (and Caffeine, Peer Guardian, and Audio Scrobbler). I have been trying to track down an offending process or plugin, but have been unsuccessful. However, I ran hang-free for a few hours with no internet browser. I never had this problem with 10.5.

    Really wish Apple would get on the ball and fix this. It's a big issue and it is making me regret the OS upgrade.

    Message was edited by: Ed Grimley
  • dlethe Level 1 (0 points)
    I have a fix ... at least it worked for me. I was averaging a 10-30 sec lockup approx every 2 hours of usage. After doing this, zero lockups after 3 days solid use.

    My system is a 17" MBP, latest version.

    1. Repair permissions
    2. Shut system down.
    3. on power-up, click and hold down option-command-R-P after you hear the 1st beep. Keep holding it through two beeps then release.
  • Carl.Walker Level 1 (0 points)

    I can confirm that the below works. I followed this prescription last night and the freezing has gone away. Previously, I could self-generate the freezing issue under load, especially noticeable when playing video or music. Now, nothing. I have played a video from YouTube while playing a movie in iTunes while doing a 1GB file copy from a Windows 7 VM to the OSX desktop, not a snifter of a pause and no dirty little beach ball. The machine has performed seamlessly all day despite constant use, something utterly unthinkable previously.

    It's a bit annoying that Apple put the update out in the first place, and that the firmware regression is a reduction in functionality, however, I'm not using an SSD drive so I won't miss the speed, plus, now my Mac works! Finally, shame on Apple for not making this fix more widely available, my local Apple store didn't have a clue what I was talking about. Genius? I don't think so, pal.

    I am confident this will fix the 30 second freeze issue, fully and permanently.

    CAVEAT: I did notice that some people on YouTube were having freeze issues which affected their screen; a total lockup. To be clear, this was not my symptom; my machine would lock for 20-30 seconds, the mouse would move but that's it, the clock stopped and all button presses were futile. On resume, all buffered key presses would be performed and the machine would return to function. I can only say that this fix solved that particular issue for me.

    Also, if you're not sure, don't do it, remember, this is done at your own risk, if it fails, that's an awfully expensive table mat you're looking at.

    One last thing; after completing the fix DON'T RE-INSTALL THE 1.7 FIRMWARE UPGRADE! You can choose to ignore the upgrade so it doesn't try to reinstall itself again. Run the Software Update Tool, choose the update, then, on the "Updates" menu option select "Ignore Update" and click OK on the resulting box. (Sorry if this is egg sucking material for you guys, I didn't know this so I figured maybe others might not either).

    This was originally posted by Panzo here;


    1) Download the linked .dmg file.

    2) Do not mount file

    3) Plug in a usb drive of any size, (the files in the .dmg are small enough to fix on any memory stick).

    4) Reformat this USB drive in Mac OSX HFS+ Journaled in disk utility.

    5) Click on the newly formatted drive Volume, then click on the tab restore (same row as erase).

    6) in this panel you will see two white input boxes, in source you will browse and select the .dmg downloaded in step 1, you can either browse it or drag and drop it in the source box.

    7) in the Destination box, drag and drop the newly formatted Volume from step 4/5

    * no need to have the erase destination box checked/ticked.

    8) hit the restore button/

    9) once this is done, unplug and replug the usb drive, shut down the machine

    10) boot up the machine while its booting up, before the apple icon pops up, press and hold the OPTION button, (on my machine it was the ALT button - CARL), until your drives/partitions pop up.

    11) in my case i had three pop up, my bootcamp partition my main mac harddrive, and the BOOTABLE USB drive i just made, select the bootable USB drive. Use Arrows to navigate and Enter button to select

    12) once this is selected the apple logo will come up and a dark gray bar will start to move right under it. Sit relax and wait for the process to be done. (Only took a couple of minutes on my Mac - CARL)

    END: you have now downgraded to EFI firmware 1.6
  • sas71 Level 1 (0 points)
    I don't know... reverting firmware with a dmg from an anonymous source doesn't exactly give me warm and fuzzy feelings inside... I think I can suffer the hangs until there's an official response.
  • dlethe Level 1 (0 points)
    The solution I posted came directly from applecare support. Now on my 4th day, ZERO lockups. I should have had at least a dozen by now.
Previous 1 3 4 5 6 7 Next