1 2 3 4 Previous Next 53 Replies Latest reply: Oct 22, 2010 1:57 AM by danile
BeSharp Level 1 Level 1 (15 points)
We are using Apple Mail 4.0 (Snow Leopard release) with Exchange 2007. Almost everything works like a charm except when we try to send attachments which are bigger than (estimated) 4 MB.

We can exclude an issue with our Exchange setup as even attachments larger than 100 MB work if sent via Entourage.

Mail's Activity Viewer indicates

Sending message
Adding messages

with the blue progress bar animated but not finishing for hours.

If anybody has any hints how to resolve – or further troubleshoot – the situation, that would be greatly appreciated.

Best,
-Ralf

MacBook Pro (Unibody), iMac, Mac OS X (10.5.7), iPhone 3GS 32GB, iPhone 3G 16GB, iPhone 16GB (all on OS 3.0)
  • 1. Re: Mail 4.0 (Snow Leopard) not sending "bigger" attachments Exchange 2007
    doctormidnight Level 1 Level 1 (0 points)
    We are seeing the same problem here - large attachments are almost impossible to send - the Sending Messages - Adding message bar goes on and on forever it seems.

    We are connecting to a hosted Exchange Server and everything has worked perfectly except sending large attachments.
  • 2. Re: Mail 4.0 (Snow Leopard) not sending "bigger" attachments Exchange 2007
    BeSharp Level 1 Level 1 (15 points)
    It's a nightmare. We don't want to revert back to Entourage (or go for Microsoft's Outlook for the Mac). Exchange support was one of the key features to migrate to Snow Leopard.

    Any idea how to fix – or if not fix, how to further troubleshoot?

    Best,
    -Ralf
  • 3. Re: Mail 4.0 (Snow Leopard) not sending "bigger" attachments Exchange 2007
    doctormidnight Level 1 Level 1 (0 points)
    No. I can find no setting in the mail application to adjust to fix this. We also use a hosted exchange server and I looked through the available settings there and found nothing that I could adjust that would potentially change the situation. We have a limit set on the size of attachments of 50 MB that can be sent or received. However, our problems have been with files in the 4 to 5 MB in size.

    mark
  • 4. Re: Mail 4.0 (Snow Leopard) not sending "bigger" attachments Exchange 2007
    BeSharp Level 1 Level 1 (15 points)
    We are on hosted Exchange, too. Did you try with Entourage? It works fine with Entourage for us. But hey, we wanted to get rid of Entourage...
  • 5. Re: Mail 4.0 (Snow Leopard) not sending "bigger" attachments Exchange 2007
    maxcasal Level 1 Level 1 (35 points)
    Same problem here.
    I hope for a fix in 10.6.1
  • 6. Re: Mail 4.0 (Snow Leopard) not sending "bigger" attachments Exchange 2007
    Ferguson20 Level 1 Level 1 (0 points)
    I just got off the phone with Apple support about the same issue. They told me that Mail only sends up to 20MB. I don't know how much I can/can't send except my attachments that are 15-30MB won't send out. I set up my Entourage account again and checked to see if I could send there and I could.

    Apple support said they didn't know if this would be fixed or not. I can't believe that they wouldn't fix this issue as most Exchange users are going to be working with big attachments etc.
  • 7. Re: Mail 4.0 (Snow Leopard) not sending "bigger" attachments Exchange 2007
    goodape Level 1 Level 1 (5 points)
    I don't think this is related to Exchange. I get the same problem on an IMAP server. Sending, forwarding, or refiling mails with large attachments (over about 2MB) is bringing the whole system to a crawl. It does complete the job, but it takes a long time.
  • 8. Re: Mail 4.0 (Snow Leopard) not sending "bigger" attachments Exchange 2007
    Ferguson20 Level 1 Level 1 (0 points)
    I agree.....this is a Mail, not an Exchange issue. It just frustrates me that Apple would put out a solution to Entourage without looking at how much their Mail program can send out. As of now, I see no benefits from switching to Snow Leopard what so ever. Everything that is offered in Mail, Contacts and iCal are offered in MS Entourage. Am I missing something here?
  • 9. Re: Mail 4.0 (Snow Leopard) not sending "bigger" attachments Exchange 2007
    AlexLB Level 1 Level 1 (0 points)
    Two issues here. First, there is a separate setting in Exchange for EWS max attachment size. (And there is yet another one for OWA.) So be sure this has been set to >5 MB. By default it is set at 5 MB. I think Exchange admins everywhere are suddenly discovering this setting.

    There are other threads here on this topic, see this:
    http://discussions.apple.com/thread.jspa?messageID=10185032&#10185032

    Now, that being said, that doesn't solve the other problem here. With large attachments, Mail is very slow to send and I end up with failures with large attachments often. The same problem is happening with Entourage Web Services Edition so it appears to be an EWS problem but I'm not sure what yet. To be clear, sometimes these messages go through, so it is not the attachment size limit.

    -- Alex
  • 10. Re: Mail 4.0 (Snow Leopard) not sending "bigger" attachments Exchange 2007
    Ferguson20 Level 1 Level 1 (0 points)
    Cheers Alex. I checked everything on my end and it's set properly. I am now back to using Entourage 2007 and I have been sending out 25MB+ attachments via my company's exchange just fine these past three days.
  • 11. Re: Mail 4.0 (Snow Leopard) not sending "bigger" attachments... MailTags?
    UserAldan Level 1 Level 1 (0 points)
    Same problem: any attachment > 1 or 2 MB brings the system to its knees right at the stage when the status screen displays "Adding Message". Even after forcing Mail to quit, it takes a while for the system to "pick up" its former speed. Not using Exchange 2007, or experiencing any issues with the Address Books as discussed in some threads (though I did clean .adbcd files, just in case).

    I've just tried disabling all my mail bundles (MailUnreadMenu and MailTags) and bringing them up one at a time, while sending a 4 MB message in between. The problem disappeared instantly, and came back when MailTags (compatibility release 2 for SL from Sep 8) was turned back on. Anyone using MailTags?
  • 12. Re: Mail 4.0 (Snow Leopard) not sending "bigger" attachments... MailTags?
    BeSharp Level 1 Level 1 (15 points)
    How did you do this? Could you perhaps explain so that other can try, too? Still having the problem here with almost EVERY attachment > 2 MB. (Sending attachments > 30 MB perfectly fine from Entourage though.)
  • 13. Re: Mail 4.0 (Snow Leopard) not sending "bigger" attachments... MailTags?
    UserAldan Level 1 Level 1 (0 points)
    In ~/Library/Mail there's a folder called "Bundles" containing "MilTags Extras" and "MailTags.mailbundle" (provided you have MailTags installed). MailUnreadMenu, and other bundles, if you're using any, would be sitting there two.

    Create another folder nearby, e.g. "~/Library/Mail/Bundles (disabled)" (in fact, it may already exist there); the name does not really matter - just some other folder. Quit Mail and drag the aforementioned two MailTags items (and/or files belonging to other Bundles) into "disabled" folder. Restart Mail.

    If you need to re-enable a Bundle simply move the corresponding files back into "Bundles". As far as MailTags are concerned all the tag data will be preserved, only tags won't be, of course, updated or searchable while disabled.
  • 14. Re: Mail 4.0 (Snow Leopard) not sending "bigger" attachments Exchange 2007
    BeSharp Level 1 Level 1 (15 points)
    Here's an update on the subject:

    As some other sources pointed out that there are separate settings for Exchange Web Services maximum attachment file size, I've escalated the issue to our Exchange hosting provider. I've today received the following confirmation:

    For OWA, MAP and EWS (EWS is the method, Apple Mail uses to communicate to Exchange) the maximum attachment size is configured to be 50 MB.

    So I can definitely exclude a mis-configured Exchange server being the cause for Apple Mail failing to send attachments > 3 MB.

    I've switched back to Entourage as I can no longer afford to not getting documents out to my clients. This is pretty poor delivery for something considered a key feature of Snow Leopard.
1 2 3 4 Previous Next