Previous 1 16 17 18 19 20 Next 288 Replies Latest reply: Jan 8, 2011 3:25 PM by UFGUY Go to original post
  • KenWhite Level 1 Level 1 (0 points)
    Around 50% of sync between my
    iPhone and iTunes result in my iPhone telling me it has no content.

    That's all fine if I realise before I disconnect my phone and go to work, but it ***** if I forget to check.

    This has been a problem for over a year for me.

    Shame on you, apple!
  • quasidemo Level 1 Level 1 (0 points)
    Thanks for this tip. It worked on iTunes10 and iOS4.0.1.
  • Level 1 Level 1 (0 points)
    I have found the answer for my iPhone 3gs that would "no content" after every sync.

    I have to turn off my firewall "Zone Alarm" and shut off my antivirus "Antivir" in order to sync.

    As soon as I do those two things it fixes it and my library returns every time. I believe that it's only the PC/Host based firewall that is blocking a critical service for sync. I just cant figure out why Apple needs my firewall off in order to sync over USB.

    No wonder they don't want to fix this one or answer the questions on it....

    Bobby, DRM is the devil!
  • Level 1 Level 1 (0 points)
    Even the BBS is buggy. It just made me double post.

    Message was edited by:
  • griga Level 1 Level 1 (0 points)
    Take IT easy guys.

    At least if you run 4.2.1 on iPhone 4 - just restart the springboard by changing system language to other than English, then open iPod and wait. Then change the language back

  • Jamon2k Level 1 Level 1 (0 points)
    This worked perfectly! Thank you!
  • Elfqueen Level 1 Level 1 (0 points)
    I was having the same problem. I even unchecked both podcasts and music for sincing then reloaded them again and it didn't work. Then I noticed that the podcast button wasn't on the bottom of the player and the "more" button didn't work; which would allow me to get to it. So I tried one more thing. I reconnected my iphone and let it sync again. Then in the divice area I unchecked the podcasts all by themselves and synced again. And low and behold I got all my songs back. I don't know why it worked when I did it by itself and not with the songs too but it did. I'll try to put my podcasts on later, after i move the podcast button to the bottom.
  • griga Level 1 Level 1 (0 points)
    The recipie for 'no content' error:

    Check how much free space you have on your device in settings -) general -) about.

    If you see that something is taking up the space - it's obviously your media library. Meaning that the library is physically on device but there has been an indexing error after sync. We don't care about the reason for this. We just need to rebuild the index. Do it by restarting the springboard, see my post above.

    If you got nothing or only part of your music syncs, make sure you checked out 'sync only checked items' flag on information tab of iTunes. Or mark/check all your content with checkbox.
  • MerlinK67 Level 1 Level 1 (0 points)
    Changing language for English to another language and back fixed it for me.
  • NYCJoePitt Level 1 Level 1 (0 points)
    Same here! I had never seen this horrible problem before. I went to -Settings -General -International -Language and switched to Spanish on my iPhone. Then I switched it back to English. And then the iPod library was rebuilt automatically on my iPhone, yay!
  • Elfqueen Level 1 Level 1 (0 points)
    This is really getting anoying. I've reset to factory settings 3 times and rolled back to prior versions 2x and still keep getting this problem. It'll work for a wile but then go back to the no content problem. Or it will show my songs and even try to play them but stop and go back to the list of songs before even one note plays. I've done the language trick 2x. Is it just me? Nothing seems to work perm. Think I have a defective phone?
  • griga Level 1 Level 1 (0 points)
    Technically nothing can be defective in the hardware - otherwise the device would not operate at all. There seems to be a software problem. If you see the library but it doesn't play - it's obviously not a indexing issue.. looks like a file system problem when iPad app requests a file but does not receive it or has codec conflict. Sure your files play fine on the PC and are correctly named/ don't have bizzar characters in lyrics field, etc ?
  • Elfqueen Level 1 Level 1 (0 points)
    well at least I know it isn't a hardware problem. thanks. but these songs have all been on the iphone before. I don't know why but now if I try to transfer more than a few songs or if for some reason it can't sink 1 song then they all go bad. I had the current list of songs on the phone for a week & working before I tried to add my big play list. Then I got this problem ^ and none will play. It started after the last update. Guess I'll have to wait for the next update and hope it goes away perm.
  • MacKingMan Level 1 Level 1 (0 points)
    I've tried what you've suggested in your earlier post (changing the language settings, then attempting to run ipod, waiting, and reverting back to English) but it didn't work... Nevertheless, I've got two iPhones, a 3GS (Verion 4.1) and the newer model running version 4.2.1. I've never received the "No Content" message on my iPhone 4 yet, but I've received it several times on my 3GS, since it's the phone I sync daily; adding music & videos on it for my Wife who's currently in Haiti.

    The only thing that does seem to work is going into iTunes, then clicking on my iPhone's music section and randomly playing a song, then ejecting... and Voila! all my songs & videos are back...

    My biggest worry though is that my wife may receive this "No Content" message while the phone is in Haiti, and she may not be able to find a PC to get it fix...

    I thought about upgrading to version 4.2.1 on my 3GS, but read somewhere else online that 4.2 isn't bullet proof, and that the message may still appear.

    So here's my question to you guys on this forum: Do you NORMALLY/ONLY receive this message after syncing, or does it appear randomly? Like while you're at the gym, or after your iPod/iPhone has been idle for months, without syncing?
  • Elfqueen Level 1 Level 1 (0 points)
    This only happens after syncing. And only after an unsuccessful sync. I tried a new solution today that so far seems to be working. I reset the phone to factory settings and instead of restoring from a back up (which might just install the bad software glitch back on) I set it up as a new iphone. I then set up NOT to sync automatically so that I have more control over what went on the phone. I then set the phone to sync all music manually. Then being careful to chose only songs that didn't have any characters other than letters (ie ?*&) in the song title or removing them from the title first. Then I synced only individual albums are small play lists and not big batches and waited till the current album was finished before adding more. Since this problem only happens after a bad sync so far I'm able to listen to all 50 songs I added to my phone.