1 2 3 Previous Next 32 Replies Latest reply: Nov 2, 2010 12:42 AM by Varun Joshi Go to original post
  • 15. Re: Error -9812 and -1202
    pauljd1964 Level 1 Level 1 (0 points)
    Many thanks, had error -1202 unable to access redeem link in quick links on itunes home page, apple email support no good, followed advice below to check pc's date and time re-set to correct date-problem solved.Can now enjoy my itunes gift card.Thanks so much for posting help.
  • 16. Re: Error -9812 and -1202
    people who know what to do Level 1 Level 1 (0 points)
    thank you so much right clicking help me so much yay
  • 17. Re: Error -9812 and -1202
    grimes7 Level 1 Level 1 (0 points)
    I'm not whiz at this either, but I was able to fix my -9812 error. I'm running a Dell XPS with Windows Vista.
    The first thing I did (based on discussion suggestion a few weeks ago) was to go into other suggestion:
    Tools
    Internet options
    advanced
    under security settings, make sure "check for server certificate revocation" is de-selected.
    Doing that first didn't work, but then I downloaded the file he suggested, and all is good now.
    If just the file download doesn't work, do both. Hope it helps.
  • 18. Re: Error -9812 and -1202
    tm0713 Level 1 Level 1 (0 points)
    "I got around the 1202 error with a pretty easy fix. Right click on "redeem" on the itunes home page. It will give you a choice to open or copy - choose "copy this link". Then paste it into a new internet explorer window. Accept the security prompt then it should load up the space to put your code in."

    I did this one and it worked for me. Try it.
  • 19. Re: Error -9812 and -1202
    drjadrake Level 1 Level 1 (0 points)
    Thanks!!!
    After many hours of looking for a fix to the 1202 error, I was able to get around it by Right clicking the redeem button, copying the link and pasting it in a new explorer page.

    Still curious as to why I still cant left click the redeem button?
  • 20. Re: Error -9812 and -1202
    Nickee Level 1 Level 1 (0 points)
    Funny! I've been having this problem for weeks. Today I had time to sit down and try to solve it. I come here to whinge and it suddenly decides to work! Typical!

    I was coming to also complain that I couldn't get the 'right-click' on Redeem option to work

    Message was edited by: Nickee
  • 21. Re: Error -9812 and -1202
    jimmyblake Level 1 Level 1 (0 points)
    I am getting -9812 and -1202 errors whenever I try and purchase anything or access my accounts page. I am, however, using Mac OS and only getting the issue on a specific machine. Anybody been able to resolve this on a Mac?

    Jimmy
  • 22. Re: Error -9812 and -1202
    dramaqueen5 Level 1 Level 1 (0 points)
    i have the same problem :/

    i have tried every solution on this page and im still getting the 1202 error when i click redeem

    ive done a diagnosis and it says it something to do with internet connection which is even more confusing!

    anyone know what to do about this?
  • 23. Re: Error -9812 and -1202
    Amandaz2006 Level 1 Level 1 (0 points)
    I had this same issue on the Mac (which seemed weird because it appeared that everyone had the issue on a PC). In order to fix it, I tried all sorts of things, such as rebooting, removing plist files, reinstalling itunes, etc. However, the thing that worked was removing all of the saved data in my keychain. Once I clicked "Reset My Default Keychain" iTunes didn't give me the error. I didn't even have to restart. It was pretty much automatically fixed! That was definitely easier than all the work I did to get to that point.
  • 24. Re: Error -9812 and -1202
    thebeee Level 1 Level 1 (0 points)
    THANK YOU SOO MUCH. I can say i almost killed my self after sitting 10 hours with this f**ing problem, and it was the bl**dy date that was incorrect?? it stood on 16 of july instead of 19 of june... you who have this problem CHECK YOU'RE DATE!
  • 25. Re: Error -9812 and -1202
    hibeam Level 1 Level 1 (0 points)
    Was installing iOS 4 on my iPhone 3; when it went to complete the install, the process stopped, with the image of the globe and USB cable appearing on the phone, and the error -9812 appearing on iTunes (Windows XP SP3).

    Thank you all for posting here! The Windows Certificate update fixed the problem. Mystery solved!
  • 26. Re: Error -9812 and -1202
    luexcriticism Level 1 Level 1 (0 points)
    I don't normally ever respond to thread solutions like this, but this really worked and saved my butt.
    Thank You!
  • 27. Re: Error -9812 and -1202
    umno1215 Level 1 Level 1 (0 points)
    Your first solution - update root certificates - worked for me; almost a year after you posted it, it is still good as gold. I would love to know how you thought of this!
  • 28. Re: Error -9812 and -1202
    Barb Hughes Level 1 Level 1 (0 points)
    I also have the code 1202 on WIndows Vista! I did all the security steps, and checked time zone. and it still wont work! also right clicked on redeem coupon to copy and open in another page..to no avail...any suggestions? help?
    thank you!!
  • 29. Re: Error -9812 and -1202
    David Lees1 Level 1 Level 1 (5 points)
    This worked for me. Apply the root cert updates from M$ and then logoff, log back on and it all worked fine. I might also add that I ran a batch file to help with my syncing problems (huge library)

    net stop "Apple Mobile Device"
    net stop "iPod Service"
    net start "iPod Service"
    net start "Apple Mobile Device"